Christopher Baines wrote 6 years ago
(address . bug-guix@gnu.org)
I'm loosing track of this issue a bit, as I've been dealing with it for
a while. I have a machine that I've setup where /gnu/store is a btrfs
subvolume. I do this so that I can make flexible use of the space on
that btrfs filesystem.
Unfortunately, the grub configuration generated for this doesn't seem to
account for this, and so it requires some tweaking to get it to boot.
A long while back, I discovered I could make the following change, then
the generated grub configuration would be fine.
---
gnu/bootloader/grub.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (15 lines)
diff --git a/gnu/bootloader/grub.scm b/gnu/bootloader/grub.scm
index 06856dd58c..c3ddc3e128 100644
--- a/gnu/bootloader/grub.scm
+++ b/gnu/bootloader/grub.scm
@@ -320,8 +320,8 @@ entries corresponding to old generations of the system."
;; Use the right file names for KERNEL and INITRD in case
;; DEVICE-MOUNT-POINT is not "/", meaning that the store is on a
;; separate partition.
- (let ((kernel (strip-mount-point device-mount-point kernel))
- (initrd (strip-mount-point device-mount-point initrd)))
+ (let ((kernel kernel)
+ (initrd initrd))
#~(format port "menuentry ~s {
~a
linux ~a ~a
--
2.19.2
Unfortunately, it's not a proper solution, as it obviously breaks when
you actually want to strip the mount point off so that grub can find the
right files.
I'm creating a bug for this, as I think it would be good to track the
issue. I've also written a system test that I believe reproduced the
issue.
From 7eee5685f95d0b6baeb97f5fdd947fe5223a61c9 Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Fri, 26 Oct 2018 18:48:32 +0100
Subject: [PATCH] WIP Btrfs store subvolume test
---
gnu/tests/install.scm | 91 ++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 90 insertions(+), 1 deletion(-)
Toggle diff (109 lines)
diff --git a/gnu/tests/install.scm b/gnu/tests/install.scm
index 4764ffffde..cfa071187c 100644
--- a/gnu/tests/install.scm
+++ b/gnu/tests/install.scm
@@ -43,7 +43,8 @@
%test-separate-home-os
%test-raid-root-os
%test-encrypted-os
- %test-btrfs-root-os))
+ %test-btrfs-root-os
+ %test-btrfs-root-with-store-subvolume-os))
;;; Commentary:
;;;
@@ -826,4 +827,92 @@ build (current-guix) and then store a couple of full system images.")
(command (qemu-command/writable-image image)))
(run-basic-test %btrfs-root-os command "btrfs-root-os")))))
+
+;;;
+;;; Btrfs root file system with store subvolume.
+;;;
+
+(define-os-with-source (%btrfs-root-with-store-subvolume-os
+ %btrfs-root-with-store-subvolume-os-source)
+ ;; The OS we want to install.
+ (use-modules (gnu) (gnu tests) (srfi srfi-1))
+
+ (operating-system
+ (host-name "liberigilo")
+ (timezone "Europe/Paris")
+ (locale "en_US.UTF-8")
+
+ (bootloader (bootloader-configuration
+ (bootloader grub-bootloader)
+ (target "/dev/vdb")))
+ (kernel-arguments '("console=ttyS0"))
+ (file-systems (cons* (file-system
+ (device (file-system-label "my-root"))
+ (mount-point "/")
+ (type "btrfs"))
+ (file-system
+ (device (file-system-label "my-root"))
+ (mount-point "/gnu/store")
+ (type "btrfs")
+ (options "subvol=/gnu/store"))
+ %base-file-systems))
+ (users (cons (user-account
+ (name "charlie")
+ (group "users")
+ (home-directory "/home/charlie")
+ (supplementary-groups '("wheel" "audio" "video")))
+ %base-user-accounts))
+ (services (cons (service marionette-service-type
+ (marionette-configuration
+ (imported-modules '((gnu services herd)
+ (guix combinators)))))
+ %base-services))))
+
+(define %btrfs-root-with-store-subvolume-installation-script
+ ;; Shell script of a simple installation.
+ "\
+. /etc/profile
+set -e -x
+guix --version
+
+export GUIX_BUILD_OPTIONS=--no-grafts
+ls -l /run/current-system/gc-roots
+parted --script /dev/vdb mklabel gpt \\
+ mkpart primary ext2 1M 3M \\
+ mkpart primary ext2 3M 2G \\
+ set 1 boot on \\
+ set 1 bios_grub on
+mkfs.btrfs -L my-root /dev/vdb2
+mount /dev/vdb2 /mnt
+btrfs subvolume create /mnt/home
+mkdir /mnt/gnu
+btrfs subvolume create /mnt/gnu/store
+herd start cow-store /mnt
+mkdir /mnt/etc
+cp /etc/target-config.scm /mnt/etc/config.scm
+guix system build /mnt/etc/config.scm
+guix system init /mnt/etc/config.scm /mnt --no-substitutes
+sync
+reboot\n")
+
+(define %test-btrfs-root-with-store-subvolume-os
+ (system-test
+ (name "btrfs-root-with-store-subvolume-os")
+ (description
+ "Test basic functionality of an OS installed like one would do by hand.
+This test is expensive in terms of CPU and storage usage since we need to
+build (current-guix) and then store a couple of full system images.")
+ (value
+ (mlet* %store-monad
+ ((image (run-install
+ %btrfs-root-with-store-subvolume-os
+ %btrfs-root-with-store-subvolume-os-source
+ #:script
+ %btrfs-root-with-store-subvolume-installation-script))
+
+ (command (qemu-command/writable-image image)))
+ (run-basic-test %btrfs-root-with-store-subvolume-os
+ command
+ "btrfs-root-with-store-subvolume-os")))))
+
;;; install.scm ends here
--
2.19.2
It would be good if a way could be found to make this "just work". I
just don't know whether the best way to do that is tweaking the way Guix
generates the grub configuration to be aware of the odd mounting, or
somehow making grub find things in the subvolume, or something else.
Thanks,
Chris
-----BEGIN PGP SIGNATURE-----
iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlv8V05fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xdlog//WFBd/LdzhI11lOnfHmS4uVxoAGC5MzZJ6nvThjzrZLxmPVbezYTOnU27
1ye73COsNLFD9I+YO30PcTxXz5fJbe0oOELrHIbb/dfk4tJ3vpR6M3kiWu6DRs2e
Nr4+g6KS65oPAgyTp2O3t3NPAWC0pLlSx644ABu1IoGr7/EgsPuZ4F536nNw51zO
WXvgGFgRtKsYjTR6AWS3AJF1zxcVW2H6Kr5U6cSSUXjZ5CspgKi9QbAH5ftew/Rc
15wxdrrO8z5F+wR5LVnoTDL5r/0LmHHlNoqvIz4cA/R33SpJkSWiscXGg9gwzfQJ
FDMGv/szhIYBXgknAvZSvJJl1NtA+UrmjG4dYXmPPabljyR1giJJhmh4VD6uuspA
LXpzTQi9jH6+Mc2FGxFcQ+WdRFuAq9tc9awv2NJKXIufQnOLTLgNbJspP1/jcGEU
PfCjC4iCQcYvAJha1jkxfV9U4uVO7wNLZtM1UtXV4Gy47uFH+R2BruTTFqsNB5Tm
q6aUkCRtF/hYZiL/bs5IvK9V43vodpKM8Hf7jxyMmipb+dXaNsCAZgxKzBFmVb8b
U7oYe40Md0cd3SrlZVju0B61KZPe3i0DW9qh0TVODscKUVd3GCGAOOyNXk3rlyZb
KqNX05l3HFAR1QsSZkLYdkz5vrCuLkqjKKjxVB7ZwI7Xz4Wdt7g=
=wgZK
-----END PGP SIGNATURE-----