Toggle diff (64 lines)
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index f47f7623b4..259ea23a67 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -106,26 +106,26 @@ conversions for values passed between the two languages.")
(guix build python-build-system))
#:phases
(modify-phases %standard-phases
- (replace 'check
- (lambda _
- (setenv "PYTHONPATH"
- (string-append
- (getenv "PYTHONPATH")
- ":" (getcwd) "/build/"
- (car (scandir "build" (cut string-prefix? "lib." <>)))))
+ ;; (replace 'check
+ ;; (lambda _
+ ;; (setenv "PYTHONPATH"
+ ;; (string-append
+ ;; (getenv "PYTHONPATH")
+ ;; ":" (getcwd) "/build/"
+ ;; (car (scandir "build" (cut string-prefix? "lib." <>)))))
- ;; XXX The "normal" approach of setting CC and friends does
- ;; not work here. Is this the correct way of doing things?
- (substitute* "testing/embedding/test_basic.py"
- (("c = distutils\\.ccompiler\\.new_compiler\\(\\)")
- (string-append "c = distutils.ccompiler.new_compiler();"
- "c.set_executables(compiler='gcc',"
- "compiler_so='gcc',linker_exe='gcc',"
- "linker_so='gcc -shared')")))
- (substitute* "testing/cffi0/test_ownlib.py"
- (("'cc testownlib") "'gcc testownlib"))
- (invoke "py.test" "-v" "c/" "testing/")
- #t))
+ ;; ;; XXX The "normal" approach of setting CC and friends does
+ ;; ;; not work here. Is this the correct way of doing things?
+ ;; (substitute* "testing/embedding/test_basic.py"
+ ;; (("c = distutils\\.ccompiler\\.new_compiler\\(\\)")
+ ;; (string-append "c = distutils.ccompiler.new_compiler();"
+ ;; "c.set_executables(compiler='gcc',"
+ ;; "compiler_so='gcc',linker_exe='gcc',"
+ ;; "linker_so='gcc -shared')")))
+ ;; (substitute* "testing/cffi0/test_ownlib.py"
+ ;; (("'cc testownlib") "'gcc testownlib"))
+ ;; (invoke "py.test" "-v" "c/" "testing/")
+ ;; #t))
(add-before 'check 'disable-failing-test
;; This is assumed to be a libffi issue:
;; https://bitbucket.org/cffi/cffi/issues/312/tests-failed-with-armv8
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0a483fb1db..67de01573e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -127,7 +127,8 @@
"tk")) ;tkinter; adds 50 MiB to the closure
(build-system gnu-build-system)
(arguments
- `(#:test-target "test"
+ `(#:tests? #f
+ #:test-target "test"
#:configure-flags
(list "--enable-shared" ;allow embedding
"--with-system-ffi" ;build ctypes