[PATCH] gnu: ghc-network: Update to 2.8.0.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)(name . Brett Gilio)(address . brettg@posteo.net)
20181124043222.10708-1-brettg@posteo.net
---
gnu/packages/haskell.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0a90ac523..5cd746b36 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4264,7 +4264,7 @@ interface.")
(define-public ghc-network
(package
(name "ghc-network")
- (version "2.6.3.6")
+ (version "2.8.0.0")
(outputs '("out" "doc"))
(source
(origin
@@ -4275,7 +4275,7 @@ interface.")
".tar.gz"))
(sha256
(base32
- "198mam7ahny48p9fajznbqq16a8ya2gw0xm3gnm1si1rmc4hdplv"))))
+ "00skcish0xmm67ax999nv1nll9rm3gqmn92099iczd73nxl55468"))))
(build-system haskell-build-system)
;; The regression tests depend on an unpublished module.
(arguments `(#:tests? #f))
--
2.19.2
Ludovic Courtès wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33479@debbugs.gnu.org)
877eh2yxdz.fsf@gnu.org
Brett Gilio <brettg@posteo.net> skribis:

Toggle quote (15 lines)
> ---
> gnu/packages/haskell.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
> index 0a90ac523..5cd746b36 100644
> --- a/gnu/packages/haskell.scm
> +++ b/gnu/packages/haskell.scm
> @@ -4264,7 +4264,7 @@ interface.")
> (define-public ghc-network
> (package
> (name "ghc-network")
> - (version "2.6.3.6")
> + (version "2.8.0.0")

I tried building everything ‘guix refresh -l ghc-network’ reports and
got this:

Toggle snippet (38 lines)
[14 of 52] Compiling Network.TLS.Util.ASN1 ( Network/TLS/Util/ASN1.hs, dist/build/Network/TLS/Util/ASN1.o )

Network/TLS/Util/ASN1.hs:16:1: error:
Bad interface file: /gnu/store/g10iyg7k77lwi1sy76x9ivxspdcdn417-ghc-asn1-types-0.3.2/lib/ghc-8.4.3/asn1-types-0.3.2/Data/ASN1/Types.hi
Something is amiss; requested module asn1-types-0.3.2:Data.ASN1.Types differs from name found in the interface file asn1-types-0.3.2:Data.ASN1.Types (if these names look the same, try again with -dppr-debug)
|
16 | import Data.ASN1.Types (fromASN1, toASN1, ASN1Object)
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Network/TLS/Util/ASN1.hs:17:1: error:
Bad interface file: /gnu/store/0v8mna962b2r902l41rkdwslp6iwcfzr-ghc-asn1-encoding-0.9.5/lib/ghc-8.4.3/asn1-encoding-0.9.5/Data/ASN1/Encoding.hi
Something is amiss; requested module asn1-encoding-0.9.5:Data.ASN1.Encoding differs from name found in the interface file asn1-encoding-0.9.5:Data.ASN1.Encoding (if these names look the same, try again with -dppr-debug)
|
17 | import Data.ASN1.Encoding (decodeASN1', encodeASN1')
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Network/TLS/Util/ASN1.hs:18:1: error:
Bad interface file: /gnu/store/0v8mna962b2r902l41rkdwslp6iwcfzr-ghc-asn1-encoding-0.9.5/lib/ghc-8.4.3/asn1-encoding-0.9.5/Data/ASN1/BinaryEncoding.hi
Something is amiss; requested module asn1-encoding-0.9.5:Data.ASN1.BinaryEncoding differs from name found in the interface file asn1-encoding-0.9.5:Data.ASN1.BinaryEncoding (if these names look the same, try again with -dppr-debug)
|
18 | import Data.ASN1.BinaryEncoding (DER(..))
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Backtrace:
4 (primitive-load "/gnu/store/igjyba1xhv796ph1mnlr2fm2fdk…")
In ice-9/eval.scm:
191:35 3 (_ _)
In srfi/srfi-1.scm:
640:9 2 (for-each #<procedure 94e3e0 at /gnu/store/avr240b3zz4…> …)
In /gnu/store/avr240b3zz4606kpijnn7s1dvcavm495-module-import/guix/build/gnu-build-system.scm:
799:31 1 (_ _)
In /gnu/store/avr240b3zz4606kpijnn7s1dvcavm495-module-import/guix/build/utils.scm:
616:6 0 (invoke _ . _)

/gnu/store/avr240b3zz4606kpijnn7s1dvcavm495-module-import/guix/build/utils.scm:616:6: In procedure invoke:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "runhaskell" arguments: ("Setup.hs" "build") exit-status: 1 term-signal: #f stop-signal: #f] 98bd40>)'.
builder for `/gnu/store/c4w8iakyhh9zwbsa84zz2zmaqraxfajx-ghc-tls-1.4.1.drv' failed with exit code 1

Could you take a look? In general GHC libraries are tightly coupled so
we must really test all the dependent of a package when updating it.

Also, could you please provide a commit log that matches our
conventions? (See ‘git log’ for some examples.)

Thank you,
Ludo’.
Brett Gilio wrote 5 years ago
(address . 33479@debbugs.gnu.org)
87a78761v4.fsf@posteo.net
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (27 lines)
> ---
> gnu/packages/haskell.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
> index 0a90ac523..5cd746b36 100644
> --- a/gnu/packages/haskell.scm
> +++ b/gnu/packages/haskell.scm
> @@ -4264,7 +4264,7 @@ interface.")
> (define-public ghc-network
> (package
> (name "ghc-network")
> - (version "2.6.3.6")
> + (version "2.8.0.0")
> (outputs '("out" "doc"))
> (source
> (origin
> @@ -4275,7 +4275,7 @@ interface.")
> ".tar.gz"))
> (sha256
> (base32
> - "198mam7ahny48p9fajznbqq16a8ya2gw0xm3gnm1si1rmc4hdplv"))))
> + "00skcish0xmm67ax999nv1nll9rm3gqmn92099iczd73nxl55468"))))
> (build-system haskell-build-system)
> ;; The regression tests depend on an unpublished module.
> (arguments `(#:tests? #f))

This is a historical bug report and is no longer relevant. It can be
closed.

--
Brett M. Gilio
Efraim Flashner wrote 5 years ago
(address . 33479-done@debbugs.gnu.org)
20191205083536.GO15280@E5400
close bug


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl3owVgACgkQQarn3Mo9
g1EaQQ/+OoWhulTWL6mIsf+f1DfPZzUU3sf1M/R8H6P9JNTHsyTbmTbUt03ALazg
QtrSrexaN3tZMUqB5rTq+coh6VkYJdX6gyFP5Sp0qG2CZp7ZxS59UyUP6tpMz8VK
v2Tdh+e95iHuZTHLOEyB2tpdA+v78gKeZxFLa7DFZn4yGf0/Ku+Pwqzt7XtMptNw
TYsDx2C42huDEYNKJFL1nNFzzy4MRKX5VEHXa6mcVIhmdBalEpSmGauqUXds+48H
qC4TtwjbmyiLa98XtDSjK5jHZ7wnFye98TlDq6gHEI+o5RQKeik3+xWdVHfWbe6u
Kj6jpJLF6kD8qV4OK3UyQPNty+FmJiHKYDDv/8l9QTAFEOkpUhsXDVKFZaTXmcDw
5uReKvzLVluUvMUVY93m9hdcSfG3y81VrSPrLIcek3+0D/7JM2b7hhY9Ui8vbnzt
YNjhlA7J7WSjxGaH9J/SHcTat36gcFDzSpgEP5+CavWqc/sdVTmzBDdHc7Xh14Cb
DZNgQl+uyaGSovBN+CNXBbdANyjGaP1khgjERwL+DV6V4MWLweJvMGw5oemmXz2m
ZYQCJqGDGKm4OtK8SMgk/dOjcECOQjniBnufIYMGnQTeouQ5qz6zL6hWbJI7oIq5
ooJa7ktvn1xh0GvyjDtjx4ub7beNiJXs0XFHa40wcjAFNaoiTBQ=
=H1KJ
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33479@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33479
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help