Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
The attached patch series adds support for the pine64.org Pinebook
laptop (similar to the Pine64+ already in Guix).
Summary of changes:
- Update arm-trusted-firmware-pine64-plus to use upstream git repository
and newer commit.
- Rename arm-trusted-firmware-pine64-plus to.
arm-trusted-firmware-sun50i-a64 to be consistant with upstream.
- Add a make-u-boot-package-sunxi64 wrapper function based on the
u-boot-pine64-plus target.
- Add support for u-boot-pinebook, with patches from the u-boot sunxi
maintainer tree backported to 2018.11.
I wasn't sure weather some of these patches should be squashed together
or not (especially 1 and 2, maybe 3 and 4).
I used patches on top of the u-boot 2018.11 release rather than a git
repository with the patches included, as it took a much longer time to
download the git respository and more disk space, though I can take
another look at using the git repository if that is preferred.
live well,
vagrant
From f227d7a113818029104ee78d8ebad54582de48e3 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Mon, 5 Nov 2018 21:58:02 +0000
Subject: [PATCH 1/4] gnu: arm-trusted-firmware-pine64-plus: Update to
2.0-1.cabe0a3.
* gnu/packages/firmware.scm (arm-trusted-firmware-pine64-plus)
[version]: Update to 2.0-1.cabe0a3,
[source](uri): Use upstream git repository.
Use platform name from upstream (sun50i_a64).
---
gnu/packages/firmware.scm | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)
Toggle diff (38 lines)
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 0b5a82e9e..90797e013 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -447,24 +447,25 @@ such as:
license:bsd-2)))) ; libfdt
(define-public arm-trusted-firmware-pine64-plus
- (let ((base (make-arm-trusted-firmware "sun50iw1p1"))
- ;; Vendor's arm trusted firmware branch hasn't been upstreamed yet.
- (commit "ae78724247a01560164d607ed66db111c74d8df0")
+ (let ((base (make-arm-trusted-firmware "sun50i_a64"))
+ ;; Use unreleased version which enables additional features needed for
+ ;; LCD support
+ (commit "cabe0a31801e99e7abb84d2114ded6bb56f3c71e")
(revision "1"))
(package
(inherit base)
(name "arm-trusted-firmware-pine64-plus")
- (version (string-append "1.2-" revision "." (string-take commit 7)))
+ (version (git-version "2.0" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/apritzel/arm-trusted-firmware.git")
+ (url "https://github.com/ARM-software/arm-trusted-firmware.git")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "0r4xnlq7v9khjfcg6gqp7nmrmnw4z1r8bipwdr07png1dcbb8214")))))))
+ "0srw2zj3vn5d2fwzjpwa5h70d5bwvb79jnpdvmd395npv0gxshdz")))))))
(define-public arm-trusted-firmware-puma-rk3399
(let ((base (make-arm-trusted-firmware "rk3399"))
--
2.11.0
From daf0962814ee61032ae29958daac3fa0997292c5 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Wed, 14 Nov 2018 16:53:14 +0000
Subject: [PATCH 2/4] gnu: arm-trusted-firmware-pine64-plus: Rename variable to
arm-trusted-firmware-sun50i-a64.
* gnu/packages/firmware (arm-trusted-firmware-pine64-plus): Rename variable to
arm-trusted-firmware-sun50i-a64.
* gnu/packages/bootloaders (u-boot-pine64-plus) [native-inputs]: Replace with
arm-trusted-firmware-sun50i-a64.
---
gnu/packages/bootloaders.scm | 2 +-
gnu/packages/firmware.scm | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
Toggle diff (37 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 2fa50a89b..3e4c8bb0b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -573,7 +573,7 @@ board-independent tools.")))
)
#t))))))
(native-inputs
- `(("firmware" ,arm-trusted-firmware-pine64-plus)
+ `(("firmware" ,arm-trusted-firmware-sun50i-a64)
,@(package-native-inputs base))))))
(define-public u-boot-bananapi-m2-ultra
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 90797e013..c396cd644 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -446,7 +446,7 @@ such as:
(license (list license:bsd-3
license:bsd-2)))) ; libfdt
-(define-public arm-trusted-firmware-pine64-plus
+(define-public arm-trusted-firmware-sun50i-a64
(let ((base (make-arm-trusted-firmware "sun50i_a64"))
;; Use unreleased version which enables additional features needed for
;; LCD support
@@ -454,7 +454,7 @@ such as:
(revision "1"))
(package
(inherit base)
- (name "arm-trusted-firmware-pine64-plus")
+ (name "arm-trusted-firmware-sun50i-a64")
(version (git-version "2.0" revision commit))
(source
(origin
--
2.11.0
From bd253c8cf018ecd8c8f34ecfba19636b37057960 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Mon, 19 Nov 2018 21:04:48 -0800
Subject: [PATCH 3/4] gnu: make-u-boot-package-sunxi64: New variable.
* gnu/packages/bootloaders.scm (make-u-boot-package-sunxi64): New varaible.
(u-boot-pine64-plus): Switch to using make-u-boot-package-sunxi64.
---
gnu/packages/bootloaders.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
Toggle diff (27 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 3e4c8bb0b..21de88443 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -554,8 +554,8 @@ board-independent tools.")))
(define-public u-boot-beagle-bone-black
(make-u-boot-package "am335x_boneblack" "arm-linux-gnueabihf"))
-(define-public u-boot-pine64-plus
- (let ((base (make-u-boot-package "pine64_plus" "aarch64-linux-gnu")))
+(define-public (make-u-boot-package-sunxi64 board triplet)
+ (let ((base (make-u-boot-package board triplet)))
(package
(inherit base)
(arguments
@@ -576,6 +576,9 @@ board-independent tools.")))
`(("firmware" ,arm-trusted-firmware-sun50i-a64)
,@(package-native-inputs base))))))
+(define-public u-boot-pine64-plus
+ (make-u-boot-package-sunxi64 "pine64_plus" "aarch64-linux-gnu"))
+
(define-public u-boot-bananapi-m2-ultra
(make-u-boot-package "Bananapi_M2_Ultra" "arm-linux-gnueabihf"))
--
2.11.0
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCW/R7ggAKCRDcUY/If5cW
qjxYAP9nJ2o1/reEk8gVVFyihxw6d3CzQ5qR752HEZu5b8MYKwEAnfv/DjDwojpi
ANF4zh2kNu6BADmO7l03sYv5h96soAk=
=nm0c
-----END PGP SIGNATURE-----