[PATCH 4/4] gnu: Add OpenShot.

  • Done
  • quality assurance status badge
Details
One participant
  • ericbavier
Owner
unassigned
Submitted by
ericbavier
Severity
normal

Debbugs page

ericbavier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
20181115041715.15993-5-ericbavier@centurylink.net
From: Eric Bavier <bavier@member.fsf.org>

* gnu/packages/video.scm (openshot-qt): New variable.
---
gnu/packages/video.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 31684dd2f..b634394d0 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3139,3 +3139,49 @@ create smoother and stable videos.")
editing library with a multi-threaded and feature rich video editing
API. It includes bindings for Python, Ruby, and other languages.")
(license license:lgpl3+)))
+
+(define-public openshot
+ (package
+ (name "openshot")
+ (version "2.4.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenShot/openshot-qt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qdw1mli4y9qhrnllnkaf6ydgw5vfvdb90chs4i679k0x0jyb9a2"))))
+ (build-system python-build-system)
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("libopenshot" ,libopenshot)
+ ("python" ,python)
+ ("python-pyqt" ,python-pyqt)
+ ("python-pyzmq" ,python-pyzmq)
+ ("python-requests" ,python-requests)
+ ("qtsvg" ,qtsvg)))
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases (modify-phases %standard-phases
+ (delete 'build) ;install phase does all the work
+ (add-before 'install 'set-tmp-home
+ (lambda _
+ ;; src/classes/info.py "needs" to create several
+ ;; directories in $HOME when loaded during build
+ (setenv "HOME" "/tmp")
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/openshot-qt")
+ `("QT_PLUGIN_PATH" prefix
+ ,(list (string-append (assoc-ref inputs "qtsvg")
+ "/lib/qt5/plugins/")))))))))
+ (home-page "https://openshot.org")
+ (synopsis "Video editor")
+ (description "OpenShot takes your videos, photos, and music files and
+helps you create the film you have always dreamed of. Easily add sub-titles,
+transitions, and effects and then export your film to many common formats.")
+ (license license:gpl3+)))
--
2.19.1
Eric Bavier wrote 6 years ago
(address . 33391-done@debbugs.gnu.org)
20181126200802.57a870ce@centurylink.net
On Wed, 14 Nov 2018 22:17:15 -0600
ericbavier@centurylink.net wrote:

Toggle quote (7 lines)
> From: Eric Bavier <bavier@member.fsf.org>
>
> * gnu/packages/video.scm (openshot-qt): New variable.
> ---
> gnu/packages/video.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 46 insertions(+)

Pushed in 69a3fcc086f0582d82f3b2d19ad94e12c67070fa

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlv8pwIACgkQ/XPKxxnT
JWaXIQ//cgxA3sB5pQwDYVDa0wgvq+DNH1pQyqDefDqAvU75V1oHf3swMKQgKbpq
2/I/XIpQTfZ8ydz6NFq1WlX7oWVGHRt/R08g1n1xq2N79pFKQssLMx4YnyfO6DBo
9rIgBO58wtlvQHazdvGzCtFUQr3wOZUWVrHP+dtf2sDt9YEoEkboPbGmpUUNCt5L
xElFle3TXyJAM1iGdi+/PxUPT84XCW0SsIXmuzGhuq1YIsmqGFOYYNekORz1FBtB
dvYZtej30fsGraleUo9PmNIjjMKrAvCgr5cGryIRsYaBBBjn3z+VohqKaDj4cxOw
BX6svGHBnKuW0o+/Ukt1buhvcC01EZZ1C9JGv3GsCTl8FxFEgAKhjI2OErjV0Wun
dvPliNoayXHyg1j/jSgFYiQr7nK5aiO8sUklbBYEuD4q7Gwulgmq58oxjVFOdryq
6t3eSEbeYLhyxieTruXHrd7MGHdGemLsXYVaee0yErpn5xqg261BxBe92KF9LDmm
LvOgpEVpcKgwF9scUUd5KzDa7ckNjS6zjpqf9N94XRhbmA5gI0ab3E5NKBC60ulx
pCPZiKirZcV//AagpjivjHuoK77xu6fwWoDhRKYAQwSDd2e8GypMRcarFAdOUKpV
biZIouZGORC0VnBu8cbQx68cyths/88Z0uD6p6gxMn/0dVDDv9E=
=4s5x
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33391@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33391
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help