[PATCH 1/4] qtwebkit: Fix pri install directory.

  • Done
  • quality assurance status badge
Details
2 participants
  • ericbavier
  • Christopher Baines
Owner
unassigned
Submitted by
ericbavier
Severity
normal

Debbugs page

ericbavier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
20181115041715.15993-2-ericbavier@centurylink.net
From: Eric Bavier <bavier@member.fsf.org>

This lets qmake find qtwebkit components, allowing packages like python-pyqt
to find qtwebkit and enable support.

* gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
to #:configure-flags. Link with "--no-keep-memory".
---
gnu/packages/qt.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d48769982..36f8aef69 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
#:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
"-DPORT=Qt"
"-DUSE_LIBHYPHEN=OFF"
- "-DUSE_SYSTEM_MALLOC=ON")))
+ "-DUSE_SYSTEM_MALLOC=ON"
+ ;; XXX: relative dir installs to build dir?
+ (string-append "-DECM_MKSPECS_INSTALL_DIR="
+ %output "/lib/qt5/mkspecs/modules")
+ ;; Sacrifice a little speed in order to link
+ ;; libraries and test executables in a
+ ;; reasonable amount of memory.
+ "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
+ "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
(home-page "https://www.webkit.org")
(synopsis "Web browser engine and classes to render and interact with web
content")
--
2.19.1
Christopher Baines wrote 6 years ago
(address . ericbavier@centurylink.net)
87h8gcso59.fsf@cbaines.net
ericbavier@centurylink.net writes:

Toggle quote (41 lines)
> From: Eric Bavier <bavier@member.fsf.org>
>
> This lets qmake find qtwebkit components, allowing packages like python-pyqt
> to find qtwebkit and enable support.
>
> * gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
> to #:configure-flags. Link with "--no-keep-memory".
> ---
> gnu/packages/qt.scm | 11 ++++++++++-
> 1 file changed, 10 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index d48769982..36f8aef69 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -10,6 +10,7 @@
> ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
> ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
> ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
> +;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
> #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
> "-DPORT=Qt"
> "-DUSE_LIBHYPHEN=OFF"
> - "-DUSE_SYSTEM_MALLOC=ON")))
> + "-DUSE_SYSTEM_MALLOC=ON"
> + ;; XXX: relative dir installs to build dir?
> + (string-append "-DECM_MKSPECS_INSTALL_DIR="
> + %output "/lib/qt5/mkspecs/modules")
> + ;; Sacrifice a little speed in order to link
> + ;; libraries and test executables in a
> + ;; reasonable amount of memory.
> + "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
> + "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
> (home-page "https://www.webkit.org")
> (synopsis "Web browser engine and classes to render and interact with web
> content")

I've tested this, and this fixed the qtwebkit build for me, which
currently doesn't work on master. So I'm all for merging it.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlvzN8JfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfaXQ/9ErcTYCrZr2cYRAU7dwi7ScVu9SifPLPc3xqIp+PqTxbFImH2R8MmTuzq
hs0e+zjDeNSu5UdYFm/85thbunnQyVvFioISx0DM6c9Oz2tTxl4t0ziZEjmF90VA
C3P2CeKtPqmNqsZAqryuAVlz1/hdY6KEXn6w5jgsh/X24GiEPOK8TLz0wZQj1vkq
SzAz/fCBkRW9xC6ErLDf35q3t4GLc5gzVFQ64ROgLlMS28VXrmcibPcBD7D8TBkw
YUTU84ULGsNCdK08RCfv+ziQ1S5izYVLF1GfI23kuQSMXffYHtjj5Z5e+WoNQ0MG
++nKtp630CzXi3VA/ILvF0SSz1K7JvmGe0lMDkeyisFFEu0HWukMlX3msgniHQcG
j4b6wJq71L0qHjHIy0MezAfPXeNOFc+ZGtqY+bNbyos2JV4qB59cOTnC/wLNImnq
mRYdNwcZoxUGIJIS+nx62Pu0UBhQXGyPMNxcxwCC0dqYaOASI/3bPW+9qVnm/w7u
5cyGx9KXcvF5EW7VmhkyNqqUmrhC3A9KkYrUwtKyxQSxPM9rnk73EG9Fcz7Wn1NB
AjhfqwTSyWobDcEnGRjlZJEIQLRpuosy0fi05Ag7jd6fERfG0bPhRe8aZP73sUN3
GwWePzCI/0+Y84tCamFPCkiR9C1ldLPFBDpy16nGUjUX1w5voOU=
=7z0X
-----END PGP SIGNATURE-----

Eric Bavier wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33390@debbugs.gnu.org)
20181119222244.26c47f9e@centurylink.net
Hi Christopher,

On Mon, 19 Nov 2018 22:22:58 +0000
Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (46 lines)
> ericbavier@centurylink.net writes:
>
> > From: Eric Bavier <bavier@member.fsf.org>
> >
> > This lets qmake find qtwebkit components, allowing packages like python-pyqt
> > to find qtwebkit and enable support.
> >
> > * gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
> > to #:configure-flags. Link with "--no-keep-memory".
> > ---
> > gnu/packages/qt.scm | 11 ++++++++++-
> > 1 file changed, 10 insertions(+), 1 deletion(-)
> >
> > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> > index d48769982..36f8aef69 100644
> > --- a/gnu/packages/qt.scm
> > +++ b/gnu/packages/qt.scm
> > @@ -10,6 +10,7 @@
> > ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
> > ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
> > ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
> > +;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
> > ;;;
> > ;;; This file is part of GNU Guix.
> > ;;;
> > @@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
> > #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
> > "-DPORT=Qt"
> > "-DUSE_LIBHYPHEN=OFF"
> > - "-DUSE_SYSTEM_MALLOC=ON")))
> > + "-DUSE_SYSTEM_MALLOC=ON"
> > + ;; XXX: relative dir installs to build dir?
> > + (string-append "-DECM_MKSPECS_INSTALL_DIR="
> > + %output "/lib/qt5/mkspecs/modules")
> > + ;; Sacrifice a little speed in order to link
> > + ;; libraries and test executables in a
> > + ;; reasonable amount of memory.
> > + "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
> > + "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
> > (home-page "https://www.webkit.org")
> > (synopsis "Web browser engine and classes to render and interact with web
> > content")
>
> I've tested this, and this fixed the qtwebkit build for me, which
> currently doesn't work on master. So I'm all for merging it.

Thanks for testing it. I assume it was the linker flags that fixed the
build on your machine? For clarity, I suppose that change should be
moved to a separate patch. WDYT?

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlvzjBUACgkQ/XPKxxnT
JWZ0Ew//QlpbUrTd/Cbzs5WOKDW4b4E9k5PYFl012oOxbXGFn6ET4RaM9lhtcbMC
L8Ztf3mH5JccKTLn76O0GgQxY5LzevAl8yvJM6rz2zRLpo4i+16LLlbnxJc2B4ya
7TyahIGWLvz41Zj2g4vT3glkbzaYOHq6IE3p/nDH9uV7v+h7vXgKrKo5oFh8mOSG
SsVGSO0VBBzkoGohPCIJF7N74gOPDMN0BrJndDmRkBpmK8/H5RSECFQ3XFtqvHq4
/oyEP/LZkyj3Q9mthaOQTHsZeE0elxL82WPalRLw8hRCaXVpk5aqQt1IFYsWYfXK
rKSs7fy/PAl0MxnRnA9/+r4qD/dnnE1hBiAeoV1CDRMPMaAkBkfcRB5coC2ctIux
znQFekQ3Z/SVczRxU+bg5Texbd+LD0cfNbrdG6TaXy5FKlZp/DWUiQIUDO4egI/m
UpuAnMVAg2P5FbBRvqtMfeQswUzFXF1twl+NzRSm9Y7/Brr8TZdCvtWP69cNAuNn
jaUxYnLI33/XP1590hcj034o7lrRAaDPFmTqtN0WDEFk20c//7k+0MPuqKnEXtl9
MrybJj97cNTB4J4B+TZ3ID6DxhntMlFj9fuE3iL+saKVdfddNTiY63ktWI8e3LcA
19+LCtQJPU9pQb0ct4QB0hcKX9q4Og7PI/krvFuBM+5kqkW8nvU=
=sYq+
-----END PGP SIGNATURE-----


Christopher Baines wrote 6 years ago
(name . Eric Bavier)(address . ericbavier@centurylink.net)(address . 33390@debbugs.gnu.org)
87ftvvskqg.fsf@cbaines.net
Eric Bavier <ericbavier@centurylink.net> writes:

Toggle quote (48 lines)
>> > From: Eric Bavier <bavier@member.fsf.org>
>> >
>> > This lets qmake find qtwebkit components, allowing packages like python-pyqt
>> > to find qtwebkit and enable support.
>> >
>> > * gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
>> > to #:configure-flags. Link with "--no-keep-memory".
>> > ---
>> > gnu/packages/qt.scm | 11 ++++++++++-
>> > 1 file changed, 10 insertions(+), 1 deletion(-)
>> >
>> > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
>> > index d48769982..36f8aef69 100644
>> > --- a/gnu/packages/qt.scm
>> > +++ b/gnu/packages/qt.scm
>> > @@ -10,6 +10,7 @@
>> > ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
>> > ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
>> > ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
>> > +;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
>> > ;;;
>> > ;;; This file is part of GNU Guix.
>> > ;;;
>> > @@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
>> > #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
>> > "-DPORT=Qt"
>> > "-DUSE_LIBHYPHEN=OFF"
>> > - "-DUSE_SYSTEM_MALLOC=ON")))
>> > + "-DUSE_SYSTEM_MALLOC=ON"
>> > + ;; XXX: relative dir installs to build dir?
>> > + (string-append "-DECM_MKSPECS_INSTALL_DIR="
>> > + %output "/lib/qt5/mkspecs/modules")
>> > + ;; Sacrifice a little speed in order to link
>> > + ;; libraries and test executables in a
>> > + ;; reasonable amount of memory.
>> > + "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
>> > + "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
>> > (home-page "https://www.webkit.org")
>> > (synopsis "Web browser engine and classes to render and interact with web
>> > content")
>>
>> I've tested this, and this fixed the qtwebkit build for me, which
>> currently doesn't work on master. So I'm all for merging it.
>
> Thanks for testing it. I assume it was the linker flags that fixed the
> build on your machine? For clarity, I suppose that change should be
> moved to a separate patch. WDYT?

I don't mind eitherway, I'm just happy that the package builds again
with the patch :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlv0SQdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcFTA/+Po3qjBm63Ll0tEK7mcwykvg20rNP/Myzio8ulgL5eazVP2OErGVH1/Ft
PvwBa+jwZZHTTgJFpW2t/ZXu2vNlWb1nhYr52zlocK+VnIsBFIcwXvLqhGiXSOZg
j4OsuNE3q8RvM7kdk3G5tukwAlevDLcnGfYg/1hwcWbLIZeU7bXPd6gNiO/d/VAJ
0SKMO06akyQMyJJjj4LyieHu/RHVjne5jP/+ufHovPShewVSX4TkhT8yx4e9nemy
KbxuQV0uDikxCOcsJ6ilh4i+C2/ZvojAtvg7bF0yQJPob7Dv3fxx6U2kX0UBvZ/X
9l1UAz2HQgiQJ4xyQmCURjXCaza7hf0B/yDCtJ5G7mLtulNcZYrnPzdQwp1oAiKZ
WK3EWT8WtamSAbGtjZWhQFGhkCWaa79VVuuYpmwxkYCsE9otcBA0HvePiy5JkM45
zugEht/19qJJvlpODQ4lU79M2/WOlt0FN0JLp+3JXVP+gP3m5cWTo0XiZNduWo24
C4a67vbLkzHuZ7Ku8M9yjE1EysUNRW/O2YN2JGFh+pKpDeE+m+Qz5BWcxJHOTH6B
br/aCqgdEAwHhB2Sk1MH3N2oINT2pb2fUj4QPcQKzVgZFIrpjspKo3xzVknmcfjH
FZVAfExJOiXxfttoRve+3WaF4/O/+GG8aw4o0hWVo4QRWECdhBY=
=Tl00
-----END PGP SIGNATURE-----

Eric Bavier wrote 6 years ago
(address . 33390-done@debbugs.gnu.org)
20181126200411.2d5c176e@centurylink.net
On Mon, 19 Nov 2018 22:22:44 -0600
Eric Bavier <ericbavier@centurylink.net> wrote:

Toggle quote (55 lines)
> Hi Christopher,
>
> On Mon, 19 Nov 2018 22:22:58 +0000
> Christopher Baines <mail@cbaines.net> wrote:
>
> > ericbavier@centurylink.net writes:
> >
> > > From: Eric Bavier <bavier@member.fsf.org>
> > >
> > > This lets qmake find qtwebkit components, allowing packages like python-pyqt
> > > to find qtwebkit and enable support.
> > >
> > > * gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
> > > to #:configure-flags. Link with "--no-keep-memory".
> > > ---
> > > gnu/packages/qt.scm | 11 ++++++++++-
> > > 1 file changed, 10 insertions(+), 1 deletion(-)
> > >
> > > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> > > index d48769982..36f8aef69 100644
> > > --- a/gnu/packages/qt.scm
> > > +++ b/gnu/packages/qt.scm
> > > @@ -10,6 +10,7 @@
> > > ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
> > > ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
> > > ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
> > > +;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
> > > ;;;
> > > ;;; This file is part of GNU Guix.
> > > ;;;
> > > @@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
> > > #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
> > > "-DPORT=Qt"
> > > "-DUSE_LIBHYPHEN=OFF"
> > > - "-DUSE_SYSTEM_MALLOC=ON")))
> > > + "-DUSE_SYSTEM_MALLOC=ON"
> > > + ;; XXX: relative dir installs to build dir?
> > > + (string-append "-DECM_MKSPECS_INSTALL_DIR="
> > > + %output "/lib/qt5/mkspecs/modules")
> > > + ;; Sacrifice a little speed in order to link
> > > + ;; libraries and test executables in a
> > > + ;; reasonable amount of memory.
> > > + "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
> > > + "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
> > > (home-page "https://www.webkit.org")
> > > (synopsis "Web browser engine and classes to render and interact with web
> > > content")
> >
> > I've tested this, and this fixed the qtwebkit build for me, which
> > currently doesn't work on master. So I'm all for merging it.
>
> Thanks for testing it. I assume it was the linker flags that fixed the
> build on your machine? For clarity, I suppose that change should be
> moved to a separate patch. WDYT?

I've split this patch in two and pushed as

0995a5692cb85418b2d5f21c24d46ee4aa9fb7c9 and
ebdb15bc3540b1901f223bc0689bae51a2f88fc4

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlv8phwACgkQ/XPKxxnT
JWYKSQ/8D7N0qvuPXiFTvpxz+pEGji4wqYSKyOhyLbF0iFATSyIBVm1WIgRxXf6B
6I+ofDHt/YBkkFDmqXsNK9ryarygr76pjQUKjc5wDdT8hCZ2gUtGeZf/NnoB6qOK
5i48dmFheilQ/vXfrLLLTEYzbFcIel+0KSO0WM7055/4febIfp+pz+LOXBA0lA2Z
SUZHBb81DxHfuta+dRSKmRZCWMlsjG++mOVhB7Em1sxv7h45DWMgABDqF3Q8iqvj
Qgtr7l1+AG/jHqF3Q60AYx15MuwKjDFRngjI1hjr8N4ETHiKRRW1iRDntu5xsmAj
yBA8bwFERy9zEMyuSdTyJHIUEdakU1jqI1CMDVh9Dw0iIDX0dTr4soOsuOMCvjP5
jb++oyhUEw5ZaD+GnH1tZ0FOd/9zW4X9ltcStWhMA33oAPfviIN4lA3ge1xh3m8q
O2uWWvhLD5m8ibZwINmBhcu01zWNYTP1ZGSQyOqQk5bQzGuK1QNfzzYo6g4RN0S1
y03Asly2+x7e1Ijmg6PTd+VhWPEq2gGqzH9M05/k55y04GOm3Lql8r9cxU8Vk0Zn
6TInTuylIpfpddJd7BYKgnZCbXAy3pGDlD8bA27CEGvS4CXw4/GdwjDvRv6PJl40
NwspZ/HC1BSsTHRlZuuGjin9RwJkCgj5YZU4HjEZB9hyWd+3VKs=
=aDPt
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33390@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33390
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help