[PATCH] gnu: Add caps-plugins-lv2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal

Debbugs page

Thorsten Wilms wrote 6 years ago
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20181112172728.14054-1-t_w_@freenet.de
* gnu/packages/audio.scm (caps-plugins-lv2): New variable.
---
gnu/packages/audio.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 91f55a354..80da64e9a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -514,6 +514,47 @@ tools (analyzer, mono/stereo tools, crossovers).")
;; The plugins are released under LGPLv2.1+
(license (list license:lgpl2.1+ license:gpl2+))))
+(define-public caps-plugins-lv2
+ (package
+ (name "caps-plugins-lv2")
+ (version "0.9.24") ; version that has been ported.
+ (source
+ (origin
+ ;; The Github project hasn't tagged a release.
+ (method git-fetch)
+ (uri (git-reference
+ ;; Actually https://github.com/moddevices/caps-lv2.git, but it's
+ ;; missing fixes for newer glibc, so using the origin of a pull
+ ;; request regarding this issue:
+ (url "https://github.com/jujudusud/caps-lv2.git")
+ (commit "9c9478b7fbd8f9714f552ebe2a6866398b0babfb")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1idfnazin3cca41zw1a8vwgnxjnkrap7bxxjamjqvgpmvydgcam1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ ;; no configure script
+ (delete 'configure)
+ (add-after 'unpack 'override-target-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* (find-files "plugins" "Makefile")
+ (("/usr/local")(assoc-ref outputs "out")))
+ #t)))))
+ (inputs
+ `(("lv2" ,lv2)))
+ ;; home-page of the original LADSPA version: http://quitte.de/dsp/caps.html
+ (home-page "https://github.com/moddevices/caps-lv2")
+ (synopsis "LV2 port of the CAPS audio plugin colection")
+ (description
+ "LV2 port of CAPS, a collection of audio plugins comprising basic virtual
+guitar amplification and a small range of classic effects, signal processors and
+generators of mostly elementary and occasionally exotic nature.")
+ (license license:gpl3+)))
+
(define-public espeak
(package
(name "espeak")
--
2.19.1
Ludovic Courtès wrote 6 years ago
(name . Thorsten Wilms)(address . t_w_@freenet.de)(address . 33356-done@debbugs.gnu.org)
87a7m8r7ut.fsf@gnu.org
Hi,

Thorsten Wilms <t_w_@freenet.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (caps-plugins-lv2): New variable.

I added a copyright line for you and committed, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33356@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33356
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help