gnu: xonotic: Symlink to xonotic data instead of copying into xonotic.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pkill9
Owner
unassigned
Submitted by
pkill9
Severity
normal

Debbugs page

pkill9 wrote 6 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
E1gM35s-00079t-V8@rmmprod06.runbox
This patch changes the 'install-data phase of the xonotic package so that it creates a symlink to xonotic's data ('xonotic-data' package) instead of copying it. This reduces the package download size from 880mb to 12mb.

The xonotic-data package is already an input in the xonotic package rather than a native-input, so that didn't need to be changed.
From 0396ed08ca9fe936e2a89f830fbee1ecfc408b9b Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Mon, 12 Nov 2018 03:14:15 +0000
Subject: [PATCH] gnu: xonotic: Symlink to xonotic data instead of copying into
xonotic.

* gnu/packages/games.scm (xonotic)[arguments]: Modify the phase
'install-data so it creates a symlink to xonotic's data instead of
copying it into the xonotic package.
---
gnu/packages/games.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3679aa09c..bc5d3d581 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5606,8 +5606,8 @@ quotation from a collection of quotes.")
(lambda* (#:key outputs inputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(data (assoc-ref inputs "xonotic-data")))
- (copy-recursively (string-append data "/share/xonotic")
- (string-append out "/share/xonotic"))
+ (symlink (string-append data "/share/xonotic")
+ (string-append out "/share/xonotic"))
#t)))
(add-after 'install-binaries 'wrap-binaries
(lambda* (#:key outputs inputs #:allow-other-keys)
--
2.19.1
Ludovic Courtès wrote 6 years ago
(address . pkill9@runbox.com)(address . 33351-done@debbugs.gnu.org)
871s7gvj86.fsf@gnu.org
Hello,

<pkill9@runbox.com> skribis:

Toggle quote (2 lines)
> This patch changes the 'install-data phase of the xonotic package so that it creates a symlink to xonotic's data ('xonotic-data' package) instead of copying it. This reduces the package download size from 880mb to 12mb.

Good catch.

Toggle quote (12 lines)
> The xonotic-data package is already an input in the xonotic package rather than a native-input, so that didn't need to be changed.
>
> From 0396ed08ca9fe936e2a89f830fbee1ecfc408b9b Mon Sep 17 00:00:00 2001
> From: Pkill -9 <pkill9@runbox.com>
> Date: Mon, 12 Nov 2018 03:14:15 +0000
> Subject: [PATCH] gnu: xonotic: Symlink to xonotic data instead of copying into
> xonotic.
>
> * gnu/packages/games.scm (xonotic)[arguments]: Modify the phase
> 'install-data so it creates a symlink to xonotic's data instead of
> copying it into the xonotic package.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33351@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33351
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help