Thorsten Wilms wrote 6 years ago
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
* gnu/packages/audio.scm (autotalent): New variable.
---
gnu/packages/audio.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
Toggle diff (54 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ee18b0022..2a1785f54 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -427,6 +427,47 @@ and editing digital audio. It features digital effects and spectrum analysis
tools.")
(license license:gpl2+)))
+(define-public autotalent
+ (package
+ (name "autotalent")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://tombaran.info/autotalent-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1n04qm66f14195ly6gsy3ra7v2j7zad5n19d8dwfmh0qs6h9hphh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ ;; no configure script
+ (delete 'configure)
+ (add-before 'install 'prepare-target-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append (assoc-ref outputs "out") "/lib/ladspa"))
+ #t))
+ (add-after 'unpack 'override-target-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/usr/lib64/ladspa")
+ (string-append (assoc-ref outputs "out") "/lib/ladspa")))
+ #t)))))
+ (inputs
+ `(("ladspa" ,ladspa)))
+ (home-page "http://tombaran.info/autotalent.html")
+ (synopsis "Pitch-correction LADSPA audio plugin")
+ (description
+ "Autotalent is a LADSPA plugin for real-time pitch-correction. Among its
+controls are allowable notes, strength of correction, LFO for vibrato and
+formant warp.")
+ ;; All code except the FFT routine is licensed under GPL2.
+ ;; The FFT routine is licensed under a Pure Data license.
+ (license (list license:gpl2
+ (license:non-copyleft "file://COPYING-mayer_fft")))))
+
(define-public azr3
(package
(name "azr3")
--
2.19.1