[PATCH] gnu: Add autotalent.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal

Debbugs page

Thorsten Wilms wrote 6 years ago
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20181110202227.21286-1-t_w_@freenet.de
* gnu/packages/audio.scm (autotalent): New variable.
---
gnu/packages/audio.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ee18b0022..2a1785f54 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -427,6 +427,47 @@ and editing digital audio. It features digital effects and spectrum analysis
tools.")
(license license:gpl2+)))
+(define-public autotalent
+ (package
+ (name "autotalent")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://tombaran.info/autotalent-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1n04qm66f14195ly6gsy3ra7v2j7zad5n19d8dwfmh0qs6h9hphh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ ;; no configure script
+ (delete 'configure)
+ (add-before 'install 'prepare-target-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append (assoc-ref outputs "out") "/lib/ladspa"))
+ #t))
+ (add-after 'unpack 'override-target-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/usr/lib64/ladspa")
+ (string-append (assoc-ref outputs "out") "/lib/ladspa")))
+ #t)))))
+ (inputs
+ `(("ladspa" ,ladspa)))
+ (home-page "http://tombaran.info/autotalent.html")
+ (synopsis "Pitch-correction LADSPA audio plugin")
+ (description
+ "Autotalent is a LADSPA plugin for real-time pitch-correction. Among its
+controls are allowable notes, strength of correction, LFO for vibrato and
+formant warp.")
+ ;; All code except the FFT routine is licensed under GPL2.
+ ;; The FFT routine is licensed under a Pure Data license.
+ (license (list license:gpl2
+ (license:non-copyleft "file://COPYING-mayer_fft")))))
+
(define-public azr3
(package
(name "azr3")
--
2.19.1
Ludovic Courtès wrote 6 years ago
(name . Thorsten Wilms)(address . t_w_@freenet.de)(address . 33337-done@debbugs.gnu.org)
87a7m4vjm2.fsf@gnu.org
Hello,

Thorsten Wilms <t_w_@freenet.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (autotalent): New variable.

I changed the license as shown below and applied.

Thanks!

Ludo’.
Toggle diff (18 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 64dcf29560..1f83c49f4d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -464,10 +464,9 @@ tools.")
"Autotalent is a LADSPA plugin for real-time pitch-correction. Among its
controls are allowable notes, strength of correction, LFO for vibrato and
formant warp.")
- ;; All code except the FFT routine is licensed under GPL2.
- ;; The FFT routine is licensed under a Pure Data license.
- (license (list license:gpl2
- (license:non-copyleft "file://COPYING-mayer_fft")))))
+ ;; All code except the FFT routine is licensed under GPLv2+.
+ ;; The FFT routine is under BSD-3.
+ (license (list license:gpl2+))))
(define-public azr3
(package
Closed
Ludovic Courtès wrote 6 years ago
(name . Thorsten Wilms)(address . t_w_@freenet.de)(address . 33337@debbugs.gnu.org)
87d0qzzzlv.fsf@gnu.org
Hi!

(+Cc.)

Thorsten Wilms <t_w_@freenet.de> skribis:

Toggle quote (9 lines)
> On 19/11/2018 22.32, Ludovic Courtès wrote:
>
>>> * gnu/packages/audio.scm (autotalent): New variable.
>>
>> I changed the license as shown below and applied.
>
> Thanks for checking and applying, but this surely shouldn't end with
> (license (list license:gpl2+))?

Oh right, I’ll remove ‘list’, though both forms are equivalent.

Thanks,
Ludo’.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33337@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33337
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help