[PATCH 1/2] gnu: gtk-doc: Use local docbook-xsl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Pierre Neidhardt
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 9 Nov 2018 19:20
(address . guix-patches@gnu.org)
20181109182013.20661-1-mail@ambrevar.xyz
* gnu/packages/gtk.scm (gtk-doc): Use local docbook-xsl.
---
gnu/packages/gtk.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 640bd75da..0d62b8083 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1411,7 +1412,12 @@ information.")
(string-append (assoc-ref inputs "docbook-xsl")
"/xml/xsl/docbook-xsl-"
,(package-version docbook-xsl)
- "/html/chunk.xsl")))
+ "/html/chunk.xsl"))
+ (("http://docbook.sourceforge.net/release/xsl/current/common/en.xml")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/common/en.xml")))
#t))
(add-after 'patch-gtk-doc-scan 'patch-test-out
(lambda _
--
2.19.1
P
P
Pierre Neidhardt wrote on 9 Nov 2018 19:24
[PATCH 2/2] gnu: webkitgtk: Include documentation.
(address . 33327@debbugs.gnu.org)
20181109182443.22490-1-mail@ambrevar.xyz
* gnu/packages/webkit.scm (webkitgtk): Include documentation.
---
gnu/packages/webkit.scm | 20 +++++++++++++++++++-
1 file changed, 19 insertions(+), 1 deletion(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index d1890c8b3..b4560c0e4 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages enchant)
#:use-module (gnu packages flex)
#:use-module (gnu packages gcc)
@@ -71,6 +73,7 @@
#:build-type "Release" ; turn off debugging symbols to save space
#:configure-flags (list
"-DPORT=GTK"
+ "-DENABLE_GTKDOC=ON" ; No doc by default
(string-append ; uses lib64 by default
"-DLIB_INSTALL_DIR="
(assoc-ref %outputs "out") "/lib")
@@ -87,7 +90,20 @@
;; XXX Disable WOFF2 ‘web fonts’. These were never
;; supported in our previous builds. Enabling them
;; requires building libwoff2 and possibly woff2dec.
- "-DUSE_WOFF2=OFF")))
+ "-DUSE_WOFF2=OFF")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-gtk-doc-scan
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Source/WebKit/WebProcess/InjectedBundle/API/gtk/DOM/docs/webkitdomgtk-docs.sgml"
+ (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/docbookx.dtd")))
+ (substitute* "Source/WebKit/UIProcess/API/gtk/docs/webkit2gtk-docs.sgml"
+ (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/docbookx.dtd")))
+ #t)))))
(native-inputs
`(("bison" ,bison)
("gettext" ,gettext-minimal)
@@ -97,6 +113,8 @@
("perl" ,perl)
("pkg-config" ,pkg-config)
("python" ,python-2) ; incompatible with Python 3 (print syntax)
+ ("gtk-doc" ,gtk-doc) ; For documentation generation
+ ("docbook-xml" ,docbook-xml) ; For documentation generation
("ruby" ,ruby)))
(propagated-inputs
`(("gtk+" ,gtk+)
--
2.19.1
L
L
Ludovic Courtès wrote on 10 Nov 2018 23:27
Re: [bug#33327] [PATCH 1/2] gnu: gtk-doc: Use local docbook-xsl.
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 33327@debbugs.gnu.org)
87wopkvaa3.fsf@gnu.org
Hi,

Pierre Neidhardt <mail@ambrevar.xyz> skribis:

Toggle quote (2 lines)
> * gnu/packages/gtk.scm (gtk-doc): Use local docbook-xsl.

This is so that users of gtk-doc don’t need to specify where docbook-xsl
is to be searched for, right?

Ludo’.
L
L
Ludovic Courtès wrote on 10 Nov 2018 23:27
Re: [bug#33327] [PATCH 2/2] gnu: webkitgtk: Include documentation.
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 33327@debbugs.gnu.org)
87sh08va8v.fsf@gnu.org
Pierre Neidhardt <mail@ambrevar.xyz> skribis:

Toggle quote (2 lines)
> * gnu/packages/webkit.scm (webkitgtk): Include documentation.

Since generated HTML documentation tends to take a lot of space, what
about moving it to a “doc” output?

Otherwise LGTM.

Thanks,
Ludo’.
P
P
Pierre Neidhardt wrote on 11 Nov 2018 11:54
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33327@debbugs.gnu.org)
874lcnnaui.fsf@ambrevar.xyz
Toggle quote (3 lines)
> This is so that users of gtk-doc don’t need to specify where docbook-xsl
> is to be searched for, right?

On the user-side, I don't know, but without this thee doc of WebKitGTK would
fail to build, so this is necessary on the builder side.

Toggle quote (3 lines)
> Since generated HTML documentation tends to take a lot of space, what
> about moving it to a “doc” output?

Documentation is <7MB, <5% of the total package size, so I didn't bother
creating a separate output.
What do you think?

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAlvoClUACgkQm9z0l6S7
zH8O1wf+K/FtRe2nnqv4TZZYWqvM2iJFHzQHOfPy2bTdRzswjLpl6lDeEpg5g1kk
epIUG1LRRtANVwBPTku1e6IGxiNWMrYHiOm/ZZmcTnUhzLhdELX9x87iYzEhozv9
oqjte59hMbh17QPgPcVHExtCqD8/y967gPjOppAjC/U7j9EmhTaudihB0NzoblRo
+wXhSNlZeTEJq0Wp+b62XQlAzg+w5BSj8j1vpfi8QeUEsWaPahlsS2ImfWVQtofN
2aqnyoSFcxvMHR//8C4YnZvfnUTGRaTvr04RH8zvHp8Ojz0X1ybUJnvhSMliuLrY
r8uEezLMFIAVyMA/LxuBv9FOET0bGQ==
=3+Cp
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 11 Nov 2018 12:35
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 33327@debbugs.gnu.org)
87h8gnu9sm.fsf@gnu.org
Pierre Neidhardt <mail@ambrevar.xyz> skribis:

Toggle quote (6 lines)
>> This is so that users of gtk-doc don’t need to specify where docbook-xsl
>> is to be searched for, right?
>
> On the user-side, I don't know, but without this thee doc of WebKitGTK would
> fail to build, so this is necessary on the builder side.

But other packages that use gtk-doc don’t have this problem, right? Any
idea what’s different?

Toggle quote (7 lines)
>> Since generated HTML documentation tends to take a lot of space, what
>> about moving it to a “doc” output?
>
> Documentation is <7MB, <5% of the total package size, so I didn't bother
> creating a separate output.
> What do you think?

I have a preference for a separate “doc” output nonetheless, if it’s not
too difficult to achieve.

Thanks for your feedback,
Ludo’.
P
P
Pierre Neidhardt wrote on 11 Nov 2018 16:06
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33327@debbugs.gnu.org)
871s7rmz5a.fsf@ambrevar.xyz
Toggle quote (3 lines)
> But other packages that use gtk-doc don’t have this problem, right? Any
> idea what’s different?

I assume it's because WebKitGTK documentation uses some option of gtkdoc that
other packages don't use.

Toggle quote (3 lines)
> I have a preference for a separate “doc” output nonetheless, if it’s not
> too difficult to achieve.

OK, I'll them and merge then.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAlvoRZEACgkQm9z0l6S7
zH/XsQf/RxxQgkA23e4MQ5cz8xUAoK2uA7eaX8rD6uUa5P7Pdz53AMUuzYZAG7X8
YAmVKHJsTAWBBH46W4h55zwX40mNN0lh2m4THfk0QwubRGyCoi2JLqRtWSCTt5dr
WfRCe8tgmMvOz5mcBNo/BMB0rpEYyl67t3fLdx7brtq7wjUt+ZL8SVOQ5KOPhgT0
woMzSNSbOmSZPaIHGW4zQS+N/j+blioP97isDf/o4jB/D1ZrIkIg4I8OHMN9PzX9
xtFYB8l29OOOEoh3/8rC9gsVD8d5s/LbLZBzTX328tRMDCC8Gf1/FR0VEQnchD+5
cVIvPm12C5kbMDlDzG+CgOVBcJrcaQ==
=POg+
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 12 Nov 2018 10:21
control message for bug #33327
(address . control@debbugs.gnu.org)
87sh06lkh3.fsf@ambrevar.xyz
tags 33327 fixed
close 33327
?