[PATCH] gnu: maxima: Fix tests on i686 and x86_64.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20181108222717.10007-1-kkebreau@posteo.net
* gnu/packages/maths.scm (maxima)[arguments]: Replace check phase.
---
gnu/packages/maths.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 808ab5345..389343051 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2716,6 +2716,18 @@ to BMP, JPEG or PNG image formats.")
(lambda _
(chmod "src/maxima" #o555)
#t))
+ (replace 'check
+ (lambda _
+ ;; This is derived from the testing code in the "debian/rules" file
+ ;; of Debian's Maxima package.
+ ;; If Maxima can successfully run this, the binary to be installed
+ ;; should be fine.
+ (zero?
+ (system
+ (string-append "./maxima-local "
+ "--lisp=gcl "
+ "--batch-string=\"run_testsuite();\" "
+ "| grep -q \"No unexpected errors found\"")))))
;; Make sure the doc and emacs files are found in the
;; standard location. Also configure maxima to find gnuplot
;; without having it on the PATH.
--
2.19.1
Ludovic Courtès wrote 6 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 33322@debbugs.gnu.org)
871s7ksnn1.fsf@gnu.org
Hello,

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/maths.scm (maxima)[arguments]: Replace check phase.

[...]

Toggle quote (11 lines)
> + ;; This is derived from the testing code in the "debian/rules" file
> + ;; of Debian's Maxima package.
> + ;; If Maxima can successfully run this, the binary to be installed
> + ;; should be fine.
> + (zero?
> + (system
> + (string-append "./maxima-local "
> + "--lisp=gcl "
> + "--batch-string=\"run_testsuite();\" "
> + "| grep -q \"No unexpected errors found\"")))))

So the exit code without grep isn’t good enough, right?

If it has to be this way, so be it!

Thanks,
Ludo’.
Kei Kebreau wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33322-done@debbugs.gnu.org)
87wopafhd7.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (25 lines)
> Hello,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/maths.scm (maxima)[arguments]: Replace check phase.
>
> [...]
>
>> + ;; This is derived from the testing code in the "debian/rules"
>> file
>> + ;; of Debian's Maxima package.
>> + ;; If Maxima can successfully run this, the binary to be installed
>> + ;; should be fine.
>> + (zero?
>> + (system
>> + (string-append "./maxima-local "
>> + "--lisp=gcl "
>> + "--batch-string=\"run_testsuite();\" "
>> + "| grep -q \"No unexpected errors found\"")))))
>
> So the exit code without grep isn’t good enough, right?
>
> If it has to be this way, so be it!
>

Yes, because I think that Maxima returns successfully as long as it
exits without the underlying Lisp implementation crashing.

Toggle quote (3 lines)
> Thanks,
> Ludo’.

Thank you for the review!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33322@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33322
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help