[PATCH 0/2] Update mash and capnproto.

  • Done
  • quality assurance status badge
Details
4 participants
  • Eric Bavier
  • Leo Famulari
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
[PATCH 0/2] Update mosh and capnproto.
(address . guix-patches@gnu.org)
87va58hdt1.fsf@cbaines.net
Update the mosh and capnproto packages. I want to update capnproto, and
I updated mosh along with it, as initially it failed to build with the
newer capnproto version.

Christopher Baines (2):
gnu: mash: Update to 2.1.
gnu: capnproto: Update to 0.7.0.

gnu/packages/bioinformatics.scm | 14 +++++++++++---
gnu/packages/serialization.scm | 10 ++++++++--
2 files changed, 19 insertions(+), 5 deletions(-)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlvjQNpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xfm+w/+NrfdCySXHbALh+zfPSyZhQRWZTLoldCDISqw93jwITSwRTC7hSMEHIwI
GFhZAfXsYcrlqrxXEo3J1I34D0EaCOryRaIn2dzTeVqAJ1cPqSkbpN0+ijTC2b0B
XKhFVmowBitU11++gEFZe3BNgPmMdqelmtPTRie/WHrgjFuVzfNUp5+z2fpy3zcL
E4z7d0CUPAyCmSvXqhjZWMcHuva6d5dT9gSVxP3f4ExAZ3G1/XXMbkV8kLs9Nxtu
V++wMgDgH0/TYWwsFWXNzmBQASEykLOfA+BXheP+Rgpp9Nn8YIun0P+NDU4MJOi4
pBJtj1ObQNkTq3tmLy58P+3z5jMSsPhs/RIouHE9EiIjPzfVz1IYWKYCNGLX3HJg
JmnyrFd7yTKXPGQ0TXTFwktHGqqTAM+BrkYkCRwK1S5fMIckNsihPKj8gKNxc73T
WI9/GHjJHC1bxPUEwFYPFTxbqcd+Z7hzMfxZFYcznbPzMqfxzhTdqaLQshSth9Np
Vk/9Ep3jVS+VJlfbgERwJD8HLkK082jcIJ0Q3ba/vN0KTS29bUJ3Lbn9oQl2KVDv
ZPv4FO5s/odp87lHP7OUiv2NgFvFF6R1UCfNuZtWHPMrcYoYIJRZi7SPtXxim8hK
5oTDSnUigE3+eDzT6PvHaX8TUDlOnQDTqJ4L6HtaDcUj8+Cy834=
=5CoE
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
[PATCH 2/2] gnu: capnproto: Update to 0.7.0.
(address . 33308@debbugs.gnu.org)
20181107195654.22832-2-mail@cbaines.net
* gnu/packages/serialization.scm (capnproto)[version]: Change to 0.7.0.
[source]: Update sha256 hash.
[arguments]: Add new 'use-tmp-for-tempory-files phase, to patch some tests to
use /tmp for tempory files, as the default /var/tmp directory doesn't exist.
---
gnu/packages/serialization.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 40b3d1bae0..77fd070bc7 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -314,7 +314,7 @@ it a convenient format to store user input files.")
(define-public capnproto
(package
(name "capnproto")
- (version "0.6.1")
+ (version "0.7.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -322,7 +322,7 @@ it a convenient format to store user input files.")
version ".tar.gz"))
(sha256
(base32
- "010s9yhq4531wvdfrdf2477zswhck6cjfby79w73rff3v06090l0"))))
+ "0hfdnhlbskagzgvby8wy6lrxj53zfzpfqimbhga68c0ji2yw1969"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -332,6 +332,12 @@ it a convenient format to store user input files.")
;; Workaround for test that tries to resolve port name from
;; /etc/services, which is not present in build environment.
(substitute* "src/kj/async-io-test.c++" ((":http") ":80"))
+ #t))
+ (add-before 'check 'use-tmp-for-tempory-files
+ (lambda _
+ (substitute* "src/kj/filesystem-disk-test.c++"
+ (("VAR\\_TMP \"/var/tmp\"")
+ "VAR_TMP \"/tmp\""))
#t)))))
(home-page "https://capnproto.org")
(synopsis "Capability-based RPC and serialization system")
--
2.19.1
Christopher Baines wrote 6 years ago
[PATCH 1/2] gnu: mash: Update to 2.1.
(address . 33308@debbugs.gnu.org)
20181107195654.22832-1-mail@cbaines.net
I'm looking to upgrade capnproto, and mash fails to build with 0.7. Therefore,
update it, and tweak the compilation to allow it to build with 0.7. The
package also builds with the current version of capnproto. I got the idea of
changing the c++ version from here [1].


* gnu/packages/bioinformatics.scm (mash)[version]: Change to 2.1.
[source]: Update sha256 hash.
[arguments]: Add new use-c++14 phase, to patch source to build using c++14.
---
gnu/packages/bioinformatics.scm | 14 +++++++++++---
1 file changed, 11 insertions(+), 3 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9f0b8025da..93503d82b8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3977,7 +3977,7 @@ sequences).")
(define-public mash
(package
(name "mash")
- (version "2.0")
+ (version "2.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3986,7 +3986,7 @@ sequences).")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "00fx14vpmgsijwxd1xql3if934l82v8ckqgjjyyhnr36qb9qrskv"))
+ "0d5m9wx1bspa5vwikazdbar4i0h6b20lzjjl1icfyl66sy1q9v9q"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -4012,7 +4012,15 @@ sequences).")
(("^#include \"kseq\\.h\"")
"#include \"htslib/kseq.h\""))
#t))
- (add-after 'fix-includes 'autoconf
+ (add-after 'fix-includes 'use-c++14
+ (lambda _
+ ;; capnproto 0.7 requires c++14 to build
+ (substitute* "configure.ac"
+ (("c\\+\\+11") "c++14"))
+ (substitute* "Makefile.in"
+ (("c\\+\\+11") "c++14"))
+ #t))
+ (add-after 'use-c++14 'autoconf
(lambda _ (zero? (system* "autoconf")))))))
(native-inputs
`(("autoconf" ,autoconf)
--
2.19.1
Leo Famulari wrote 6 years ago
Re: [bug#33308] [PATCH 0/2] Update mosh and capnproto.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33308@debbugs.gnu.org)
20181107201919.GA29144@jasmine.lan
On Wed, Nov 07, 2018 at 07:45:30PM +0000, Christopher Baines wrote:
Toggle quote (4 lines)
> Update the mosh and capnproto packages. I want to update capnproto, and
> I updated mosh along with it, as initially it failed to build with the
> newer capnproto version.

I got excited about a new release of mosh (the mobile shell). You mean
mash, right? :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlvjSMQACgkQJkb6MLrK
fwiR+RAAw9h5123NRW1PpImogQOpsDcanjbrX5uiqEJCDcu/E767Slb2tNJxDToM
5MJS5yOL8szO0110GM32HpVlh1EtnOOlcZh99XH19Zdnv48zRSWA82sxt5TF7B23
TZArrHKBzk9zyT8i4q7l+d5eAx7mCjJEo/hXU/iL006Ykch8OXA8ggBa/unZ7yj/
gtv/7fdqnmkxQkLhbazxu6rz3RdMEi08Yvhq1EoxP/6HkYHJpqo2SqngqjqApXoi
u5dZ+/GoDHsz8LGQb2/T6mJviLVbfZsST7FSL8Hly48dLwYWMTMnwLi7K8AE6TC6
qFl4253C/G6aYJ96bdi11h/7YvTkjp2PMl+IY8PZpJOXGbw7sUncdTR2hOed+Li7
/S1LFxe9/F4L5n44IBJZosRyF7fFF/dmU7uXJZ+b/NCKYhq9DkNuwgwlepgMBYZ9
1k1gZB/duNjldGU20VJY4HaY9c8cbMq6PiSGIIYx144/7H3OF/qQB5tNQGJVT+mu
S0pK6/RD8DUq+18j6B2I5WYy9KZT9ivZjVA5WaKpGc+LenSl56Frc5C86CbkyqmM
6nT1tsezCHCwItyOEpIhdzfaOrep29WyPRyBLVCyHPJjxdvuwp86GX2aioCiRIOU
/lrvgb6a6KIDCnN/dDw2NLNASMXToDrSVJrloY2CgncmQSW3dNc=
=yQZN
-----END PGP SIGNATURE-----


Eric Bavier wrote 6 years ago
Re: [bug#33308] [PATCH 1/2] gnu: mash: Update to 2.1.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33308@debbugs.gnu.org)
20181107212327.2b3f7ded@centurylink.net
On Wed, 7 Nov 2018 19:56:53 +0000
Christopher Baines <mail@cbaines.net> wrote:


Toggle quote (3 lines)
> * gnu/packages/bioinformatics.scm (mash)[version]: Change to 2.1.
> [source]: Update sha256 hash.

I think here we typically just say "(mash)[source]: Upgrade to 2.1."

Toggle quote (22 lines)
> [arguments]: Add new use-c++14 phase, to patch source to build using c++14.
> ---
> gnu/packages/bioinformatics.scm | 14 +++++++++++---
> 1 file changed, 11 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
> index 9f0b8025da..93503d82b8 100644
> --- a/gnu/packages/bioinformatics.scm
> +++ b/gnu/packages/bioinformatics.scm
> @@ -4012,7 +4012,15 @@ sequences).")
> (("^#include \"kseq\\.h\"")
> "#include \"htslib/kseq.h\""))
> #t))
> - (add-after 'fix-includes 'autoconf
> + (add-after 'fix-includes 'use-c++14
> + (lambda _
> + ;; capnproto 0.7 requires c++14 to build
> + (substitute* "configure.ac"
> + (("c\\+\\+11") "c++14"))
> + (substitute* "Makefile.in"
> + (("c\\+\\+11") "c++14"))

I believe the configure.ac patch is sufficient for us here, since the
compile steps will pick up the CPPFLAGS set there. Too bad the
configure.ac is written so poorly... :( one should be able to just
pass "CPPFLAGS=-std=c++14" to `make`.

Toggle quote (4 lines)
> + #t))
> + (add-after 'use-c++14 'autoconf
> (lambda _ (zero? (system* "autoconf")))))))

Maybe you could also update this step to use 'invoke'.

Thanks,
`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlvjrC8ACgkQ/XPKxxnT
JWZ7/A/+L/z4LHaHeFfXm+Xol43VUryILpWzJ8NkCvyNLBwAk+r7ymmu26Fmgyja
rMuF36x8zBJgtEDmCd/6YYc7RkzjzC2Iww2Uc8E3ukLgwDOsY2S+uLxs5qdNATsp
knm80bO92Ei4JUuznjfWvyY4SCGhyfTRxdCsqk1wdlRw9srh2us0WvFtJzbh3OYI
bc1mXpYd4A+1ke4fDfnpcEqGOeMXc4SPAQ0TN1Z06jeRmKLANmb5Bb2Z0Z/qoqsi
H5phSxNand64SDeSqIG7TqbefggBzAg3tlqZc/nGtFOI9xU+54uEuSLoiDJkAIVc
m6/h6DwBvePnBDH+jjlWf4ZtybIzVSMWlZC/Mlg/+iJg0mqYZyiv3C6FzCVaVd1n
hRArWnm/TE0Q7cSSju67zKj8/6or94kA4lX+wSZyv8UhOac/0eV44h7pAO66jhlO
WKaqiMBEioDHRm+yS3UV1HJE4kk4jCP38wu1qrhD2lmqsghoYICk7B4d12c8XY1H
hihchygZ8+T5+To2y65zjiMiJRQ9WRcqogHSQkvNMuh6Ntuh5jjr+dp40a7OFYBu
UYGbTM1lOkt2Pj9wGyaeJ2e2H7kFQ6nF1zfvyT0xop5TbQ15i8py4xVBEw1hKz2l
hP749qdRkvueafBdz1ASCZX1P43PhEjmx1y8jz0AADXBmbWRcIc=
=YzmY
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 6 years ago
Re: [bug#33308] [PATCH 2/2] gnu: capnproto: Update to 0.7.0.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33308@debbugs.gnu.org)
875zx4wp2p.fsf@gnu.org
Hello,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (5 lines)
> * gnu/packages/serialization.scm (capnproto)[version]: Change to 0.7.0.
> [source]: Update sha256 hash.
> [arguments]: Add new 'use-tmp-for-tempory-files phase, to patch some tests to
> use /tmp for tempory files, as the default /var/tmp directory doesn't exist.

I’d suggest moving the /var/tmp explanation in a comment but otherwise
LGTM, thanks!

Ludo’.
Christopher Baines wrote 6 years ago
[PATCH v2 2/2] gnu: capnproto: Update to 0.7.0.
(address . 33308@debbugs.gnu.org)
20181126190433.25295-2-mail@cbaines.net
* gnu/packages/serialization.scm (capnproto): Update to 0.7.0.
[arguments]: Add new 'use-tmp-for-tempory-files phase.
---
gnu/packages/serialization.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 2df0ce1364..2d61f7451b 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -306,7 +306,7 @@ it a convenient format to store user input files.")
(define-public capnproto
(package
(name "capnproto")
- (version "0.6.1")
+ (version "0.7.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -314,7 +314,7 @@ it a convenient format to store user input files.")
version ".tar.gz"))
(sha256
(base32
- "010s9yhq4531wvdfrdf2477zswhck6cjfby79w73rff3v06090l0"))))
+ "0hfdnhlbskagzgvby8wy6lrxj53zfzpfqimbhga68c0ji2yw1969"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -324,6 +324,14 @@ it a convenient format to store user input files.")
;; Workaround for test that tries to resolve port name from
;; /etc/services, which is not present in build environment.
(substitute* "src/kj/async-io-test.c++" ((":http") ":80"))
+ #t))
+ (add-before 'check 'use-tmp-for-tempory-files
+ (lambda _
+ ;; Use /tmp for tempory files, as the default /var/tmp directory
+ ;; doesn't exist.
+ (substitute* "src/kj/filesystem-disk-test.c++"
+ (("VAR\\_TMP \"/var/tmp\"")
+ "VAR_TMP \"/tmp\""))
#t)))))
(home-page "https://capnproto.org")
(synopsis "Capability-based RPC and serialization system")
--
2.19.2
Christopher Baines wrote 6 years ago
[PATCH v2 1/2] gnu: mash: Fix build with capnproto 0.7.
(address . 33308@debbugs.gnu.org)
20181126190433.25295-1-mail@cbaines.net
I'm looking to upgrade capnproto, and mash fails to build with 0.7. Therefore,
tweak the compilation to allow it to build with 0.7. The package also builds
with the current version of capnproto. I got the idea of changing the c++
version from here [1].


* gnu/packages/bioinformatics.scm (mash)[arguments]: Add new use-c++14 phase.
---
gnu/packages/bioinformatics.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 782af294e0..571d85aed7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4018,6 +4018,14 @@ sequences).")
"src/mash/CommandScreen.cpp")
(("^#include \"kseq\\.h\"")
"#include \"htslib/kseq.h\""))
+ #t))
+ (add-after 'fix-includes 'use-c++14
+ (lambda _
+ ;; capnproto 0.7 requires c++14 to build
+ (substitute* "configure.ac"
+ (("c\\+\\+11") "c++14"))
+ (substitute* "Makefile.in"
+ (("c\\+\\+11") "c++14"))
#t)))))
(native-inputs
`(("autoconf" ,autoconf)
--
2.19.2
Christopher Baines wrote 6 years ago
(no subject)
(address . control@debbugs.gnu.org)
87sgznabqt.fsf@cbaines.net
retitle 33308 [PATCH 0/2] Update mash and capnproto.
thanks
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlv8RwpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdscRAAjXozS2HUWo60c0bBkozK7cnZNcG1tCyEooHEp92/BotYfL13HOGXloTa
Io0azq/cWBFjikRsDkG/7j1HfTd9Y0ZCzcXbI+QN1wAHz0B7UT1XJSimFiFt5Zat
q+oXsDzMIxaBSwYLNircHu+gUhBJQPKbC+BmNuOA8UCKvIDTBZZOi+S6vxEtb9Ix
uDuR1wDXBzPBYk2VZt1n0Zqmecw4wTatueBLsJSJ9rS1tQEVgRHNIOfjRb+XfTSz
gsrLhWLNwFdLcHDGCCIU2QqyEDTeAAIjho1HZLVFRnFNuKivfR/9BcxZFBiocH34
pmh+vazDGm8ZzqXayj4nQgXUUT4C4A8GFxr7u3hynLWeFOPha3uoxlsdfwTDLp8W
RTZiKObffmeVQ9OYFYjFFC1jkixNuMasXvi3qfqmX2iYTOIJpuwJcrvxatKsJd9H
r1X2eqPwa1+9SXiFUWTx1fd419M+XijWCIX73vJA4EalOxSM0D8SAR6dHGBw65Xk
KuLj1/hNRWAC02kMe8EyrD1hOaRV03jk+wmKCZuWb0/OnbH11vDNSGEr7IVajw0Y
R8gkKzeRftX2FGr76tqPAZPWvp//ZfEmUcYQexgdBiKIhwukGdTJ34wJPKXxJHc4
1xymmJM4iJvdYqoB0VeiJb+mAN3lUBysdPwcvKjdJOh4pQso8is=
=m6/s
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
Re: [bug#33308] [PATCH 0/2] Update mosh and capnproto.
(name . Leo Famulari)(address . leo@famulari.name)(address . 33308@debbugs.gnu.org)
87r2f7abej.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (8 lines)
> On Wed, Nov 07, 2018 at 07:45:30PM +0000, Christopher Baines wrote:
>> Update the mosh and capnproto packages. I want to update capnproto, and
>> I updated mosh along with it, as initially it failed to build with the
>> newer capnproto version.
>
> I got excited about a new release of mosh (the mobile shell). You mean
> mash, right? :)

Yep, sorry about that, I've fixed the title of the bug now.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlv8SMRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfTWg/+K7HNjWNp/4Juc8cm9YghqnkzMqsFvm5YQqNyxWy1R0EL9Ee2hv+tAMkr
W5dxEdvWvLJ+6zPr118CI/EHFsOScjcDcANQMTtfVxJXopWj+WGMJRVuY3LfAKb9
fpPoGQF1DT/tLNwNQk+lUXGLRBDLl4Evw14FTSPZZFtohT1VsGs/TCFWL6CQBhZD
2lKlX+99ojNHAH4bX+ZpNEvzZ3flZjISHCI5K7dlWcUa9a1Vv9FOgQLAcrlWm4yP
vKF8hKT6Jmwtm3YgebWlHnaw6GxSrFezQ89lEKqwnSOgmCZQrnf+I3MxzvE0SPid
G8VqSt/Eyy6mdDF7a3Nh7pMpvVwVfy61JXgjTgK01AED6Oy8t44/swNja784/UaB
l4sFgPeORxRTzNa0WCF2+w4Ha5XobN3FD1glsoCQ7crEKOcM676oEo3NrM1HbvtB
HvhhyUawyjBKJG4oIRmWCuAfZbM8IqzXltDXHmb5RW6jlHnbb2vN3T2jm5e44y2g
Ccf38HvEjN5h0GxzKhEMJqQHNiOPOHd7UEH1hpxKVZ8B9YeChUMfI/MM4k6wZ+82
kxDQQKDMt3rvuCK+a3s+fS7+ZG3OchWZFbueTNyP9Jq7cV6H+rdnkuQxuyPtV0zy
I65T4DgNqqELhS/FcBsK5nrSQpKdh6oAmLOhPY6/JEZtVoEX29s=
=ebA9
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
Re: [bug#33308] [PATCH 2/2] gnu: capnproto: Update to 0.7.0.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33308@debbugs.gnu.org)
87pnurabc4.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Hello,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/serialization.scm (capnproto)[version]: Change to 0.7.0.
>> [source]: Update sha256 hash.
>> [arguments]: Add new 'use-tmp-for-tempory-files phase, to patch some tests to
>> use /tmp for tempory files, as the default /var/tmp directory doesn't exist.
>
> I’d suggest moving the /var/tmp explanation in a comment but otherwise
> LGTM, thanks!

Great, I've done this now, and sent some updated patches.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlv8SRtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xepzg/8DeBhhBR1g7lu06RSh9A7FYZpSGPfdwGHrNNqSUM0CfaXTZhn/DWdvLQg
ESeiY2vHTg/8muP/q6xPrM5znh81m2yUg6G4Vz+RaMSpn4dlu/6PXttXix7tE8fL
98sqqFjHO1f/s0LSIr9yGNimYai54uxrrosnt0Z2pHqVWlQMzRIrTctSDHKwD2lz
GbCRVn4wMZ+pt7KXzZ8f8eQ3fg/Ha/8Dc/bkqjcTG1OvGn3BI7G6PVre7b71CWLJ
EGLZm7/ue2vCBb+WRPX3G/JitioNvlRpeGcBv+YdcWMrRPsDZjJCkpqIKOB14KIl
6/G7g3eFzOSJeObTZFxhLlwNf+LWc4D93XoK98l2zC1siFq1tA2nPBneUTkDg0+D
obq0Q8jsESZLMw28F4XEWR7beBO/ml4E//ZjQcFRasIkFELudVddVs1Jqr16SdUQ
C9lwh2xJ11/pD3ek4MEoc1WvScK/xJP+NjxY3Z55IRXiAqfBJd71P8jUg9w6VBIo
cx2np9ItC48gQO2YaSlOwyaDdkyKEKPwi5exTvr+xSwUavGYW3Ge1mvcjPglg6B5
/XPQygWBtOcSmdqPkZyXBNe1eDrTXEE2kOaqwpSl8xRqPd1WqKldLyZSOCd5CJQe
C1JyxyvSh8yGLAyLgwqRgjSjmReboqKlNIjwGPTRk7r1C5Kc3nM=
=987p
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
Re: [bug#33308] [PATCH 1/2] gnu: mash: Update to 2.1.
(name . Eric Bavier)(address . ericbavier@centurylink.net)(address . 33308@debbugs.gnu.org)
87o9abaay9.fsf@cbaines.net
Eric Bavier <ericbavier@centurylink.net> writes:

Toggle quote (9 lines)
> On Wed, 7 Nov 2018 19:56:53 +0000
> Christopher Baines <mail@cbaines.net> wrote:
>
>
>> * gnu/packages/bioinformatics.scm (mash)[version]: Change to 2.1.
>> [source]: Update sha256 hash.
>
> I think here we typically just say "(mash)[source]: Upgrade to 2.1."

Ok, I've sent a new set of patches now, and updated the commit messages.

Toggle quote (27 lines)
>> [arguments]: Add new use-c++14 phase, to patch source to build using c++14.
>> ---
>> gnu/packages/bioinformatics.scm | 14 +++++++++++---
>> 1 file changed, 11 insertions(+), 3 deletions(-)
>>
>> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
>> index 9f0b8025da..93503d82b8 100644
>> --- a/gnu/packages/bioinformatics.scm
>> +++ b/gnu/packages/bioinformatics.scm
>> @@ -4012,7 +4012,15 @@ sequences).")
>> (("^#include \"kseq\\.h\"")
>> "#include \"htslib/kseq.h\""))
>> #t))
>> - (add-after 'fix-includes 'autoconf
>> + (add-after 'fix-includes 'use-c++14
>> + (lambda _
>> + ;; capnproto 0.7 requires c++14 to build
>> + (substitute* "configure.ac"
>> + (("c\\+\\+11") "c++14"))
>> + (substitute* "Makefile.in"
>> + (("c\\+\\+11") "c++14"))
>
> I believe the configure.ac patch is sufficient for us here, since the
> compile steps will pick up the CPPFLAGS set there. Too bad the
> configure.ac is written so poorly... :( one should be able to just
> pass "CPPFLAGS=-std=c++14" to `make`.

I tried removing the Makefile.in change, but it didn't work for some
reason.

Toggle quote (6 lines)
>> + #t))
>> + (add-after 'use-c++14 'autoconf
>> (lambda _ (zero? (system* "autoconf")))))))
>
> Maybe you could also update this step to use 'invoke'.

This patch has now turned in to just fixing the package for the newer
version of capnproto, as Ricardo did the upgrade a few weeks ago. This
particular stage was removed in
e35dce017090685d07aedf10c9899c0cdcc70d9e.

Thanks for your comments Eric :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlv8Sw5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XeabhAAtpiRDR+Qg+KaLOv7r/5LYJ2QveBeT6tGGZEdXMpB2zkD2jx1iUjzEUDx
dlSpDzxP6WA9/l+siPocsRqg+OehwGLyFgMkRedRlaUv3DZlM9X30hfsOa2CbET3
OUGcTZDrkXIBMc6k9PqmJb4VyBp1LYCtSPeim2xR5yobZcgVhpgZhUZwmA4hSd7q
fEcul9jisxxqGGsao9cH6szyYce+Bxo/yAw5o0qfbi5NCTHOHjxWMqhHEfiKim5R
sPoCB+75q9kV1J1vDb23fOuRUlHzz/Wuw3TsowYvik1jVglZ6yVV+WmYtUrgwV56
eGOAsFEDhaGUyq/FvmRlvht+JCcsc1ln4G07WQlRqXWPP3QuV9tflJCA1IsreRkk
Fpz/UAq0bW+2j4UUp3uCLnql3+IVO0wbRQTjobGkUDak+Z7EFf13hTYrViTazFlx
EbzD/FBXKKhjktungrXFzBJgX5vCnllbIWqBQSDVytlrp4dXgLmdc/oqpfEIBvk9
A1wtzs9TcwSnkl/Md3G3De2FNlSnQyCNPpzBKnZcCMH0suhaUp0smM9EMBuFePPx
EeIOjlr7ozYm92SLdVj4Wx87YLN0nOxTRk64Rbis6UtO16VOjvz5UBurbnVuddFc
hUwmrdT4rQNAvQPB0JoamljLuX4EzgpcAzX/H2wMBN908hugxoU=
=Ag6/
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
Re: [bug#33308] [PATCH v2 2/2] gnu: capnproto: Update to 0.7.0.
(address . 33308-done@debbugs.gnu.org)
87sgzbogq5.fsf@cbaines.net
I've now gone ahead and pushed these two patches [1]. Thanks for taking
a look :)

1: As 9c5f4b82bb0ed6a0447a68f9cb18c4da5f692acf and
9c5f4b82bb0ed6a0447a68f9cb18c4da5f692acf
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlwINlJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcT2Q//XEtkXd6wPExQIDcDiWcuHbeCaCoWYVZUH+ZydB/bNopOnusg5eUDxhzl
EC9v6ZynWwPcY/vGKG3naSQ98bqNU9ksqJjjvNZLCBHo0kKYBsufduA8Fcjv+bDL
pbgzCW60rRr76csIwoqLtoCKaR2XSBJt7/lxQu9jjk4IOxGjmAsdxkcBjM9fK4pc
wnibv6dvnDwBPoKuLZsusyLEJIGbZLVdQLEe2xxxy05Hk/iqPtVRye6tA7IxGbGT
Sa0RzUZi5YUqNfU9R1UomUPUMTlJa983UOFWS86Dq/EKBZmrorwNSr8kIulgt+ne
Q5BKG1iDgVBnTaqVX4e9dREw2WbBfvetUntbpk1VHiYKL6SO/uzoEy5HImc2Z7XW
wQIH3fBOdkftPT2lUkMie+Vpg828w+dsDjh7IZXU7x8wlnSc5fIzmiVBcLfl9MlO
f4OwnS9A3vqRl2DIbN9O1XOk+tYar+QXeyWCZ/6zOo1ZJLlrP07frKJvfphvng+n
bgNyB4PxGXfLfOJfTSxjgDOLpUDRIaNxzxBQ3LAlhtPnG3t3eY+mzvmN/tS36SqS
zLP7k5/IlP3+6oJ/iSheKN+aAQ6gBGEPOKNBpV3Cb1vIA4arqOV36vAMztro6CRl
ekQJqw4EB1cHH5yF/MrLIoMx7Ul/O6O0ekot1ha6Xv9YyCVZWts=
=2yJH
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33308@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33308
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help