'ssh-daemon' fails to start

  • Done
  • quality assurance status badge
Details
5 participants
  • Christopher Lemmer Webber
  • Ludovic Courtès
  • Brant Gardner
  • maxim.cournoyer
  • swedebugia
Owner
unassigned
Submitted by
swedebugia
Severity
important
Merged with

Debbugs page

swedebugia wrote 6 years ago
shepherd: Service ssh-daemon could not be started.
(address . bug-guix@gnu.org)
c78be403-0616-67a0-fd5a-e1196b6a14d1@riseup.net
Hi

This morning I started my GuixSD VM as usual.

Openssh server was not running even though it was enabled and should
have been respawned. Hmm.

Lucky for me SSH is not the only way into this system...

From the host I got:

$ ssh  sdb@localhost -p10022
ssh_exchange_identification: read: Connection reset by peer

On the guest:

$ grep -3 "ssh-daemon could not /var/log/messages
Nov  7 07:19:30 localhost vmunix: [    0.366701] VFS: Dquot-cache hash
table entries: 512 (order 0, 4096 bytes)
Nov  7 07:19:30 localhost vmunix: [    0.367764] AppArmor: AppArmor
Filesystem Enabled
Nov  7 07:19:30 localhost vmunix: [    0.368569] pnp: PnP ACPI init
Nov  7 07:19:31 localhost shepherd[1]: Service ssh-daemon could not be
started.
Nov  7 07:19:31 localhost vmunix: [    0.370291] pnp: PnP ACPI: found 6
devices
Nov  7 07:19:31 localhost vmunix: [    0.378960] clocksource: acpi_pm:
mask: 0xffffff max_cycles: 0xffffff, max_idle_ns: 2085701024 ns
Nov  7 07:19:31 localhost vmunix: [    0.380434] NET: Registered
protocol family 2

Herd said:

$ cat sshd-stopped
Status of ssh-daemon:
  It is stopped.
  It is enabled.
  Provides (ssh-daemon).
  Requires (syslogd).
  Conflicts with ().
  Will be respawned.               <-- not true!

Starting it yielded:

$ cat sshd-start
Service ssh-daemon has been started.

How do I increase the verbosity of shepherd? I did not find anything
about that in the shepherd manual

Is there a way to debug further?

--
Cheers
Swedebugia
PS
$ guix --version
guix (GNU Guix) 1f44934fb6e2cefccbecd4fa347025349fa9ff76 (=0.15
Attachment: file
Ludovic Courtès wrote 6 years ago
control message for bug #33299
(address . control@debbugs.gnu.org)
87sh0cshbn.fsf@gnu.org
severity 33299 important
Ludovic Courtès wrote 6 years ago
control message for bug #30993
(address . control@debbugs.gnu.org)
87r2fwshbc.fsf@gnu.org
merge 30993 33299
Ludovic Courtès wrote 6 years ago
Re: bug#33299: shepherd: Service ssh-daemon could not be started.
(name . swedebugia)(address . swedebugia@riseup.net)
87muqksh7i.fsf@gnu.org
Hello,

swedebugia <swedebugia@riseup.net> skribis:

Toggle quote (5 lines)
> This morning I started my GuixSD VM as usual.
>
> Openssh server was not running even though it was enabled and should
> have been respawned. Hmm.

This seems to be the same issue as described in
https://issues.guix.info/issue/30993 (I’ve now merged both).

It’s a serious problem…

Thanks for reporting it,
Ludo’.
Ludovic Courtès wrote 6 years ago
control message for bug #30993
(address . control@debbugs.gnu.org)
87tvgb520i.fsf@gnu.org
merge 30993 34580
Brant Gardner wrote 5 years ago
Archived problem report bug#34580 (Service ssh-daemon could no t be started)
(address . control@debbugs.gnu.org)
1ee347ea-f340-4d61-8bfb-53a58139aa2d@www.fastmail.com
unarchive 34580

--
Brant Gardner
Attachment: file
Ludovic Courtès wrote 5 years ago
control message for bug #30993
(address . control@debbugs.gnu.org)
87r242ls3n.fsf@gnu.org
merge 30993 37309
quit
Ludovic Courtès wrote 5 years ago
(address . control@debbugs.gnu.org)
87pnjmls36.fsf@gnu.org
retitle 30993 'ssh-daemon' fails to start
quit
maxim.cournoyer wrote 5 years ago
(address . control@debbugs.gnu.org)
87wo1wppdk.fsf@hurd.i-did-not-set--mail-host-address--so-tickle-me
tags 30993 fixed
close 30993
quit
Christopher Lemmer Webber wrote 4 years ago
unarchive 37309
(address . control@debbugs.gnu.org)
87y2imjtm0.fsf@dustycloud.org
unarchive 37309
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33299@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33299
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help