Eric Bavier wrote 6 years ago
(address . guix-patches@gnu.org)
Hello Guix,
I noticed building 'python-minimal' that its tests seemed to have poor
memory performance, i.e. using *a lot* of RAM. I thought maybe
dropping --cores=... would help, but it did not; the tests use all
available cores by default. The attached patch fixes this issue,
though, the package still uses all cores while building some extension
libraries.
I suppose this patch would go to core-updates?
Cheers,
`~Eric
From 076d2f7f32a51f90f85be3da836d208987e9c678 Mon Sep 17 00:00:00 2001
From: Eric Bavier <bavier@member.fsf.org>
Date: Thu, 1 Nov 2018 21:18:41 -0500
Subject: [PATCH] python: Honor '--cores=...' in tests.
* gnu/packages/python.scm (python-2.7)[arguments]: Add #:make-flags.
---
gnu/packages/python.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (16 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fbb280224..9a8b9dfcf 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -206,6 +206,9 @@
"--enable-unicode=ucs4"
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))
+ ;; With no -j argument tests use all available cpus, so provide one.
+ #:make-flags
+ (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
#:modules ((ice-9 ftw) (ice-9 match)
(guix build utils) (guix build gnu-build-system))
--
2.19.1
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlvg+zAACgkQ/XPKxxnT
JWaQJhAAnK19/Gseg2vroo+GPgnUIrKK61Nsa55pbr0G0h0fPZTxSOABO2QkTt0W
ZYqAwFtaSpxbebwRWUrZEAJpxqHST4KDsAaiHAryDyue/oxojNIhUvZfpgpVG1Dh
sNxkkS4uX0ru/yVtPwpRhw3SXmZb62EKAGT09R4Vn3oC8GRVTpfKeRjQMDY42zPD
dLfSN2lUx/WbwE0oAfnDOUQtX0JwuFdErHJ4wXNiiRqedw0FWNrdeMS0mImSK0ol
2tIHUUMC57CmozcXuemyB2o6Acn6UTyie1XjqpDlfKKbuheI9THLKcGrmha/6UU/
epgtjcH/2K+Q0aoepr7obCocAUuIEtJwiRyLstsyGK5SqVOfQUGhC9BEGrj83uJy
BswnD9iT5UNkNfBxQDBvdEhKAInvJDjNbt5XR2OGcdzGKF9ePrfahpWP/cijIKOG
JD069Zezv8bPaKTXh58pMHEu/+4RE+ClimdJqMdseJX6vOg6xFhpV0xO8xW4jnD8
SZYkqlP3StATyLit8Lro89ZrbJ6HRjmqiDFjFJz7f7yW3Zen4LyFmFrigWzr0Dub
qMtfUASji+87tRiAe+qezilOWy2TER2Ly0SfzVz90LbD4kFUFYALIKDSgc0ABZ+R
JQnEBHrlivwjWGWh4dchqhB6MW/f3d6Te1f1BUC8KUHZ0tZIswE=
=MFCC
-----END PGP SIGNATURE-----