[PATCH] gnu: Add python-pyelftools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
87o9b32oyp.fsf@aikidev.net
* gnu/packages/python.scm (python-pyelftools):
New public variable.
---
gnu/packages/python.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 54ea0caac..c553ab319 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10578,6 +10578,29 @@ useful as a validator for JSON data.")
(define-public python2-validictory
(package-with-python2 python-validictory))
+(define-public python-pyelftools
+ (package
+ (name "python-pyelftools")
+ (version "0.25")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyelftools" version))
+ (sha256
+ (base32
+ "090vdksbz341f7ljvr0zswblw4lspa8qaiikzyjkf318arpxmil9"))))
+ (build-system python-build-system)
+ ;; Test suite requires python-setuptools
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page
+ "https://github.com/eliben/pyelftools")
+ (synopsis
+ "Library for analyzing ELF files and DWARF debugging information")
+ (description
+ "Library for analyzing ELF files and DWARF debugging information")
+ (license license:public-domain)))
+
(define-public python-pyev
(package
(name "python-pyev")
--
2.19.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCW+C2HgAKCRDcUY/If5cW
qvEHAP9qwkvR75ec/w1DFjHbwsZ6S0N1kU29u2QOENBQArP08QD9HdSt/At7GQi+
0GmwVurKyoxuADzClJaEmvO8KutTCgU=
=b585
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 33283@debbugs.gnu.org)
87k1lrw2qe.fsf@gnu.org
Hello!

Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (3 lines)
> * gnu/packages/python.scm (python-pyelftools):
> New public variable.

[...]

Toggle quote (7 lines)
> + (home-page
> + "https://github.com/eliben/pyelftools")
> + (synopsis
> + "Library for analyzing ELF files and DWARF debugging information")
> + (description
> + "Library for analyzing ELF files and DWARF debugging information")

Could you expound the description a bit? (See

Otherwise LGTM.

TIA!

Ludo’.
Vagrant Cascadian wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33283@debbugs.gnu.org)
871s7xgc1h.fsf@aikidev.net
On 2018-11-05, Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (19 lines)
> Hello!
>
> Vagrant Cascadian <vagrant@debian.org> skribis:
>
>> * gnu/packages/python.scm (python-pyelftools):
>> New public variable.
>
> [...]
>
>> + (home-page
>> + "https://github.com/eliben/pyelftools")
>> + (synopsis
>> + "Library for analyzing ELF files and DWARF debugging information")
>> + (description
>> + "Library for analyzing ELF files and DWARF debugging information")
>
> Could you expound the description a bit? (See
> <https://www.gnu.org/software/guix/manual/en/html_node/Synopses-and-Descriptions.html>.)

Updated patch attached with an updated synopsis and description,
attempting to follow the mentioned guidelines.

live well,
vagrant
From ee20fe1b8e0ecb1fb706b7929af5e4bb63843ff5 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Mon, 5 Nov 2018 19:36:57 +0000
Subject: [PATCH] gnu: Add python-pyelftools.

* gnu/packages/python.scm (python-pyelftools):
New public variable.
---
gnu/packages/python.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 54ea0caac..83a62532b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10578,6 +10578,31 @@ useful as a validator for JSON data.")
(define-public python2-validictory
(package-with-python2 python-validictory))
+(define-public python-pyelftools
+ (package
+ (name "python-pyelftools")
+ (version "0.25")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyelftools" version))
+ (sha256
+ (base32
+ "090vdksbz341f7ljvr0zswblw4lspa8qaiikzyjkf318arpxmil9"))))
+ (build-system python-build-system)
+ ;; Test suite requires python-setuptools
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page
+ "https://github.com/eliben/pyelftools")
+ (synopsis
+ "Analyze binary and library file information")
+ (description "This Python Library provides interfaces for parsing and
+analyzing two binary and library file formats; the Executable and Linking
+Format- ELF, and debugging information in the Debugging With Attributed
+Record Format- DWARF.")
+ (license license:public-domain)))
+
(define-public python-pyev
(package
(name "python-pyev")
--
2.11.0
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCW+IACgAKCRDcUY/If5cW
qhHvAQCpRGpYB/K5kYgyP5FLiuMAsV2tb6MxNXkL6GXnLZjrjwEA54mRGsfWP7YA
zFMfcync6/VtXXq/Cn25iZ4MSu23zgs=
=FDh+
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 33283-done@debbugs.gnu.org)
875zx8tx90.fsf@gnu.org
Hi Vagrant,

Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (8 lines)
> From ee20fe1b8e0ecb1fb706b7929af5e4bb63843ff5 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@debian.org>
> Date: Mon, 5 Nov 2018 19:36:57 +0000
> Subject: [PATCH] gnu: Add python-pyelftools.
>
> * gnu/packages/python.scm (python-pyelftools):
> New public variable.

Applied with extra nitpicking below. ;-)

Thank you!

Ludo’.
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10597,10 +10597,10 @@ useful as a validator for JSON data.")
(synopsis
"Analyze binary and library file information")
- (description "This Python Library provides interfaces for parsing and
+ (description "This Python library provides interfaces for parsing and
analyzing two binary and library file formats; the Executable and Linking
-Format- ELF, and debugging information in the Debugging With Attributed
-Record Format- DWARF.")
+Format (ELF), and debugging information in the Debugging With Attributed
+Record Format (DWARF).")
(license license:public-domain)))
(define-public python-pyev
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33283@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33283
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help