On Sun, 28 Oct 2018 21:02:27 +0100
Pierre Neidhardt <mail@ambrevar.xyz> wrote:
Toggle quote (34 lines)
> Hi!
>
> Consult the manual, "(guix) X Window". There is an example near the
> end:
>
> --8<---------------cut here---------------start------------->8---
> (define bepo-evdev
> "Section \"InputClass\"
> Identifier \"evdev keyboard catchall\"
> Driver \"evdev\"
> MatchIsKeyboard \"on\"
> Option \"xkb_layout\" \"fr\"
> Option \"xkb_variant\" \"bepo\"
> EndSection")
>
> (operating-system
> ...
> (services
> (modify-services %desktop-services
> (slim-service-type config =>
> (slim-configuration
> (inherit config)
> (startx (xorg-start-command
> #:configuration-file
> (xorg-configuration-file
> #:extra-config
> (list bepo-evdev)))))))))
> --8<---------------cut here---------------end--------------->8---
>
> The above example only details keyboard configuration. For your
> trackpad, have a look at libinput's manpage.
> Also https://wiki.archlinux.org/index.php/Libinput may give you a
> good coverage of the topic.
I've been having the same problem on my Think Penguin laptop, and since
seeing this email, I've tried modifying my config.scm unsuccessfully.
I've run the reconfigure command and rebooted. Here is my services
field:
---BEGIN---
(services
(cons* (gnome-desktop-service) (console-keymap-service "dvorak")
(extra-special-file "/usr/bin/env" (file-append coreutils
"/bin/env")) (modify-services %desktop-services
(slim-service-type config =>
(slim-configuration
(inherit config)
(startx
(xorg-start-command
#:configuration-file
(xorg-configuration-file
#:extra-config
'(
"Section \"InputClass\"
Identifier \"keyboard-all\"
Option \"XkbLayout\" \"dvorak\"
MatchIsKeyboard \"on\"
EndSection
Section \"InputClass\"
Identifier \"touchpad-all\"
MatchIsTouchpad \"on\"
Option \"DisableWhileTyping\" \"on\"
Option \"Tapping\" \"on\"
EndSection"
))))))
(guix-service-type config =>
(guix-configuration
(inherit config)
(substitute-urls
(list
"https://berlin.guixsd.org"
"https://mirror.hydra.gnu.org"
"https://hydra.gnu.org")))))))
---END---
Neither DisableWhileTyping nor Tapping has any effect. I also set the
corresponding settings in Gnome Tweaks > Keyboard & Mouse > Touchpad.
If I need a Driver field or some specific Identifier, I haven't been
able to find a way to determine the correct info for those fields.
Luther