[PATCH] gnu: Add jp2a.

  • Done
  • quality assurance status badge
Details
2 participants
  • Pierre-Antoine Rouby
  • Ludovic Courtès
Owner
unassigned
Submitted by
Pierre-Antoine Rouby
Severity
normal
P
P
Pierre-Antoine Rouby wrote on 25 Oct 2018 12:28
(address . guix-patches@gnu.org)(name . Pierre-Antoine Rouby)(address . contact@parouby.fr)
20181025102816.20497-1-contact@parouby.fr
* gnu/packages/image.scm: New variable.
---
gnu/packages/image.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index b367e0799..6e3c6cc18 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,6 +44,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
@@ -1497,3 +1499,29 @@ Two other programs are included with Gifsicle: @command{gifview} is a
lightweight animated-GIF viewer, and @command{gifdiff} compares two GIFs for
identical visual appearance.")
(license license:gpl2+)))
+
+(define-public jp2a
+ (package
+ (name "jp2a")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/cslarsen/jp2a/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nahpjvrahixcfqqrjj2k4fscc8qs4hqnmj2qgjzsjj3z6xxh2g5"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libjpeg" ,libjpeg)
+ ("curl" ,curl)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://csl.name/jp2a/")
+ (synopsis "Converts JPG images to ASCII")
+ (description "Jp2a is a small utility that converts JPG images to
+ASCII.")
+ (license license:gpl2)))
--
2.19.1
L
L
Ludovic Courtès wrote on 26 Oct 2018 21:13
(name . Pierre-Antoine Rouby)(address . contact@parouby.fr)(address . 33148-done@debbugs.gnu.org)
87woq4bjwv.fsf@gnu.org
Hello Pierre-Antoine!

Pierre-Antoine Rouby <contact@parouby.fr> skribis:

Toggle quote (2 lines)
> * gnu/packages/image.scm: New variable.

Applied with the minor changes below. Thank you! :-)

Ludo’.
Toggle diff (25 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 6e3c6cc18f..9bf9bd7e5e 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1511,7 +1511,8 @@ identical visual appearance.")
version ".tar.gz"))
(sha256
(base32
- "0nahpjvrahixcfqqrjj2k4fscc8qs4hqnmj2qgjzsjj3z6xxh2g5"))))
+ "0nahpjvrahixcfqqrjj2k4fscc8qs4hqnmj2qgjzsjj3z6xxh2g5"))
+ (file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(inputs
`(("libjpeg" ,libjpeg)
@@ -1521,7 +1522,7 @@ identical visual appearance.")
("automake" ,automake)
("pkg-config" ,pkg-config)))
(home-page "https://csl.name/jp2a/")
- (synopsis "Converts JPG images to ASCII")
- (description "Jp2a is a small utility that converts JPG images to
-ASCII.")
+ (synopsis "Convert JPEG images to ASCII")
+ (description
+ "Jp2a is a small utility that converts JPEG images to ASCII.")
(license license:gpl2)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33148@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33148
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch