Indeterministic test failure in python2

  • Done
  • quality assurance status badge
Details
3 participants
  • Gábor Boskovits
  • Joshua Branson
  • Ludovic Courtès
Owner
Somebody
Submitted by
Joshua Branson
Severity
normal
J
J
Joshua Branson wrote on 18 Oct 2018 16:58
guix pull resulted in an error: compute-guix-derivation
(address . bug-guix@gnu.org)
8736t3713o.fsf@fastmail.com
Here is a copy of the failed guix pull command. It's just the tail end
of the error message. Some details about my machine. I'm running
Parabola GNU/Linux. I installed guix via the install guix script. I
have a Macbook 7,1 (2010). I did notice many warning messages that
said, "Cannot find python3".

However,

$ pacman -Q python3
python 3.7.0-4

$ which python3
/usr/bin/python3


Anyway, here's the error messages. It seemed like guix was trying to
build python3, and failed.


Total duration: 8 min 47 sec
Tests result: FAILURE
make: *** [Makefile:869: test] Error 2

Test suite failed, dumping logs.
Backtrace:
\ 4 (primitive-load "/gnu/store/nh1m265kg7ddar7jgwd7dh8f8y7???")
In ice-9/eval.scm:
191:35 3 (_ _)
In srfi/srfi-1.scm:
640:9 2 (for-each #<procedure b84680 at /gnu/store/f95ghy8mx00???> ???)
In /gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:
799:31 1 (_ _)
369:6 0 (check #:target _ #:make-flags _ #:tests? _ # _ # _ # _)

/gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:369:6: In procedure check:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "make" arguments: ("test" "-j" "2") exit-status: 2 term-signal: #f stop-signal: #f] b8a840>)'.
builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1
@ build-failed /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv - 1 builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1
Backtrace:
18 (primitive-load "/gnu/store/5ns8ygdfzr0rzsiy92qw3im2lga???")
In ice-9/eval.scm:
155:9 17 (_ _)
159:9 16 (_ #(#(#(#(#(#(#(#(#(#(#(???) ???) ???) ???) ???) ???) ???) ???) ???) ???) ???))
In guix/store.scm:
1605:24 15 (run-with-store _ _ #:guile-for-build _ #:system _ # _)
In guix/gexp.scm:
684:2 14 (_ _)
In guix/monads.scm:
485:9 13 (_ _)
In guix/gexp.scm:
550:22 12 (_ _)
684:2 11 (_ _)
In guix/monads.scm:
485:9 10 (_ _)
In guix/gexp.scm:
550:22 9 (_ _)
684:2 8 (_ _)
In guix/monads.scm:
485:9 7 (_ _)
In guix/gexp.scm:
550:22 6 (_ _)
In guix/store.scm:
1501:38 5 (_ #<build-daemon 256.97 d26f50>)
In guix/packages.scm:
881:14 4 (cache! #<weak-table 453/883> #<package guile-gcrypt@0???> ???)
In unknown file:
3 (_ #<procedure thunk ()> #<procedure list _> #<undefined>)
In guix/packages.scm:
1205:22 2 (thunk)
1138:25 1 (bag->derivation #<build-daemon 256.97 d26f50> #<<bag>???> ???)
In srfi/srfi-1.scm:
592:17 0 (map1 (("source" #<origin #<<git-reference> url: "???>) ???))

srfi/srfi-1.scm:592:17: In procedure map1:
Throw to key `srfi-34' with args `(#<condition &nix-protocol-error [message: "build of `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed" status: 100] 60a4660>)'.
guix pull: error: You found a bug: the program '/gnu/store/5ns8ygdfzr0rzsiy92qw3im2lgakq802-compute-guix-derivation'
failed to compute the derivation for Guix (version: "39d7fdce453b0ca23ecbed72048647debbaa58a6"; system: "x86_64-linux";
host version: "82402f76bebfa3bb563a58227eb4081f9bdb6142"; pull-version: 1).
Please report it by email to <bug-guix@gnu.org>.
G
G
Gábor Boskovits wrote on 18 Oct 2018 17:23
(name . Joshua Branson)(address . jbranso@fastmail.com)(address . 33082@debbugs.gnu.org)
CAE4v=ph5cv0=8O9Jf+opT_y_n7kDjpHPyHGH9N7wUgEV8ROjNQ@mail.gmail.com
Hello Joshua,

Thanks for the report.

Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
18., Cs, 16:51):
Toggle quote (42 lines)
>
>
>
> Here is a copy of the failed guix pull command. It's just the tail end
> of the error message. Some details about my machine. I'm running
> Parabola GNU/Linux. I installed guix via the install guix script. I
> have a Macbook 7,1 (2010). I did notice many warning messages that
> said, "Cannot find python3".
>
> However,
>
> $ pacman -Q python3
> python 3.7.0-4
>
> $ which python3
> /usr/bin/python3
>
>
> Anyway, here's the error messages. It seemed like guix was trying to
> build python3, and failed.
>
>
> Total duration: 8 min 47 sec
> Tests result: FAILURE
> make: *** [Makefile:869: test] Error 2
>
> Test suite failed, dumping logs.
> Backtrace:
> \ 4 (primitive-load "/gnu/store/nh1m265kg7ddar7jgwd7dh8f8y7???")
> In ice-9/eval.scm:
> 191:35 3 (_ _)
> In srfi/srfi-1.scm:
> 640:9 2 (for-each #<procedure b84680 at /gnu/store/f95ghy8mx00???> ???)
> In /gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:
> 799:31 1 (_ _)
> 369:6 0 (check #:target _ #:make-flags _ #:tests? _ # _ # _ # _)
>
> /gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:369:6: In procedure check:
> Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "make" arguments: ("test" "-j" "2") exit-status: 2 term-signal: #f stop-signal: #f] b8a840>)'.
> builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1
> @ build-failed /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv - 1 builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1

It was trying to build python2, and tests failed.
Could you retry this to see if it is a persistent failure, or the
tests are failing indeterministically?

Toggle quote (44 lines)
> Backtrace:
> 18 (primitive-load "/gnu/store/5ns8ygdfzr0rzsiy92qw3im2lga???")
> In ice-9/eval.scm:
> 155:9 17 (_ _)
> 159:9 16 (_ #(#(#(#(#(#(#(#(#(#(#(???) ???) ???) ???) ???) ???) ???) ???) ???) ???) ???))
> In guix/store.scm:
> 1605:24 15 (run-with-store _ _ #:guile-for-build _ #:system _ # _)
> In guix/gexp.scm:
> 684:2 14 (_ _)
> In guix/monads.scm:
> 485:9 13 (_ _)
> In guix/gexp.scm:
> 550:22 12 (_ _)
> 684:2 11 (_ _)
> In guix/monads.scm:
> 485:9 10 (_ _)
> In guix/gexp.scm:
> 550:22 9 (_ _)
> 684:2 8 (_ _)
> In guix/monads.scm:
> 485:9 7 (_ _)
> In guix/gexp.scm:
> 550:22 6 (_ _)
> In guix/store.scm:
> 1501:38 5 (_ #<build-daemon 256.97 d26f50>)
> In guix/packages.scm:
> 881:14 4 (cache! #<weak-table 453/883> #<package guile-gcrypt@0???> ???)
> In unknown file:
> 3 (_ #<procedure thunk ()> #<procedure list _> #<undefined>)
> In guix/packages.scm:
> 1205:22 2 (thunk)
> 1138:25 1 (bag->derivation #<build-daemon 256.97 d26f50> #<<bag>???> ???)
> In srfi/srfi-1.scm:
> 592:17 0 (map1 (("source" #<origin #<<git-reference> url: "???>) ???))
>
> srfi/srfi-1.scm:592:17: In procedure map1:
> Throw to key `srfi-34' with args `(#<condition &nix-protocol-error [message: "build of `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed" status: 100] 60a4660>)'.
> guix pull: error: You found a bug: the program '/gnu/store/5ns8ygdfzr0rzsiy92qw3im2lgakq802-compute-guix-derivation'
> failed to compute the derivation for Guix (version: "39d7fdce453b0ca23ecbed72048647debbaa58a6"; system: "x86_64-linux";
> host version: "82402f76bebfa3bb563a58227eb4081f9bdb6142"; pull-version: 1).
> Please report it by email to <bug-guix@gnu.org>.
>
>
>
Best regards,
g_bor
L
L
Ludovic Courtès wrote on 19 Oct 2018 11:11
(name . Gábor Boskovits)(address . boskovits@gmail.com)
877eiei9n2.fsf@gnu.org
Hello,

Gábor Boskovits <boskovits@gmail.com> skribis:

Toggle quote (3 lines)
> Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
> 18., Cs, 16:51):

[...]

Toggle quote (24 lines)
>> Total duration: 8 min 47 sec
>> Tests result: FAILURE
>> make: *** [Makefile:869: test] Error 2
>>
>> Test suite failed, dumping logs.
>> Backtrace:
>> \ 4 (primitive-load "/gnu/store/nh1m265kg7ddar7jgwd7dh8f8y7???")
>> In ice-9/eval.scm:
>> 191:35 3 (_ _)
>> In srfi/srfi-1.scm:
>> 640:9 2 (for-each #<procedure b84680 at /gnu/store/f95ghy8mx00???> ???)
>> In /gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:
>> 799:31 1 (_ _)
>> 369:6 0 (check #:target _ #:make-flags _ #:tests? _ # _ # _ # _)
>>
>> /gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:369:6: In procedure check:
>> Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "make" arguments: ("test" "-j" "2") exit-status: 2 term-signal: #f stop-signal: #f] b8a840>)'.
>> builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1
>> @ build-failed /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv - 1 builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1
>
> It was trying to build python2, and tests failed.
> Could you retry this to see if it is a persistent failure, or the
> tests are failing indeterministically?

Specifically, could you try running:

guix build /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv

?

If you enabled substitutes (pre-built binaries) you should now be
getting substitutes for this.

If that is the case, you can go ahead and rerun ‘guix pull’.

(This doesn’t tell us why you were getting test failures in the first
place, but that’s a separate issue.)

HTH,
Ludo’.
J
J
Joshua Branson wrote on 19 Oct 2018 17:59
(address . bug-guix@gnu.org)
1539964762.2162108.1547911576.742F013B@webmail.messagingengine.com
Well, I thought I'd try to enable substitutes...

[root@dobby guix]# pwd
/var/guix/profiles/per-user/root/guix-profile/share/guix

guix archive --authorize berlin.guixsd.org.pub

This commands has been hanging (doing nothing, as far I can tell) for 5+ minutes. That sounds non-normal.

On Fri, Oct 19, 2018, at 2:11 AM, Ludovic Courtès wrote:
Toggle quote (52 lines)
> Hello,
>
> Gábor Boskovits <boskovits@gmail.com> skribis:
>
> > Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
> > 18., Cs, 16:51):
>
> [...]
>
> >> Total duration: 8 min 47 sec
> >> Tests result: FAILURE
> >> make: *** [Makefile:869: test] Error 2
> >>
> >> Test suite failed, dumping logs.
> >> Backtrace:
> >> \ 4 (primitive-load "/gnu/store/nh1m265kg7ddar7jgwd7dh8f8y7???")
> >> In ice-9/eval.scm:
> >> 191:35 3 (_ _)
> >> In srfi/srfi-1.scm:
> >> 640:9 2 (for-each #<procedure b84680 at /gnu/store/f95ghy8mx00???> ???)
> >> In /gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:
> >> 799:31 1 (_ _)
> >> 369:6 0 (check #:target _ #:make-flags _ #:tests? _ # _ # _ # _)
> >>
> >> /gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:369:6: In procedure check:
> >> Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "make" arguments: ("test" "-j" "2") exit-status: 2 term-signal: #f stop-signal: #f] b8a840>)'.
> >> builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1
> >> @ build-failed /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv - 1 builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1
> >
> > It was trying to build python2, and tests failed.
> > Could you retry this to see if it is a persistent failure, or the
> > tests are failing indeterministically?
>
> Specifically, could you try running:
>
> guix build /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv
>
> ?
>
> If you enabled substitutes (pre-built binaries) you should now be
> getting substitutes for this.
>
> If that is the case, you can go ahead and rerun ‘guix pull’.
>
> (This doesn’t tell us why you were getting test failures in the first
> place, but that’s a separate issue.)
>
> HTH,
> Ludo’.
>
>
>
J
J
Joshua Branson wrote on 19 Oct 2018 19:09
(address . bug-guix@gnu.org)
87k1mdrhhj.fsf@fastmail.com
Joshua Branson <jbranso@fastmail.com> writes:

Toggle quote (9 lines)
> Well, I thought I'd try to enable substitutes...
>
> [root@dobby guix]# pwd
> /var/guix/profiles/per-user/root/guix-profile/share/guix
>
> guix archive --authorize berlin.guixsd.org.pub
>
> This commands has been hanging (doing nothing, as far I can tell) for 5+ minutes. That sounds non-normal.

Ahh I forgot the "<".

guix archive --authorize < berlin.guixsd.org.pub


So now I am definitely using substitutes. I only have a few minutes
before I need to go to work, so I don't think "guix pull" will have
enough time to finish. I'll have to try again tomorrow.



Toggle quote (54 lines)
>
> On Fri, Oct 19, 2018, at 2:11 AM, Ludovic Courtès wrote:
>> Hello,
>>
>> Gábor Boskovits <boskovits@gmail.com> skribis:
>>
>> > Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
>> > 18., Cs, 16:51):
>>
>> [...]
>>
>> >> Total duration: 8 min 47 sec
>> >> Tests result: FAILURE
>> >> make: *** [Makefile:869: test] Error 2
>> >>
>> >> Test suite failed, dumping logs.
>> >> Backtrace:
>> >> \ 4 (primitive-load "/gnu/store/nh1m265kg7ddar7jgwd7dh8f8y7???")
>> >> In ice-9/eval.scm:
>> >> 191:35 3 (_ _)
>> >> In srfi/srfi-1.scm:
>> >> 640:9 2 (for-each #<procedure b84680 at /gnu/store/f95ghy8mx00???> ???)
>> >> In /gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:
>> >> 799:31 1 (_ _)
>> >> 369:6 0 (check #:target _ #:make-flags _ #:tests? _ # _ # _ # _)
>> >>
>> >> /gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:369:6: In procedure check:
>> >> Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "make" arguments: ("test" "-j" "2") exit-status: 2 term-signal: #f stop-signal: #f] b8a840>)'.
>> >> builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1
>> >> @ build-failed /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv - 1 builder for `/gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv' failed with exit code 1
>> >
>> > It was trying to build python2, and tests failed.
>> > Could you retry this to see if it is a persistent failure, or the
>> > tests are failing indeterministically?
>>
>> Specifically, could you try running:
>>
>> guix build /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv
>>
>> ?
>>
>> If you enabled substitutes (pre-built binaries) you should now be
>> getting substitutes for this.
>>
>> If that is the case, you can go ahead and rerun ‘guix pull’.
>>
>> (This doesn’t tell us why you were getting test failures in the first
>> place, but that’s a separate issue.)
>>
>> HTH,
>> Ludo’.
>>
>>
>>
L
L
Ludovic Courtès wrote on 20 Oct 2018 12:06
(name . Joshua Branson)(address . jbranso@fastmail.com)(address . 33082@debbugs.gnu.org)
87o9bpaq4i.fsf@gnu.org
Hello,

Joshua Branson <jbranso@fastmail.com> skribis:

Toggle quote (15 lines)
> Joshua Branson <jbranso@fastmail.com> writes:
>
>> Well, I thought I'd try to enable substitutes...
>>
>> [root@dobby guix]# pwd
>> /var/guix/profiles/per-user/root/guix-profile/share/guix
>>
>> guix archive --authorize berlin.guixsd.org.pub
>>
>> This commands has been hanging (doing nothing, as far I can tell) for 5+ minutes. That sounds non-normal.
>
> Ahh I forgot the "<".
>
> guix archive --authorize < berlin.guixsd.org.pub

Note that this authorizes the use of substitutes coming from
berlin.guixsd.org, but you also need to tell guix-daemon or your guix
command to actually fetch substitutes from https://berlin.guixsd.org.
You can do that with the --substitute-urls option:


Let us know how it goes!

Ludo’.
J
J
Joshua Branson wrote on 29 Oct 2018 16:09
(address . bug-guix@gnu.org)
878t2grdqb.fsf@fastmail.com
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (3 lines)
> Hello,
>

I was able to update successfully. This bug seems like a duplicate of
python 2 not deterministic. Someone ought to close this bug report.

Toggle quote (27 lines)
> Joshua Branson <jbranso@fastmail.com> skribis:
>
>> Joshua Branson <jbranso@fastmail.com> writes:
>>
>>> Well, I thought I'd try to enable substitutes...
>>>
>>> [root@dobby guix]# pwd
>>> /var/guix/profiles/per-user/root/guix-profile/share/guix
>>>
>>> guix archive --authorize berlin.guixsd.org.pub
>>>
>>> This commands has been hanging (doing nothing, as far I can tell) for 5+ minutes. That sounds non-normal.
>>
>> Ahh I forgot the "<".
>>
>> guix archive --authorize < berlin.guixsd.org.pub
>
> Note that this authorizes the use of substitutes coming from
> berlin.guixsd.org, but you also need to tell guix-daemon or your guix
> command to actually fetch substitutes from https://berlin.guixsd.org.
> You can do that with the --substitute-urls option:
>
> https://www.gnu.org/software/guix/manual/en/html_node/Substitutes.html
>
> Let us know how it goes!
>
> Ludo’.
G
G
Gábor Boskovits wrote on 29 Oct 2018 16:12
(name . Joshua Branson)(address . jbranso@fastmail.com)(address . 33082@debbugs.gnu.org)
CAE4v=pg0v5Seee0MMm=L9E42L2pKA3y8BC424w-erYPWw9BvWQ@mail.gmail.com
Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt. 29., H
15:54):

Toggle quote (9 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
> > Hello,
> >
>
> I was able to update successfully. This bug seems like a duplicate of
> python 2 not deterministic. Someone ought to close this bug report.
>

I believe this is not the case, usually non deterministic means the build
is not reproducible, while this is a non-deterministic test failure. I
would suggest keeping this bug open, if I am right, maybe renaming to
non-deterministic test failure in python2. What do you think?

Toggle quote (33 lines)
>
> > Joshua Branson <jbranso@fastmail.com> skribis:
> >
> >> Joshua Branson <jbranso@fastmail.com> writes:
> >>
> >>> Well, I thought I'd try to enable substitutes...
> >>>
> >>> [root@dobby guix]# pwd
> >>> /var/guix/profiles/per-user/root/guix-profile/share/guix
> >>>
> >>> guix archive --authorize berlin.guixsd.org.pub
> >>>
> >>> This commands has been hanging (doing nothing, as far I can tell) for
> 5+ minutes. That sounds non-normal.
> >>
> >> Ahh I forgot the "<".
> >>
> >> guix archive --authorize < berlin.guixsd.org.pub
> >
> > Note that this authorizes the use of substitutes coming from
> > berlin.guixsd.org, but you also need to tell guix-daemon or your guix
> > command to actually fetch substitutes from https://berlin.guixsd.org.
> > You can do that with the --substitute-urls option:
> >
> > https://www.gnu.org/software/guix/manual/en/html_node/Substitutes.html
> >
> > Let us know how it goes!
> >
> > Ludo’.
>
>
>
>
Attachment: file
J
J
Joshua Branson wrote on 30 Oct 2018 13:59
(address . bug-guix@gnu.org)
87o9bbfv3x.fsf@fastmail.com
Gábor Boskovits <boskovits@gmail.com> writes:

Toggle quote (13 lines)
> Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt. 29., H 15:54):
>
> ludo@gnu.org (Ludovic Courtès) writes:
>
> > Hello,
> >
>
> I was able to update successfully. This bug seems like a duplicate of
> python 2 not deterministic. Someone ought to close this bug report.
>
> I believe this is not the case, usually non deterministic means the build is not reproducible, while this is a non-deterministic test failure. I would suggest
> keeping this bug open, if I am right, maybe renaming to non-deterministic test failure in python2. What do you think?

Fair enough. Since I made the bug report, then I should try to build it
again and see what happens.

Toggle quote (28 lines)
>
> > Joshua Branson <jbranso@fastmail.com> skribis:
> >
> >> Joshua Branson <jbranso@fastmail.com> writes:
> >>
> >>> Well, I thought I'd try to enable substitutes...
> >>>
> >>> [root@dobby guix]# pwd
> >>> /var/guix/profiles/per-user/root/guix-profile/share/guix
> >>>
> >>> guix archive --authorize berlin.guixsd.org.pub
> >>>
> >>> This commands has been hanging (doing nothing, as far I can tell) for 5+ minutes. That sounds non-normal.
> >>
> >> Ahh I forgot the "<".
> >>
> >> guix archive --authorize < berlin.guixsd.org.pub
> >
> > Note that this authorizes the use of substitutes coming from
> > berlin.guixsd.org, but you also need to tell guix-daemon or your guix
> > command to actually fetch substitutes from https://berlin.guixsd.org.
> > You can do that with the --substitute-urls option:
> >
> > https://www.gnu.org/software/guix/manual/en/html_node/Substitutes.html
> >
> > Let us know how it goes!
> >
> > Ludo’.
G
G
Gábor Boskovits wrote on 30 Oct 2018 13:57
(name . Joshua Branson)(address . jbranso@fastmail.com)(address . 33082@debbugs.gnu.org)
CAE4v=pg2feYUnnP+g51PDPUSg-wTsG+S5V4ssB1skw-ukmjY0g@mail.gmail.com
Hello Joshua,

Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
30., K, 13:44):
Toggle quote (20 lines)
>
> Gábor Boskovits <boskovits@gmail.com> writes:
>
> > Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt. 29., H 15:54):
> >
> > ludo@gnu.org (Ludovic Courtès) writes:
> >
> > > Hello,
> > >
> >
> > I was able to update successfully. This bug seems like a duplicate of
> > python 2 not deterministic. Someone ought to close this bug report.
> >
> > I believe this is not the case, usually non deterministic means the build is not reproducible, while this is a non-deterministic test failure. I would suggest
> > keeping this bug open, if I am right, maybe renaming to non-deterministic test failure in python2. What do you think?
>
> Fair enough. Since I made the bug report, then I should try to build it
> again and see what happens.
>

Thanks for having a look, please make sure to use guix build -K, so
that the failed build results are retained.
If you can't trigger the failure, then I will try to do this later.

Best regards,
g_bor
J
J
Joshua Branson wrote on 30 Oct 2018 16:15
(address . bug-guix@gnu.org)
87tvl3h3er.fsf@fastmail.com
Gábor Boskovits <boskovits@gmail.com> writes:

Toggle quote (29 lines)
> Hello Joshua,
>
> Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
> 30., K, 13:44):
>>
>> Gábor Boskovits <boskovits@gmail.com> writes:
>>
>> > Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt. 29., H 15:54):
>> >
>> > ludo@gnu.org (Ludovic Courtès) writes:
>> >
>> > > Hello,
>> > >
>> >
>> > I was able to update successfully. This bug seems like a duplicate of
>> > python 2 not deterministic. Someone ought to close this bug report.
>> >
>> > I believe this is not the case, usually non deterministic means the build is not reproducible, while this is a
>> > non-deterministic test failure. I would suggest
>> > keeping this bug open, if I am right, maybe renaming to non-deterministic test failure in python2. What do you think?
>>
>> Fair enough. Since I made the bug report, then I should try to build it
>> again and see what happens.
>>
>
> Thanks for having a look, please make sure to use guix build -K, so
> that the failed build results are retained.
> If you can't trigger the failure, then I will try to do this later.

I was able to build this successfully:

guix build -K /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv


Collecting setuptools
Collecting pip
Installing collected packages: setuptools, pip
Successfully installed pip-9.0.1 setuptools-28.8.0
phase `install' succeeded after 32.6 seconds
starting phase `move-tk-inter'
phase `move-tk-inter' succeeded after 0.2 seconds
starting phase `remove-tests'
phase `remove-tests' succeeded after 0.8 seconds
starting phase `patch-shebangs'
phase `patch-shebangs' succeeded after 0.0 seconds
starting phase `make-libraries-writable'
phase `make-libraries-writable' succeeded after 0.1 seconds
starting phase `strip'
stripping binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/lib" with "strip" and flags ("--strip-debug" "--enable-deterministic-archives")
stripping binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/bin" with "strip" and flags ("--strip-debug" "--enable-deterministic-archives")
stripping binaries in "/gnu/store/z0r8jiimjgdg2sl3h9ad9z1v1i95752v-python2-2.7.14-tk/lib" with "strip" and flags ("--strip-debug" "--enable-deterministic-archives")
phase `strip' succeeded after 2.9 seconds
starting phase `validate-runpath'
validating RUNPATH of 64 binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/lib"...
validating RUNPATH of 1 binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/bin"...
validating RUNPATH of 1 binaries in "/gnu/store/z0r8jiimjgdg2sl3h9ad9z1v1i95752v-python2-2.7.14-tk/lib"...
phase `validate-runpath' succeeded after 1.1 seconds
starting phase `validate-documentation-location'
phase `validate-documentation-location' succeeded after 0.0 seconds
starting phase `delete-info-dir-file'
phase `delete-info-dir-file' succeeded after 0.0 seconds
starting phase `patch-dot-desktop-files'
phase `patch-dot-desktop-files' succeeded after 0.0 seconds
starting phase `install-license-files'
installing 1 license files
phase `install-license-files' succeeded after 0.0 seconds
starting phase `reset-gzip-timestamps'
phase `reset-gzip-timestamps' succeeded after 0.1 seconds
starting phase `compress-documentation'
compressing documentation in '/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/share/man' with "gzip" and flags ("--best" "--no-name")
phase `compress-documentation' succeeded after 0.1 seconds
successfully built /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv
/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14
/gnu/store/z0r8jiimjgdg2sl3h9ad9z1v1i95752v-python2-2.7.14-tk


I suppose now we can close this bug report, since I can't reproduce the
error?

Thanks

Toggle quote (3 lines)
>
> Best regards,
> g_bor
G
G
Gábor Boskovits wrote on 30 Oct 2018 17:18
(name . Joshua Branson)(address . jbranso@fastmail.com)(address . 33082@debbugs.gnu.org)
CAE4v=pgv8XgGBQeq1DJQpechB+h=EA1c2j3sgMWv6XzOkCXG2Q@mail.gmail.com
Hello Joshua,

Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
30., K, 16:10):
Toggle quote (83 lines)
>
> Gábor Boskovits <boskovits@gmail.com> writes:
>
> > Hello Joshua,
> >
> > Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
> > 30., K, 13:44):
> >>
> >> Gábor Boskovits <boskovits@gmail.com> writes:
> >>
> >> > Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt. 29., H 15:54):
> >> >
> >> > ludo@gnu.org (Ludovic Courtès) writes:
> >> >
> >> > > Hello,
> >> > >
> >> >
> >> > I was able to update successfully. This bug seems like a duplicate of
> >> > python 2 not deterministic. Someone ought to close this bug report.
> >> >
> >> > I believe this is not the case, usually non deterministic means the build is not reproducible, while this is a
> >> > non-deterministic test failure. I would suggest
> >> > keeping this bug open, if I am right, maybe renaming to non-deterministic test failure in python2. What do you think?
> >>
> >> Fair enough. Since I made the bug report, then I should try to build it
> >> again and see what happens.
> >>
> >
> > Thanks for having a look, please make sure to use guix build -K, so
> > that the failed build results are retained.
> > If you can't trigger the failure, then I will try to do this later.
>
> I was able to build this successfully:
>
> guix build -K /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv
>
>
> Collecting setuptools
> Collecting pip
> Installing collected packages: setuptools, pip
> Successfully installed pip-9.0.1 setuptools-28.8.0
> phase `install' succeeded after 32.6 seconds
> starting phase `move-tk-inter'
> phase `move-tk-inter' succeeded after 0.2 seconds
> starting phase `remove-tests'
> phase `remove-tests' succeeded after 0.8 seconds
> starting phase `patch-shebangs'
> phase `patch-shebangs' succeeded after 0.0 seconds
> starting phase `make-libraries-writable'
> phase `make-libraries-writable' succeeded after 0.1 seconds
> starting phase `strip'
> stripping binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/lib" with "strip" and flags ("--strip-debug" "--enable-deterministic-archives")
> stripping binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/bin" with "strip" and flags ("--strip-debug" "--enable-deterministic-archives")
> stripping binaries in "/gnu/store/z0r8jiimjgdg2sl3h9ad9z1v1i95752v-python2-2.7.14-tk/lib" with "strip" and flags ("--strip-debug" "--enable-deterministic-archives")
> phase `strip' succeeded after 2.9 seconds
> starting phase `validate-runpath'
> validating RUNPATH of 64 binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/lib"...
> validating RUNPATH of 1 binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/bin"...
> validating RUNPATH of 1 binaries in "/gnu/store/z0r8jiimjgdg2sl3h9ad9z1v1i95752v-python2-2.7.14-tk/lib"...
> phase `validate-runpath' succeeded after 1.1 seconds
> starting phase `validate-documentation-location'
> phase `validate-documentation-location' succeeded after 0.0 seconds
> starting phase `delete-info-dir-file'
> phase `delete-info-dir-file' succeeded after 0.0 seconds
> starting phase `patch-dot-desktop-files'
> phase `patch-dot-desktop-files' succeeded after 0.0 seconds
> starting phase `install-license-files'
> installing 1 license files
> phase `install-license-files' succeeded after 0.0 seconds
> starting phase `reset-gzip-timestamps'
> phase `reset-gzip-timestamps' succeeded after 0.1 seconds
> starting phase `compress-documentation'
> compressing documentation in '/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/share/man' with "gzip" and flags ("--best" "--no-name")
> phase `compress-documentation' succeeded after 0.1 seconds
> successfully built /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv
> /gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14
> /gnu/store/z0r8jiimjgdg2sl3h9ad9z1v1i95752v-python2-2.7.14-tk
>
>
> I suppose now we can close this bug report, since I can't reproduce the
> error?
>

Please leave this open, until I can have a closer look. I will take
ownership of this bug.

Toggle quote (9 lines)
> Thanks
>
> >
> > Best regards,
> > g_bor
>
>
>

Best regards,
g_bor
J
J
Joshua Branson wrote on 30 Oct 2018 18:12
(address . bug-guix@gnu.org)
87bm7bgxzx.fsf@fastmail.com
Gábor Boskovits <boskovits@gmail.com> writes:

Toggle quote (95 lines)
> Hello Joshua,
>
> Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
> 30., K, 16:10):
>>
>> Gábor Boskovits <boskovits@gmail.com> writes:
>>
>> > Hello Joshua,
>> >
>> > Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt.
>> > 30., K, 13:44):
>> >>
>> >> Gábor Boskovits <boskovits@gmail.com> writes:
>> >>
>> >> > Joshua Branson <jbranso@fastmail.com> ezt írta (id?pont: 2018. okt. 29., H 15:54):
>> >> >
>> >> > ludo@gnu.org (Ludovic Courtès) writes:
>> >> >
>> >> > > Hello,
>> >> > >
>> >> >
>> >> > I was able to update successfully. This bug seems like a duplicate of
>> >> > python 2 not deterministic. Someone ought to close this bug report.
>> >> >
>> >> > I believe this is not the case, usually non deterministic means the build is not reproducible, while this is a
>> >> > non-deterministic test failure. I would suggest
>> >> > keeping this bug open, if I am right, maybe renaming to non-deterministic test failure in python2. What do you think?
>> >>
>> >> Fair enough. Since I made the bug report, then I should try to build it
>> >> again and see what happens.
>> >>
>> >
>> > Thanks for having a look, please make sure to use guix build -K, so
>> > that the failed build results are retained.
>> > If you can't trigger the failure, then I will try to do this later.
>>
>> I was able to build this successfully:
>>
>> guix build -K /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv
>>
>>
>> Collecting setuptools
>> Collecting pip
>> Installing collected packages: setuptools, pip
>> Successfully installed pip-9.0.1 setuptools-28.8.0
>> phase `install' succeeded after 32.6 seconds
>> starting phase `move-tk-inter'
>> phase `move-tk-inter' succeeded after 0.2 seconds
>> starting phase `remove-tests'
>> phase `remove-tests' succeeded after 0.8 seconds
>> starting phase `patch-shebangs'
>> phase `patch-shebangs' succeeded after 0.0 seconds
>> starting phase `make-libraries-writable'
>> phase `make-libraries-writable' succeeded after 0.1 seconds
>> starting phase `strip'
>> stripping binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/lib" with "strip" and flags ("--strip-debug"
>> "--enable-deterministic-archives")
>> stripping binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/bin" with "strip" and flags ("--strip-debug"
>> "--enable-deterministic-archives")
>> stripping binaries in "/gnu/store/z0r8jiimjgdg2sl3h9ad9z1v1i95752v-python2-2.7.14-tk/lib" with "strip" and flags
>> ("--strip-debug" "--enable-deterministic-archives")
>> phase `strip' succeeded after 2.9 seconds
>> starting phase `validate-runpath'
>> validating RUNPATH of 64 binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/lib"...
>> validating RUNPATH of 1 binaries in "/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/bin"...
>> validating RUNPATH of 1 binaries in "/gnu/store/z0r8jiimjgdg2sl3h9ad9z1v1i95752v-python2-2.7.14-tk/lib"...
>> phase `validate-runpath' succeeded after 1.1 seconds
>> starting phase `validate-documentation-location'
>> phase `validate-documentation-location' succeeded after 0.0 seconds
>> starting phase `delete-info-dir-file'
>> phase `delete-info-dir-file' succeeded after 0.0 seconds
>> starting phase `patch-dot-desktop-files'
>> phase `patch-dot-desktop-files' succeeded after 0.0 seconds
>> starting phase `install-license-files'
>> installing 1 license files
>> phase `install-license-files' succeeded after 0.0 seconds
>> starting phase `reset-gzip-timestamps'
>> phase `reset-gzip-timestamps' succeeded after 0.1 seconds
>> starting phase `compress-documentation'
>> compressing documentation in '/gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14/share/man' with "gzip" and flags
>> ("--best" "--no-name")
>> phase `compress-documentation' succeeded after 0.1 seconds
>> successfully built /gnu/store/qpvqn6ff2lmfq74ff3i9pz5hrb01p9hw-python2-2.7.14.drv
>> /gnu/store/l7164sj4k77c4bwy9mrqq9d96bxiz4kw-python2-2.7.14
>> /gnu/store/z0r8jiimjgdg2sl3h9ad9z1v1i95752v-python2-2.7.14-tk
>>
>>
>> I suppose now we can close this bug report, since I can't reproduce the
>> error?
>>
>
> Please leave this open, until I can have a closer look. I will take
> ownership of this bug.
>

Sounds like a plan. I wouldn't know how to close it anyway.

Toggle quote (11 lines)
>> Thanks
>>
>> >
>> > Best regards,
>> > g_bor
>>
>>
>>
>
> Best regards,
> g_bor
G
G
Gábor Boskovits wrote on 31 Oct 2018 21:14
Take ownership and try to reproduce this
(address . control@debbugs.gnu.org)
CAE4v=phoTiOrjXAB0Ew-BndbQKVbiSPcyxTu8NC7_oFgEXz1-Q@mail.gmail.com
owner 33082 !
L
L
Ludovic Courtès wrote on 1 Nov 2018 16:11
Re: bug#33082: guix pull resulted in an error: compute-guix-derivation
(name . Gábor Boskovits)(address . boskovits@gmail.com)
87a7msu91h.fsf@gnu.org
Hi Gábor,

Gábor Boskovits <boskovits@gmail.com> skribis:

Toggle quote (3 lines)
> Please leave this open, until I can have a closer look. I will take
> ownership of this bug.

I suggest retitling it since it’s really about Python 2 and not about
‘guix pull’.

Thanks for looking into this, Gábor!

Ludo’.
G
G
Gábor Boskovits wrote on 1 Nov 2018 17:31
Retitle to reflect the real issue
(address . control@debbugs.gnu.org)
CAE4v=phkf68RjDVcgQzXMbTaXmR2nJM37P=6ekZ0h0W1VjNwVA@mail.gmail.com
retitle 33082 Indeterministic test failure in python2
G
G
Gábor Boskovits wrote on 28 Feb 2019 11:09
Indeterministic test failure in python2
(address . 33082-done@debbugs.gnu.org)
CAE4v=piBUZcVBOHQYHcLhrcvrrsw+fR=59pTP0=OZsQKS5HdUg@mail.gmail.com
Hello,

I just had a little time to have a look at this. The test failure was
not triggered in 25 consecutive builds. Also, since the bug was
reported we updated python2.

So either it is hard to reproduce, or it is fixed by the update.

I am closing this now, if anyone experieces the issue again, please
feel free to reopen.
Closed
?