[PATCH] gnu: Add i3blocks.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Meiyo Peng
Owner
unassigned
Submitted by
Meiyo Peng
Severity
normal

Debbugs page

Meiyo Peng wrote 6 years ago
(address . guix-patches@gnu.org)
87pnwa8eow.fsf@gmail.com
Hello,

I created a package for i3blocks. This is my first guix package, so
forgive me if i did anything wrong.


From 6116bec4d60175e2d1fb12da75c803962ddb3ec7 Mon Sep 17 00:00:00 2001
From: Meiyo Peng <meiyo.peng@gmail.com>
Date: Tue, 16 Oct 2018 15:16:43 +0800
Subject: [PATCH] gnu: Add i3blocks.

* gnu/packages/wm.scm (i3blocks): New variable.
---
gnu/packages/wm.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7c58770de..d5e191770 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
+;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -233,6 +234,46 @@ from scratch. i3 is primarily targeted at advanced users and
developers.")
(license license:bsd-3)))
+(define-public i3blocks
+ (let ((commit "37f23805ff886639163fbef8aedba71c8071eff8")
+ (revision "1"))
+ (package
+ (name "i3blocks")
+ (version (string-append "1.4-" revision "."
+ (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vivien/i3blocks.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "15rnrcajzyrmhlz1a21qqsjlj3dkib70806dlb386fliylc2kisb"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _ (invoke "sh" "autogen.sh")))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man1 (string-append out "/share/man/man1")))
+ (install-file "docs/i3blocks.1" man1)))))
+ #:tests? #f))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/vivien/i3blocks")
+ (synopsis "Minimalist scheduler for status bar scripts")
+ (description "i3blocks executes your command lines and generates a
+status line from their output. The generated line is meant to be displayed by
+the i3 window manager through its i3bar component, as an alternative to
+i3status.")
+ (license license:gpl3+))))
+
(define-public perl-anyevent-i3
(package
(name "perl-anyevent-i3")
--
2.19.1
Ludovic Courtès wrote 6 years ago
(name . Meiyo Peng)(address . meiyo.peng@gmail.com)(address . 33058-done@debbugs.gnu.org)
87mur9ekck.fsf@gnu.org
Hi Meiyo,

Meiyo Peng <meiyo.peng@gmail.com> skribis:

Toggle quote (3 lines)
> I created a package for i3blocks. This is my first guix package, so
> forgive me if i did anything wrong.

It looks great to me!

Toggle quote (7 lines)
>>From 6116bec4d60175e2d1fb12da75c803962ddb3ec7 Mon Sep 17 00:00:00 2001
> From: Meiyo Peng <meiyo.peng@gmail.com>
> Date: Tue, 16 Oct 2018 15:16:43 +0800
> Subject: [PATCH] gnu: Add i3blocks.
>
> * gnu/packages/wm.scm (i3blocks): New variable.

I’ve applied it with the minor changes below: leave the default value of
#:tests? (it doesn’t hurt), and return #t in the build phase. That’s
#it!

Thank you for the patch, and welcome! :-)

Ludo’.
Toggle diff (15 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d5e191770..68d497e95 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -260,8 +260,8 @@ developers.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(man1 (string-append out "/share/man/man1")))
- (install-file "docs/i3blocks.1" man1)))))
- #:tests? #f))
+ (install-file "docs/i3blocks.1" man1)
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
Closed
Meiyo Peng wrote 6 years ago
(address . ludo@gnu.org)(address . 33058@debbugs.gnu.org)
871s8ltkr7.fsf@gmail.com
Hi Ludo,

On Fri, Oct 19, 2018 at 8:45 PM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (4 lines)
> I’ve applied it with the minor changes below: leave the default value of
> #:tests? (it doesn’t hurt), and return #t in the build phase. That’s
> #it!

Thank you, Ludo. I will do better next time.

Toggle quote (2 lines)
> Thank you for the patch, and welcome! :-)

I love guix, and I'm migrating all my computers to guix! Thank you for
your contributions to the guix community!

--
Meiyo Peng
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33058@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33058
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help