[PATCH] gnu: csound: Update to 6.11.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • 宋文武
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
87a7nix3c7.fsf@posteo.net
Toggle diff (71 lines)
diff --git a/gnu/packages/astronomy.scm
b/gnu/packages/astronomy.scm
index 3c8b9cc8d..5eb11cddd 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -128,7 +129,7 @@ programs for the manipulation and analysis of
astronomical data.")
(define-public stellarium
(package
(name "stellarium")
- (version "0.18.1")
+ (version "0.18.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/Stellarium/"
name
@@ -136,7 +137,7 @@ programs for the manipulation and analysis of
astronomical data.")
"/" name "-" version ".tar.gz"))
(sha256
(base32
-
"0vjkwrjy22b4wdjkafm63pmb0fck14ffnylpq8xr91ywycw4blrq"))))
+
"1nr8n0v4wa0wfvqqk5kyy1jrv6xnvv4ppfa8l8bklrxbjvpsi0km"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d233940f2..785375295 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2018 okapi <okapi@firemail.cc>
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -650,7 +651,7 @@ emulation (valve, tape), bit fiddling
(decimator, pointer-cast), etc.")
(define-public csound
(package
(name "csound")
- (version "6.09.1")
+ (version "6.11.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -659,7 +660,7 @@ emulation (valve, tape), bit fiddling
(decimator, pointer-cast), etc.")
(file-name (string-append name "-" version
".tar.gz"))
(sha256
(base32
-
"0xqpqws4jsv7fyawcjzwaw544qbfh29xq164kdf30a9v1n3yklp4"))))
+
"072pk5h9w0vhw0ncc9dn90haw1yv18v04iwwjn8nsp6930w7dvxd"))))
(build-system cmake-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
Brett Gilio wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . guix-patches@gnu.org)
87k1mmluil.fsf@posteo.net
Brett Gilio writes:

I made an error on the last patch submission.

Toggle quote (36 lines)
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index d233940f2..785375295 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -13,6 +13,7 @@
> ;;; Copyright © 2018 okapi <okapi@firemail.cc>
> ;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
> +;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -650,7 +651,7 @@ emulation (valve, tape), bit fiddling
> (decimator,
> pointer-cast), etc.")
> (define-public csound
> (package
> (name "csound")
> - (version "6.09.1")
> + (version "6.11.0")
> (source (origin
> (method url-fetch)
> (uri (string-append
> @@ -659,7 +660,7 @@ emulation (valve, tape), bit fiddling
> (decimator,
> pointer-cast), etc.")
> (file-name (string-append name "-" version
> ".tar.gz"))
> (sha256
> (base32
> -
> "0xqpqws4jsv7fyawcjzwaw544qbfh29xq164kdf30a9v1n3yklp4"))))
> + "072pk5h9w0vhw0ncc9dn90haw1yv18v04iwwjn8nsp6930w7dvxd"))))
> (build-system cmake-build-system)
> (inputs
> `(("alsa-lib" ,alsa-lib)
Tobias Geerinckx-Rice wrote 6 years ago
Re: [bug#33028] [PATCH] gnu: csound: Update to 6.11.0
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33028@debbugs.gnu.org)
87ftxac0a8.fsf@tobias.gr
Brett Gilio wrote:
Toggle quote (77 lines)
> diff --git a/gnu/packages/astronomy.scm
> b/gnu/packages/astronomy.scm
> index 3c8b9cc8d..5eb11cddd 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -1,6 +1,7 @@
> ;;; GNU Guix --- Functional package management for GNU
> ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
> ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
> +;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -128,7 +129,7 @@ programs for the manipulation and analysis
> of
> astronomical data.")
> (define-public stellarium
> (package
> (name "stellarium")
> - (version "0.18.1")
> + (version "0.18.2")
> (source (origin
> (method url-fetch)
> (uri (string-append
> "https://github.com/Stellarium/"
> name
> @@ -136,7 +137,7 @@ programs for the manipulation and analysis
> of
> astronomical data.")
> "/" name "-" version
> ".tar.gz"))
> (sha256
> (base32
> -
> "0vjkwrjy22b4wdjkafm63pmb0fck14ffnylpq8xr91ywycw4blrq"))))
> + "1nr8n0v4wa0wfvqqk5kyy1jrv6xnvv4ppfa8l8bklrxbjvpsi0km"))))
> (build-system cmake-build-system)
> (inputs
> `(("qtbase" ,qtbase)
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index d233940f2..785375295 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -13,6 +13,7 @@
> ;;; Copyright © 2018 okapi <okapi@firemail.cc>
> ;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
> +;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -650,7 +651,7 @@ emulation (valve, tape), bit fiddling
> (decimator,
> pointer-cast), etc.")
> (define-public csound
> (package
> (name "csound")
> - (version "6.09.1")
> + (version "6.11.0")
> (source (origin
> (method url-fetch)
> (uri (string-append
> @@ -659,7 +660,7 @@ emulation (valve, tape), bit fiddling
> (decimator,
> pointer-cast), etc.")
> (file-name (string-append name "-" version
> ".tar.gz"))
> (sha256
> (base32
> -
> "0xqpqws4jsv7fyawcjzwaw544qbfh29xq164kdf30a9v1n3yklp4"))))
> + "072pk5h9w0vhw0ncc9dn90haw1yv18v04iwwjn8nsp6930w7dvxd"))))
> (build-system cmake-build-system)
> (inputs
> `(("alsa-lib" ,alsa-lib)


Hmm. How are you generating and sending these patches?

This one includes your previous stellarium patch and both seem to
have indentation issues (the hashes should align, for example).

Kind regards,

T G-R
Tobias Geerinckx-Rice wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33028@debbugs.gnu.org)
87efcuc087.fsf@tobias.gr
Brett,

Brett Gilio wrote:
Toggle quote (4 lines)
> Brett Gilio writes:
>
> I made an error on the last patch submission.

Then you can ignore the first part of my last e-mail :-)

The munging is still a problem, though. Are you using git
send-email?

Kind regards,

T G-R
Brett Gilio wrote 6 years ago
[PATCH] gnu: update csound 6.11.0
(address . 33028@debbugs.gnu.org)(name . Brett Gilio)(address . brettg@posteo.net)
20181013001027.29723-1-brettg@posteo.net
---
gnu/packages/audio.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d233940f2..785375295 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2018 okapi <okapi@firemail.cc>
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -650,7 +651,7 @@ emulation (valve, tape), bit fiddling (decimator, pointer-cast), etc.")
(define-public csound
(package
(name "csound")
- (version "6.09.1")
+ (version "6.11.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -659,7 +660,7 @@ emulation (valve, tape), bit fiddling (decimator, pointer-cast), etc.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0xqpqws4jsv7fyawcjzwaw544qbfh29xq164kdf30a9v1n3yklp4"))))
+ "072pk5h9w0vhw0ncc9dn90haw1yv18v04iwwjn8nsp6930w7dvxd"))))
(build-system cmake-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
--
2.19.1
Brett Gilio wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33028@debbugs.gnu.org)
87r2guogb9.fsf@posteo.net
Brett Gilio writes:

Toggle quote (41 lines)
> ---
> gnu/packages/audio.scm | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index d233940f2..785375295 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -13,6 +13,7 @@
> ;;; Copyright © 2018 okapi <okapi@firemail.cc>
> ;;; Copyright © 2018 Maxim Cournoyer
> <maxim.cournoyer@gmail.com>
> ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
> +;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -650,7 +651,7 @@ emulation (valve, tape), bit fiddling
> (decimator, pointer-cast), etc.")
> (define-public csound
> (package
> (name "csound")
> - (version "6.09.1")
> + (version "6.11.0")
> (source (origin
> (method url-fetch)
> (uri (string-append
> @@ -659,7 +660,7 @@ emulation (valve, tape), bit fiddling
> (decimator, pointer-cast), etc.")
> (file-name (string-append name "-" version
> ".tar.gz"))
> (sha256
> (base32
> -
> "0xqpqws4jsv7fyawcjzwaw544qbfh29xq164kdf30a9v1n3yklp4"))))
> +
> "072pk5h9w0vhw0ncc9dn90haw1yv18v04iwwjn8nsp6930w7dvxd"))))
> (build-system cmake-build-system)
> (inputs
> `(("alsa-lib" ,alsa-lib)

Hopefully this one looks better. I'll admit I was having an issue
with
git send-email until I finally figured out how to get it working.
宋文武 wrote 6 years ago
Re: [bug#33028] [PATCH] gnu: update csound 6.11.0
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33028-done@debbugs.gnu.org)
87efct44sd.fsf@member.fsf.org
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (5 lines)
> ---
> gnu/packages/audio.scm | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33028@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33028
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help