[PATCH] gnu: stellarium: Update to 0.18.2

  • Done
  • quality assurance status badge
Details
4 participants
  • Brett Gilio
  • Leo Famulari
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal
B
B
Brett Gilio wrote on 12 Oct 2018 23:16
(address . guix-patches@gnu.org)
87bm7yx3uf.fsf@posteo.net
Toggle diff (36 lines)
diff --git a/gnu/packages/astronomy.scm
b/gnu/packages/astronomy.scm
index 3c8b9cc8d..5eb11cddd 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -128,7 +129,7 @@ programs for the manipulation and analysis of
astronomical data.")
(define-public stellarium
(package
(name "stellarium")
- (version "0.18.1")
+ (version "0.18.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/Stellarium/"
name
@@ -136,7 +137,7 @@ programs for the manipulation and analysis of
astronomical data.")
"/" name "-" version ".tar.gz"))
(sha256
(base32
-
"0vjkwrjy22b4wdjkafm63pmb0fck14ffnylpq8xr91ywycw4blrq"))))
+
"1nr8n0v4wa0wfvqqk5kyy1jrv6xnvv4ppfa8l8bklrxbjvpsi0km"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
T
T
Tobias Geerinckx-Rice wrote on 12 Oct 2018 23:50
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33027@debbugs.gnu.org)
87d0sebzsg.fsf@tobias.gr
Brett, Guix,

Brett Gilio wrote:
Toggle quote (6 lines)
> (define-public stellarium
> (package
> (name "stellarium")
> - (version "0.18.1")
> + (version "0.18.2")

I tried updating stellarium recently but ran into the following
test failure:

12/15 Test #12: testEphemeris ....................***Exception:
Child aborted 0.01 sec
********* Start testing of TestEphemeris *********
Config: Using QtTest library 5.11.1, Qt 5.11.1
(x86_64-little_endian-lp64 shared (dynamic) release build; by GCC
5.5.0)
QWARN : TestEphemeris::initTestCase() WARNING
StelFileMgr::StelFileMgr: could not find install location:
"/gnu/store/gk73b3xdzcfn7xp587r8yd31pw88ndjq-stellarium-0.18.2/share/stellarium"
(we checked for
"/gnu/store/gk73b3xdzcfn7xp587r8yd31pw88ndjq-stellarium-0.18.2/share/stellarium/data/ssystem_major.ini"
).
QWARN : TestEphemeris::initTestCase() Maybe this is AppImage or
something similar? Let's check relative path...
QWARN : TestEphemeris::initTestCase() WARNING
StelFileMgr::StelFileMgr: could not find install location:
"/tmp/guix-build-stellarium-0.18.2.drv-0/build/src/../share/stellarium"
(we checked for
"/tmp/guix-build-stellarium-0.18.2.drv-0/build/src/../share/stellarium/data/ssystem_major.ini"
).
QFATAL : TestEphemeris::initTestCase() Couldn't find install
directory location.
FAIL! : TestEphemeris::initTestCase() Received a fatal error.
Loc: [Unknown file(0)]
Totals: 0 passed, 1 failed, 0 skipped, 0 blacklisted, 0ms
********* Finished testing of TestEphemeris *********

I haven't had time to look into it yet. It's weird/interesting
that you don't run into it, though...

Could you try building with '--rounds=<about 20 or so>' and see if
you can make it fail?

Kind regards,

T G-R
B
B
Brett Gilio wrote on 13 Oct 2018 02:13
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
87pnweoga2.fsf@posteo.net
Tobias Geerinckx-Rice writes:

Toggle quote (56 lines)
> Brett, Guix,
>
> Brett Gilio wrote:
>> (define-public stellarium
>> (package
>> (name "stellarium")
>> - (version "0.18.1")
>> + (version "0.18.2")
>
> I tried updating stellarium recently but ran into the following
> test failure:
>
> 12/15 Test #12: testEphemeris ....................***Exception:
> Child aborted
> 0.01 sec
> ********* Start testing of TestEphemeris *********
> Config: Using QtTest library 5.11.1, Qt 5.11.1
> (x86_64-little_endian-lp64 shared
> (dynamic) release build; by GCC 5.5.0)
> QWARN : TestEphemeris::initTestCase() WARNING
> StelFileMgr::StelFileMgr: could
> not find install location:
> "/gnu/store/gk73b3xdzcfn7xp587r8yd31pw88ndjq-stellarium-0.18.2/share/stellarium"
> (we checked for
> "/gnu/store/gk73b3xdzcfn7xp587r8yd31pw88ndjq-stellarium-0.18.2/share/stellarium/data/ssystem_major.ini"
> ).
> QWARN : TestEphemeris::initTestCase() Maybe this is AppImage or
> something
> similar? Let's check relative path...
> QWARN : TestEphemeris::initTestCase() WARNING
> StelFileMgr::StelFileMgr: could
> not find install location:
> "/tmp/guix-build-stellarium-0.18.2.drv-0/build/src/../share/stellarium"
> (we
> checked for
> "/tmp/guix-build-stellarium-0.18.2.drv-0/build/src/../share/stellarium/data/ssystem_major.ini"
> ).
> QFATAL : TestEphemeris::initTestCase() Couldn't find install
> directory location.
> FAIL! : TestEphemeris::initTestCase() Received a fatal error.
> Loc: [Unknown file(0)]
> Totals: 0 passed, 1 failed, 0 skipped, 0 blacklisted, 0ms
> ********* Finished testing of TestEphemeris *********
>
> I haven't had time to look into it yet. It's weird/interesting
> that you don't
> run into it, though...
>
> Could you try building with '--rounds=<about 20 or so>' and see
> if you can make
> it fail?
>
> Kind regards,
>
> T G-R

This issue is appearing for me, now, too. Interesting. I will see
if I
can revise it and then send the appropriately formatted git patch.
I
think I figured out how to do that now.


--
Brett M. Gilio
Free Software Foundation, Member
https://gnu.org/s/guix/| https://emacs.org
L
L
Ludovic Courtès wrote on 27 Oct 2018 15:51
(name . Brett Gilio)(address . brettg@posteo.net)
87pnvva45w.fsf@gnu.org
Hi Brett,

Brett Gilio <brettg@posteo.net> skribis:

Toggle quote (4 lines)
> This issue is appearing for me, now, too. Interesting. I will see if I
> can revise it and then send the appropriately formatted git patch. I
> think I figured out how to do that now.

Did you eventually find a way to address this?

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 27 Dec 2018 11:59
control message for bug #33027
(address . control@debbugs.gnu.org)
878t0bb5gk.fsf@gnu.org
tags 33027 moreinfo
L
L
Leo Famulari wrote on 13 Feb 2019 00:17
Re: [bug#33027] [PATCH] gnu: stellarium: Update to 0.18.2
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33027-done@debbugs.gnu.org)
20190212231718.GA31772@jasmine.lan
Stellarium was updated to 0.18.3 in commit
81c64748bad51c7449eea8bab4953ecb89d02fa2, so I'm closing this bug
ticket.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlxjU/4ACgkQJkb6MLrK
fwhbkA//QgCLTHbSpx/CPFpzQHe4L7Ko/B2WjRGwh/O6oDBvBGvpd4frnR/JX2gD
4aaV7AU1+ey55XhPn1tBKdSlZaPiTr4/h14//A5hXL9oROmwPG1Ezdpd9LF3m+Kt
7oVsy+i2wKWkhb0gxGBodjgJtzch8DaHK00r3+H3mPeYNGTLqj1LlD+Pr4k5SneX
yMbdWP1Emhg87RqxAI4XS1dKC8MVqQ4OZ9QteAB0R3p+x+XcD0ejUcQbSFonASt4
vjRIH5xmIcVG/WdN1byUkqWDzoqWD3q0Wx6ZIqaatncvhyRSb3BeCWRCY21O1skD
diLfVTb/NfSU/Gk6O/gKLG2FL1iCN4d4sp89nznDlQUvEUNP9hcs05rfevisVUCv
SKINKt594Em9blpjD0B44JHGFZFUvubrH2k6VgQROXenwgq3PUhg+0OfykPOr6x9
QVgAH7Gc3RK+Z99CuNDChJ478oVmvIi1an/C8FJ8MibNrFMHGnoQFJTmgeqW+9xR
49I8id2J30MgxbhISY7KOnafd1Kpc0ngex1RKZAGYyyk0Pjk+tCy/nZN0O9LEpJP
1tKyJ0sg5iIWNztwyGBChcIaapiJgzaRfBf3Q4/6NtubDp0bQwH2iwiKlGGjZj1Z
fgPWFQGbBZdfjCmQmFxwG1M7Bhz8F0qeTq7uZxEJGb7k8yossR0=
=3di6
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33027@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33027
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch