[PATCH 1/3] gnu: guile2.0-guix: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • ericbavier
  • Ludovic Courtès
Owner
unassigned
Submitted by
ericbavier
Severity
normal

Debbugs page

ericbavier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@cray.com)
20181011015246.24964-2-ericbavier@centurylink.net
From: Eric Bavier <bavier@cray.com>

* gnu/packages/gnupg.scm (guile2.0-gcrypt): New variable.
* gnu/packages/guile.scm (guile2.0-sqlite3): New variable.
* gnu/packages/package-management.scm (guile2.0-guix)[propagated-inputs]: Use
them.
---
gnu/packages/gnupg.scm | 12 ++++++++++--
gnu/packages/guile.scm | 4 ++++
gnu/packages/package-management.scm | 2 ++
3 files changed, 16 insertions(+), 2 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 067a2338d..c38fe6420 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015, 2018 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
@@ -67,7 +67,8 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
- #:use-module (guix build-system python))
+ #:use-module (guix build-system python)
+ #:use-module (srfi srfi-1))
(define-public libgpg-error
(package
@@ -485,6 +486,13 @@ strong randomness, and more. It is implemented using the foreign function
interface (FFI) of Guile.")
(license license:gpl3+)))
+(define-public guile2.0-gcrypt
+ (package (inherit guile-gcrypt)
+ (name "guile2.0-gcrypt")
+ (inputs
+ `(("guile" ,guile-2.0)
+ ,@(alist-delete "guile" (package-inputs guile-gcrypt))))))
+
(define-public python-gpg
(package
(name "python-gpg")
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index e223edb9f..912b0218e 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
+;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1151,6 +1152,9 @@ Guile's foreign function interface.")
"This package provides Guile bindings to the SQLite database system.")
(license license:gpl3+)))
+(define-public guile2.0-sqlite3
+ (package-for-guile-2.0 guile-sqlite3))
+
(define-public haunt
(package
(name "haunt")
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 500abd512..000c28632 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -365,7 +365,9 @@ the Nix package manager.")
,@(alist-delete "guile" (package-inputs guix))))
(propagated-inputs
`(("gnutls" ,gnutls/guile-2.0)
+ ("guile-gcrypt" ,guile2.0-gcrypt)
("guile-json" ,guile2.0-json)
+ ("guile-sqlite3" ,guile2.0-sqlite3)
("guile-ssh" ,guile2.0-ssh)
("guile-git" ,guile2.0-git)))))
--
2.19.0
Ludovic Courtès wrote 6 years ago
(address . ericbavier@centurylink.net)
87efcsdx7x.fsf@gnu.org
Hello Eric,

ericbavier@centurylink.net skribis:

Toggle quote (7 lines)
> From: Eric Bavier <bavier@cray.com>
>
> * gnu/packages/gnupg.scm (guile2.0-gcrypt): New variable.
> * gnu/packages/guile.scm (guile2.0-sqlite3): New variable.
> * gnu/packages/package-management.scm (guile2.0-guix)[propagated-inputs]: Use
> them.

LGTM, thanks!

As discussed on IRC, I still plan to remove support for Guile 2.0
soonish, but in the meantime I think this patch doesn’t hurt.

Ludo’.
Eric Bavier wrote 6 years ago
(address . 33011-done@debbugs.gnu.org)
20181016173502.3870e904@centurylink.net
On Sun, 14 Oct 2018 23:39:30 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (16 lines)
> Hello Eric,
>
> ericbavier@centurylink.net skribis:
>
> > From: Eric Bavier <bavier@cray.com>
> >
> > * gnu/packages/gnupg.scm (guile2.0-gcrypt): New variable.
> > * gnu/packages/guile.scm (guile2.0-sqlite3): New variable.
> > * gnu/packages/package-management.scm (guile2.0-guix)[propagated-inputs]: Use
> > them.
>
> LGTM, thanks!
>
> As discussed on IRC, I still plan to remove support for Guile 2.0
> soonish, but in the meantime I think this patch doesn’t hurt.

OK.

Pushed in c8e3651a824bbc28915802265d9a5e7cc6405eea
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlvGZ5YACgkQ/XPKxxnT
JWaAiQ/9F5lmGhFIAFLY5hXk/OgXRxpQA4t1vjh6iV8ua12zQuo3eYXCqQS7tYFi
m9Nc8wrxkfHJ98cOL1qCRo6G1YkIB7oynY1BwssXMjUgJoHHAgD1suI2ZKbmjwMQ
cm1m/2UA84vgNgNEVdlu0RkE5/Df+u8y9sWlYpj8izwyYtVBIYpam9XVbZmhNDc9
iTGBWD0ndg5gIBIHvSzyqYv8Q69/1PrUPSN37GfvPY9AkNTyql8vrfwiUBd2b8yo
a4aNoiN3dCVGqS/4wCZotjkuwc8cQScXiSnnN4dy+1B9RPbaV9qO7JrHcuXz6Owv
GqPR/i70ZKYOVga2vIKBnYEN32Wpq+yLLgUUVT9o6pyHjPiw2PxhgdgUUhOPCOMb
ypuEglezIfFwj222QgTis1oWE8nILKeMyXJx13g99uPCQhBWmCH77xvdiGPjBO4I
PK93GB44LPD231bs0AU9tmYruO3gu4tMotMoak7eotm8EZUBEc6BDsncGHFopTo0
za5DGkDVycVIixJ8zDdb7xcuK+tA6OuWzVC2rNcEQtstuelsVwS66uhUwGLZSpMq
qHtTCOk8NZ/OYg0BujJGJNXCX6iPEyDas4BqBkG09tXKNz0Aptk4AHxg4gdUoOJ8
4V57xgHwHNQHo5YUt1uuyHrwkwwyNXJjJgLKCsGl02DXymJyd1U=
=yAia
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 33011@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33011
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help