[PATCH] gnu: Add kicad-symbols.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Leo Famulari
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20181010101736.21507-1-dannym@scratchpost.org
* gnu/packages/engineering.scm (kicad-symbols): New variable.
---
gnu/packages/engineering.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ee524ec78..2516143a7 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -823,6 +823,30 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
render model libraries.")
(license license:lgpl2.0+))))
+(define-public kicad-symbols
+ (package
+ (name "kicad-symbols")
+ (version "5.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KiCad/kicad-symbols.git")
+ (commit version)))
+ (file-name (string-append "kicad-symbols-" version "-checkout"))
+ (sha256
+ (base32
+ "18z5vpdq7hy2mpvm5vz1dz3ra3a5iybavvlzi8q2bmmdb6gsvf64"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; No tests exist
+ (home-page "http://kicad-pcb.org/")
+ (synopsis "Official KiCad schematic symbol libraries for Kicad 5")
+ (description "This package contains the official KiCad schematic symbol
+libraries for Kicad 5.")
+ ;; TODO: Exception: "To the extent that the creation of electronic designs that use 'Licensed Material' can be considered to be 'Adapted Material', then the copyright holder waives article 3 of the license with respect to these designs and any generated files which use data provided as part of the 'Licensed Material'."
+ ;; See <https://github.com/KiCad/kicad-symbols/blob/master/LICENSE.md>.
+ (license license:cc-by-sa4.0)))
+
(define-public linsmith
(package
(name "linsmith")
Leo Famulari wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 33004@debbugs.gnu.org)
20181010193030.GD22832@jasmine.lan
On Wed, Oct 10, 2018 at 12:17:36PM +0200, Danny Milosavljevic wrote:
Toggle quote (2 lines)
> * gnu/packages/engineering.scm (kicad-symbols): New variable.

Thanks, LGTM!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlu+U1YACgkQJkb6MLrK
fwiV7A/+PqYRO1vVaT8xQNKswIg4D8386yxIKHjVv6NcOCJGvqztWVeLnLEBXMs6
HbIM0mRsBxUSCiJvO/1wAYRw8F7Aw76xfLUq9Ha8taKjIfATnYvN8eKRWHTWwICF
EmphAP8wz30rgGFwOMYjmaljryWq4Kj5yYeVTCvgjDOMDzNNCshyWG0OCI2hBcX8
ykH0aCBJMXxO/Ogx2/7Oz/wyq8HZruO9hUrwM3W2X2KXg5ukYlefVtEZOGRGZOVs
RUaEf5hxYK5K8rEhW3mQF6U0KRgcLhCDskgFEDH183zX6rxwj5oA3KXzfOckx5sD
0z8fyNInrrj3uuOb5U50n178fACSQTQ/zPkai6TFyDVRz4R/g5TF0/lNpuK9EYOy
7ruw4arQ9Ew1GCAlGeU4tc4f6ErYHEwrmh7RsB0pGzx0rP4Lr77RVDyIz7FHHXc/
gM5bAQ4N4tp2gBVbE0kvVXy64b0v8gtHl+hJIN4gg72H1aB4E39pp8HC97WAni0R
ckEcBELzf640hXzpf8Oxg/VGdXy8FWR5NWh0FEHJ/OJ8PrkiZ6eDH4B2r7e22Ur3
WQ3RSYZ/ueL+VrzCgfomj72Ifrj/SxWGfKFwEg253PEL1F0ggWQYEK6GNNzNbOk+
qs8Lr+ZpyTxgQloVPkd4MhK9Zst2yf3fpbbY9JQhHv6WfRYQBUc=
=A3oG
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 6 years ago
(no subject)
(address . control@debbugs.gnu.org)
20181010230431.1a3f4889@scratchpost.org
close 33004
-----BEGIN PGP SIGNATURE-----

iQEyBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlu+aV8ACgkQ5xo1VCww
uqW4Zwf4red/FQVcZmWEM9KcfYjoqLHFgl66oBRGlvmy+ow2ol/cdngUK0bn9QJ4
7IkAljxQkKOrsiSiKMYa/4nmCmIZKO1g/Cg+tHkhvjQoc/S/2Lcp4A5fSnE0zflg
bw3synzDmaurcp+Ji2skkx03L/lmOeKPUS8CVorhCosgwu9wrTOpSivgmxgfFoPA
wGkBL+u8OTtLMQTnuWE4DKFF8eElH8SMsFCUy2v7n7tvVxj2q3FJBwTCiOTzXR7x
wvGDm57dklctrfTtbSEZxe5bay8+XVkI8NcK9yl24BsG3vUB+tzYEM1mt48eZKBB
y9zO5YP7zAHWDMtSyfdm5XP8pf8F
=cB/q
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 33004@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 33004
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help