[PATCH] Add gimp-resynthesizer package

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal

Debbugs page

Thorsten Wilms wrote 6 years ago
(address . guix-patches@gnu.org)
815797f6-0e23-328f-3706-271befff25c4@freenet.de
* gnu/packages/gimp.scm (gimp-resynthesizer): New variable.
---
gnu/packages/gimp.scm | 61 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)

Toggle diff (93 lines)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index df8f242c7..2e74f3128 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -305,3 +306,63 @@ brushstrokes which is used by MyPaint and GIMP.")
MyPaint.")
(home-page "https://github.com/Jehan/mypaint-brushes")
(license license:cc0)))
+
+(define-public gimp-resynthesizer
+ ;; GIMP does not respect any plugin search path environment variable,
so after
+ ;; installation users have to edit their GIMP settings to include
+ ;; "$HOME/.guix-profile/lib/gimp/2.0/plug-ins/" in
+ ;; “Edit->Preferences->Folders->Plug Ins”.
+ (package
+ (name "gimp-resynthesizer")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
"https://github.com/bootchk/resynthesizer/archive/v"
+ version
+ ".tar.gz"))
+ (sha256 (base32
"0l3404w6rqny7h3djskxf149gzx6x4qhndgbh3403c9lbh4pi1kr"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(;; Turn off tests to avoid:
+ ;; make[1]: *** No rule to make target '../src/resynth-gui.c',
needed by 'resynthesizer.pot'. Stop.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-env
+ (lambda _
+ (setenv "CONFIG_SHELL" (which "sh"))
+ #t))
+ (add-after 'configure 'set-prefix
+ ;; Attempt to install to GIMP's plugin directory will fail.
+ ;; Use own store address.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((target (string-append (assoc-ref outputs "out")
+ "/lib/gimp/"
+ (car (string-split
,(package-version gimp) #\.))
+ ".0")))
+ (substitute* (list "src/resynthesizer/Makefile"
+ "src/resynthesizer-gui/Makefile")
+ (("GIMP_LIBDIR = .*")
+ (string-append "GIMP_LIBDIR = " target "\n")))
+ (mkdir-p target))
+ #t))
+ )))
+ (native-inputs
+ `(("autoconf" ,autoconf-wrapper)
+ ("automake" ,automake)
+ ("glib" ,glib "bin") ; glib-gettextize
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gimp" ,gimp)
+ ("gdk-pixbuf" ,gdk-pixbuf) ; needed by gimp-2.0.pc
+ ("cairo" ,cairo)
+ ("gegl" ,gegl)
+ ("gtk+" ,gtk+-2) ; needed by gimpui-2.0.pc
+ ("glib" ,glib)))
+ (home-page "https://github.com/bootchk/resynthesizer")
+ (synopsis "GIMP plugins for texture synthesis")
+ (description
+ "Resynthesizer plugins for GIMP. Encompasses tools for healing
selections (content aware fill), enlarging the canvas and healing the
border, increasing the resolution while adding detail and transfering
the style of an image.")
+ (license license:gpl3+)))
--
2.19.0


--
Thorsten Wilms

thorwil's design for free software:
http://thorwil.wordpress.com/
Ludovic Courtès wrote 6 years ago
(name . Thorsten Wilms)(address . t_w_@freenet.de)(address . 32976@debbugs.gnu.org)
87woqswgpm.fsf@gnu.org
Thorsten Wilms <t_w_@freenet.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/gimp.scm (gimp-resynthesizer): New variable.

[...]

Toggle quote (4 lines)
> + (uri (string-append
> "https://github.com/bootchk/resynthesizer/archive/v"
> + version

This patch was also garbled by the email client’s line-wrapping, I
suppose.

Could you try to resend it?

Thanks,
Ludo’.
Thorsten Wilms wrote 6 years ago
[PATCH] * gnu/packages/gimp.scm (gimp-resynthesizer): New variable.
(address . 32976@debbugs.gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20181008191110.5189-1-t_w_@freenet.de
---
gnu/packages/gimp.scm | 61 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)

Toggle diff (78 lines)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index df8f242c7..2e74f3128 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -305,3 +306,63 @@ brushstrokes which is used by MyPaint and GIMP.")
MyPaint.")
(home-page "https://github.com/Jehan/mypaint-brushes")
(license license:cc0)))
+
+(define-public gimp-resynthesizer
+ ;; GIMP does not respect any plugin search path environment variable, so after
+ ;; installation users have to edit their GIMP settings to include
+ ;; "$HOME/.guix-profile/lib/gimp/2.0/plug-ins/" in
+ ;; “Edit->Preferences->Folders->Plug Ins”.
+ (package
+ (name "gimp-resynthesizer")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/bootchk/resynthesizer/archive/v"
+ version
+ ".tar.gz"))
+ (sha256 (base32 "0l3404w6rqny7h3djskxf149gzx6x4qhndgbh3403c9lbh4pi1kr"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(;; Turn off tests to avoid:
+ ;; make[1]: *** No rule to make target '../src/resynth-gui.c', needed by 'resynthesizer.pot'. Stop.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-env
+ (lambda _
+ (setenv "CONFIG_SHELL" (which "sh"))
+ #t))
+ (add-after 'configure 'set-prefix
+ ;; Attempt to install to GIMP's plugin directory will fail.
+ ;; Use own store address.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((target (string-append (assoc-ref outputs "out")
+ "/lib/gimp/"
+ (car (string-split ,(package-version gimp) #\.))
+ ".0")))
+ (substitute* (list "src/resynthesizer/Makefile"
+ "src/resynthesizer-gui/Makefile")
+ (("GIMP_LIBDIR = .*")
+ (string-append "GIMP_LIBDIR = " target "\n")))
+ (mkdir-p target))
+ #t))
+ )))
+ (native-inputs
+ `(("autoconf" ,autoconf-wrapper)
+ ("automake" ,automake)
+ ("glib" ,glib "bin") ; glib-gettextize
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gimp" ,gimp)
+ ("gdk-pixbuf" ,gdk-pixbuf) ; needed by gimp-2.0.pc
+ ("cairo" ,cairo)
+ ("gegl" ,gegl)
+ ("gtk+" ,gtk+-2) ; needed by gimpui-2.0.pc
+ ("glib" ,glib)))
+ (home-page "https://github.com/bootchk/resynthesizer")
+ (synopsis "GIMP plugins for texture synthesis")
+ (description
+ "Resynthesizer plugins for GIMP. Encompasses tools for healing selections (content aware fill), enlarging the canvas and healing the border, increasing the resolution while adding detail and transfering the style of an image.")
+ (license license:gpl3+)))
--
2.19.0
Ludovic Courtès wrote 6 years ago
(name . Thorsten Wilms)(address . t_w_@freenet.de)(address . 32976-done@debbugs.gnu.org)
87o9c4uoaq.fsf@gnu.org
Thorsten Wilms <t_w_@freenet.de> skribis:

Toggle quote (4 lines)
> ---
> gnu/packages/gimp.scm | 61 +++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 61 insertions(+)

Applied with the changes below.

Thanks!

Ludo'.
Toggle diff (55 lines)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 2e74f3128..cd0deac15 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -319,9 +319,11 @@ MyPaint.")
(origin
(method url-fetch)
(uri (string-append "https://github.com/bootchk/resynthesizer/archive/v"
- version
- ".tar.gz"))
- (sha256 (base32 "0l3404w6rqny7h3djskxf149gzx6x4qhndgbh3403c9lbh4pi1kr"))))
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0l3404w6rqny7h3djskxf149gzx6x4qhndgbh3403c9lbh4pi1kr"))
+ (file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(arguments
`( ;; Turn off tests to avoid:
@@ -334,20 +336,19 @@ MyPaint.")
(setenv "CONFIG_SHELL" (which "sh"))
#t))
(add-after 'configure 'set-prefix
- ;; Attempt to install to GIMP's plugin directory will fail.
- ;; Use own store address.
+ ;; Install plugin under $prefix, not under GIMP's libdir.
(lambda* (#:key outputs #:allow-other-keys)
(let ((target (string-append (assoc-ref outputs "out")
"/lib/gimp/"
- (car (string-split ,(package-version gimp) #\.))
+ ,(version-major
+ (package-version gimp))
".0")))
(substitute* (list "src/resynthesizer/Makefile"
"src/resynthesizer-gui/Makefile")
(("GIMP_LIBDIR = .*")
(string-append "GIMP_LIBDIR = " target "\n")))
- (mkdir-p target))
- #t))
- )))
+ (mkdir-p target)
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
@@ -364,5 +365,8 @@ MyPaint.")
(home-page "https://github.com/bootchk/resynthesizer")
(synopsis "GIMP plugins for texture synthesis")
(description
- "Resynthesizer plugins for GIMP. Encompasses tools for healing selections (content aware fill), enlarging the canvas and healing the border, increasing the resolution while adding detail and transfering the style of an image.")
+ "This package provides resynthesizer plugins for GIMP, which encompasses
+tools for healing selections (content-aware fill), enlarging the canvas and
+healing the border, increasing the resolution while adding detail, and
+transfering the style of an image.")
(license license:gpl3+)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32976@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32976
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help