[PATCH] gnu: Add picard.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20181007153307.25389-1-mail@cbaines.net
* gnu/packages/music.scm (picard): New variable.
---
gnu/packages/music.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3163e6a8f6..e1bac6f51e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2429,6 +2429,47 @@ and managing stations, can be controlled remotely via fifo, and can run
event-based scripts for scrobbling, notifications, etc.")
(license license:expat)))
+(define-public picard
+ (package
+ (name "picard")
+ (version "2.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://musicbrainz.osuosl.org/pub/musicbrainz/"
+ "picard/picard-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ds3ylpqn717fnzcjrfn05v5xram01bj6n3hwn9igmkd1jgf8vhc"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "picard/const/__init__.py"
+ (("pyfpcalc")
+ (string-append
+ "pyfpcalc', '"
+ (assoc-ref inputs "chromaprint") "/bin/fpcalc")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "python" "setup.py" "install"
+ (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--root=/"))))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("chromaprint" ,chromaprint)
+ ("python-pyqt" ,python-pyqt)
+ ("python-mutagen" ,python-mutagen)))
+ (home-page "https://picard.musicbrainz.org/")
+ (synopsis "Graphical music tagging application")
+ (description
+ "MusicBrainz Picard is a music tagging application, supporting multiple
+formats, looking up tracks through metadata and audio fingerprints.")
+ (license license:gpl2+)))
+
(define-public python-mutagen
(package
(name "python-mutagen")
--
2.19.1
Leo Famulari wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 32971@debbugs.gnu.org)
20181008024901.GA6377@jasmine.lan
On Sun, Oct 07, 2018 at 04:33:07PM +0100, Christopher Baines wrote:
Toggle quote (2 lines)
> * gnu/packages/music.scm (picard): New variable.

Thanks! LGTM
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlu6xZcACgkQJkb6MLrK
fwjvBRAA8RRapM5HEpOzgrq+R83u7yUA+zGlD4R2YWRoNN8jJIY32C3vpy0hWCJs
YJX2GCgle/aUkCLbNIJetvMdiXoGSlfNBJMqglBDrD+b9NSdc2F5Bb1y1IOsCczF
nNbzZU3Au3NKncTJIhwOMrjVh/bmkSdwTah/oSIGf71QcEfTSoMqwExVibtJL8ge
+aAXzwuCG/oRDz9F76uOFt6gEm5DLeruyEkCuFbHgRZBwxUULwzin62iUd8iIToH
tMDyf6u552ERItuu9R+RXDcLW0Qpcrlnq1AnBkuL3vDrnkSury90tZk/BCWRDdin
s6NDtsG3eETOsNhejjr3OrDFznwxsezuTBkmQr0CdgM1KQgvO9PJKIKzH8OEW2AE
5QO9e8je8KhNDjenZ5i204GK2JA8xqgreJjEIk4GW7YVWZnHJIyDVpoy6cYHJr8I
qdspVmJSmkWzZoiJOOHwGIZ5o0+8wqClvuifRcNsCSXQSQASxMoXIYWMH9WpUAue
xiww4a2v/wNstVANZcJSuGolPquGG2NHMaPxqQCLsy0MpixEBZ7RDy4YkqnW/JMC
p+mYrxj6cWpwGevJxRksd2hwD7KIZeMrP2K/CB/t2pdbNyUBnr6L8CADkZCEbmWA
7sZ3P4JDpY9fS3ViUVyoDr6JnSe6wQ2Dgz+ejnovfYl/XibcIVY=
=8uDj
-----END PGP SIGNATURE-----


Christopher Baines wrote 6 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 32971-done@debbugs.gnu.org)
87k1mt548g.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (5 lines)
> On Sun, Oct 07, 2018 at 04:33:07PM +0100, Christopher Baines wrote:
>> * gnu/packages/music.scm (picard): New variable.
>
> Thanks! LGTM

Great, I've pushed this to master. Thanks for taking a look!
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlu6/E9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcQCA/+OlrwEKB6C0ajX3QBWUoiHUc6cZMjQrnn76Qoc0P3YajbD9ri7yHedwfq
140mU3oaRXnwIJQEWfsROx6GLIT/Sfyw+MkzVkCBTx/ZvHr2BpBOzM+DF6zwmg8q
N4I2hLXPAi1KTYOY2+3OPEyTjOEdiK1wVJNZT5E7Cea3wIJvLWRnO6BiopTus91i
Q2YjKG8NyQgRDWVgVhLmiuDjWEEgOCHTda4aAPGIOyHz0be7n9nwYPFZ7n48GUCQ
GkyvPG3hPFb6KBNPZ+bwbf52JST5ZwGM93Tz/WF2s2MW2xZQsRcbBKWcdoUsgHXn
edA5rA9Nbyxlp2A7fvN45lwsWaD0jBDUDvjrBtokpxu/kN3ZPxGsS+wFwRZZjhFw
pN5Gxb4pd2gXOrOvxi/v2joLa86gI0pgVgycCvYV1bGuubpyqCdiH1LfTiWPE2ZK
eNaEPOIH6nNhO8DPxhAri+n1YJO61+h9dxr21e+/yQedrA9zbT+8+dqzOr96f0pp
878BR1LjA4hQubbTvi51/xO/JQr4HMcwxC7sKqGJeV+ANe2ycCsDzzFe6PorBk2j
2xU5DNmQTLebjxGQW/ZslxuvDBEQksRMQs3o8qjdT6GvJNun20A+GIjoDHonEWL0
jy/UTJXwMemma8aRSR7lRIzIVYP0GiHGSFNTdIZFaArLKWHb6+g=
=P+At
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32971@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32971
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help