[PATCH] build-system/asdf: Properly handle dependency specification casing.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Patterson
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Patterson
Severity
normal

Debbugs page

Andy Patterson wrote 6 years ago
(address . guix-patches@gnu.org)
20181002051703.7e2ebf14@mailservices.uwaterloo.ca
From fd4047ab93f9be94ddfeef48248fca6a0580131f Mon Sep 17 00:00:00 2001
From: Andy Patterson <ajpatter@uwaterloo.ca>
Date: Tue, 2 Oct 2018 04:57:31 -0400
Subject: [PATCH] build-system/asdf: Properly handle dependency
specification casing.

* guix/build/lisp-utils.scm (normalize-dependency): Modify match
clauses to match the upper-case symbols that lisp produces.
---
guix/build/lisp-utils.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (22 lines)
diff --git a/guix/build/lisp-utils.scm b/guix/build/lisp-utils.scm
index 6470cfec9..3f5cdf86b 100644
--- a/guix/build/lisp-utils.scm
+++ b/guix/build/lisp-utils.scm
@@ -84,11 +84,12 @@
(define (normalize-dependency dependency)
"Normalize the name of DEPENDENCY. Handles dependency definitions
of the dependency-def form described by
-<https://common-lisp.net/project/asdf/asdf.html#The-defsystem-grammar>."
+<https://common-lisp.net/project/asdf/asdf.html#The-defsystem-grammar>.
+Assumes that any symbols in DEPENDENCY will be in upper-case."
(match dependency
- ((':version name rest ...)
+ ((':VERSION name rest ...)
`(:version ,(normalize-string name) ,@rest))
- ((':feature feature-specification dependency-specification)
+ ((':FEATURE feature-specification dependency-specification)
`(:feature
,feature-specification
,(normalize-dependency dependency-specification)))
--
2.19.0
Ludovic Courtès wrote 6 years ago
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(address . 32904-done@debbugs.gnu.org)
87y3bgo8n1.fsf@gnu.org
Andy Patterson <ajpatter@uwaterloo.ca> skribis:

Toggle quote (9 lines)
> From fd4047ab93f9be94ddfeef48248fca6a0580131f Mon Sep 17 00:00:00 2001
> From: Andy Patterson <ajpatter@uwaterloo.ca>
> Date: Tue, 2 Oct 2018 04:57:31 -0400
> Subject: [PATCH] build-system/asdf: Properly handle dependency
> specification casing.
>
> * guix/build/lisp-utils.scm (normalize-dependency): Modify match
> clauses to match the upper-case symbols that lisp produces.

Applied, thanks!

Ludo'.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32904@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32904
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help