[PATCH] gnu: ruby: Add Ruby 2.5.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20180929111601.21182-1-mail@cbaines.net
* gnu/packages/ruby.scm (ruby)[version]: Update to 2.5.1.
[source]: Remove the Ruby 2.4 patch, and update sha256.
(ruby-2.4): New variable.
---
gnu/packages/ruby.scm | 25 ++++++++++++++++++++++---
1 file changed, 22 insertions(+), 3 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 874bab8ae3..566d940255 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -55,7 +55,7 @@
(define-public ruby
(package
(name "ruby")
- (version "2.4.3")
+ (version "2.5.1")
(source
(origin
(method url-fetch)
@@ -64,8 +64,7 @@
"/ruby-" version ".tar.xz"))
(sha256
(base32
- "0l9bv67dgsphk42lmiskhrnh47hbyj6rfg2rcjx22xivpx07srr3"))
- (patches (search-patches "ruby-rubygems-276-for-ruby24.patch"))
+ "0kbm3gkv689d1mb8fh261z8s79d6hw07p0xyk735yfqyskpcasl8"))
(modules '((guix build utils)))
(snippet `(begin
;; Remove bundled libffi
@@ -107,6 +106,26 @@ a focus on simplicity and productivity.")
(home-page "https://www.ruby-lang.org")
(license license:ruby)))
+(define-public ruby-2.4
+ (package
+ (inherit ruby)
+ (version "2.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
+ (version-major+minor version)
+ "/ruby-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0l9bv67dgsphk42lmiskhrnh47hbyj6rfg2rcjx22xivpx07srr3"))
+ (patches (search-patches "ruby-rubygems-276-for-ruby24.patch"))
+ (modules '((guix build utils)))
+ (snippet `(begin
+ ;; Remove bundled libffi
+ (delete-file-recursively "ext/fiddle/libffi-3.2.1")
+ #t))))))
+
(define-public ruby-2.3
(package
(inherit ruby)
--
2.18.0
Christopher Baines wrote 6 years ago
Re: Ruby 2.5, pushing to staging?
(address . 32871@debbugs.gnu.org)(address . guix-devel@gnu.org)
87d0se6f37.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (16 lines)
> A new minor version of Ruby has been out for a while, and it would be
> good to get Ruby 2.5 in to Guix.
>
> I've put up a patch here [1], and tried it locally. I've pushed some
> fixes to master to make some packages compatible [2], and while I do get
> some failures when building the 958 (according to guix refresh -l)
> dependant packages, I'm unsure how many of these are down to the Ruby
> upgrade.
>
> 1: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32871
> 2: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32870
>
> Anyway, looking at the contributing guide this is possibly too big of a
> change to push directly to master, so should I push this to the staging
> branch?

I've now gone ahead and pushed to staging. Not really sure what happens
now.... will berlin and hydra pick this up automatically, and start
building packages?
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlvBDxxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xcrcg/9GbgTHAZx+/2DdRqjIWmV0j04vY89p8b1KjLVPZFJslBtwFx/0NGtqpsK
hOFbNZ8TtA3MXWzvaD6OlZQ3ThtgKYadZ+/pOMmACUvuU2YwrqD2Imyj7iOjhXI2
Z2XXnV8HHdYKNMKAZ53uVr1Rh5ILRpu6B10rfjcQ3cYNgSJLrKy8hx22x9OV4aRm
JERFeSYv104F/bKx/Rqot0NuHwvy/OMe1/UwflKmv2M3qUjKP0HqDrzn4Gm5Hf9B
WryPR7L8NlzYFnw3/a6XYUHzqpAvGOuy5NAErzvAfBh2tIGhXRGuZzZD3E9+TSR6
70xpD1242t2lqvFcQXABmj4b48EWlmf3x2uiG72xtlsDEfcrI9OZ8I0mpajQuUz7
NV6gAaszcTSERoK/f/rxfl0KAi9+BMVbaSWbpcGspA5t+zea1Ru9kvUaGXbNj5y1
oT4IR8the2D6MNCxQxvios3dl62v8fwKDL3ghX9cpLYRstVT9Kc3K1o8h+1Zsjbe
XzVQepQZuvBOasMao2HRkwyb54SJZBJbYLe+U6C0v1RRNKrTcuwTN4A0tPaEvdMM
6EM0tNEPnbwUjeGXADMWltTtipTyy5J8yUS5TG887werJ2HoBNUJlNduJN32U8bF
hoq9gF7iAcB2FZjS2+3iBm1/I/HsWVDNioRrRxSmqZm9x49lwGs=
=9YrQ
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
Re: [bug#32871] Ruby 2.5, pushing to staging?
(name . Christopher Baines)(address . mail@cbaines.net)
87murfk2aj.fsf@gnu.org
Hi Chris,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (22 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> A new minor version of Ruby has been out for a while, and it would be
>> good to get Ruby 2.5 in to Guix.
>>
>> I've put up a patch here [1], and tried it locally. I've pushed some
>> fixes to master to make some packages compatible [2], and while I do get
>> some failures when building the 958 (according to guix refresh -l)
>> dependant packages, I'm unsure how many of these are down to the Ruby
>> upgrade.
>>
>> 1: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32871
>> 2: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32870
>>
>> Anyway, looking at the contributing guide this is possibly too big of a
>> change to push directly to master, so should I push this to the staging
>> branch?
>
> I've now gone ahead and pushed to staging. Not really sure what happens
> now.... will berlin and hydra pick this up automatically, and start
> building packages?

Not yet! Primarily because we’re focusing (or trying to…) on building
core-updates so we can get it merged soonish, after which we can
hopefully merge staging.

Thanks!

Ludo’.
Christopher Baines wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87muraat1y.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (6 lines)
> Hi Chris,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Christopher Baines <mail@cbaines.net> writes:

...

Toggle quote (12 lines)
>>> Anyway, looking at the contributing guide this is possibly too big of a
>>> change to push directly to master, so should I push this to the staging
>>> branch?
>>
>> I've now gone ahead and pushed to staging. Not really sure what happens
>> now.... will berlin and hydra pick this up automatically, and start
>> building packages?
>
> Not yet! Primarily because we’re focusing (or trying to…) on building
> core-updates so we can get it merged soonish, after which we can
> hopefully merge staging.

So, berlin seemed to do something [1], but most of the builds are
scheduled. But yeah, waiting for core-updates is fine.

-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlvJ72lfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdlmRAAuLyo8j0d1AkkA2U9wLlK4jEM9dmLQ4WsUzw2xGuCfOB4ftWSwjSM8jmP
bV+jAGTm3UG54vPlSGsiXtBK19XXXsbfX7ENhk88sRjoKuWlKxtmUicLLjRUg0AQ
/mkfw3HQNHIt8wAKw+tvedCHCmvx0lrb40scjqn3YJVrCUplEF9t+Z1/I/Oh8A3q
zcVk8mPYjctw9xdGGYANx/gE0f6bBuFEIOQPOa2Mr3M+c8CV0xOhbgRMgf1FMW+G
eCxhOEei9qXEFxu7gDn4TMSr+334zanGd6KCcE5T15PAd66hQTURPDi4N2Z/sXzq
AUtu9mfRkvTLU9HWaXJpvsPUWu0KPoOu75nGG5koh12ocO2vpwM5GxGDWi/GgmCa
4OmB7+ozxuleD9IGCg0u57bNPLlhooj51Qz1YUk9d9WQdzyUO9ciqfRVIEHDQeIW
pAszCO8hBQ+dhARVVjLjWHwxGvRnuLsKDmraDG1FSBUapW0sghK2fKSIysIBnOjc
lBtbjhufwlhXUx+NntawfIN8789FWMb3OE5p8rhTQY3y7/0LMR/cxldd0io6tEW6
YjYLRMdAjWR9pmqj9ZjAjLbapzZvNNxitYIvrUQrOh58FUpUU/y05EgS1Uqnu1Hp
OBZQvpU8mtNW1lW7RAxQAN1gdXimLVpATdCVGr57wMllky9rl/w=
=xG8e
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
Re: Ruby 2.5, pushing to staging?
(address . 32871@debbugs.gnu.org)(address . guix-devel@gnu.org)
87k1kjx4s5.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (22 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> A new minor version of Ruby has been out for a while, and it would be
>> good to get Ruby 2.5 in to Guix.
>>
>> I've put up a patch here [1], and tried it locally. I've pushed some
>> fixes to master to make some packages compatible [2], and while I do get
>> some failures when building the 958 (according to guix refresh -l)
>> dependant packages, I'm unsure how many of these are down to the Ruby
>> upgrade.
>>
>> 1: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32871
>> 2: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32870
>>
>> Anyway, looking at the contributing guide this is possibly too big of a
>> change to push directly to master, so should I push this to the staging
>> branch?
>
> I've now gone ahead and pushed to staging. Not really sure what happens
> now.... will berlin and hydra pick this up automatically, and start
> building packages?

So, I'm still interested in pushing Ruby 2.5 forward. I've now pushed an
upgrade from 2.5.1 to 2.5.3 to the staging branch, as that seemed
sensible.

I can see that ci.guix.info (berlin) has picked this up (I think here
[1]), but I'm not sure what to do next...?

Thanks,

Chris

-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlwMCopfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XeTWQ/5AcWb7sZRliagQ0NKh3hSSG8/bp6CmQ1JLizKk/C5DZm0937u9OFCT+EV
qqgPuu/MBx2cxD0aVOeOIN6XiqXOkvtaFhBHolVJRkYw0dHsS/DWel8Gi6aIqwly
3IMv6VeKymfCth6dbyMEmUrVqOmQzajkeLZF3iWvzoPCEZZ1O+fpzTZaAd5Sq4O+
gbdISTfdrI09Pb2qlQcP01Z3R+i+TVXzTurukaBVvysomG+8o5cpXeQXcrGnegKD
SzaLW9wiy24iJzU5N3UNHl3E1jjU+0WaO5UwVPd7h6RxjdENRD/Oxi7J3M1VC8rc
wZZOyoV8pHQNGBw5NwPph1+bHr4DueaY3tdkgrnJca7HGh66Os6bzoMqs1ftC5xV
zuzRZIEOFonGOPihpqa3WyG0nLIhKKeod6GDRUcPMxYneQeFZWZetLy8obCsZBT9
PXiB046R8JYk9NHNaZJXVCRWKtGOuN/u9OA+L6n83n0tYqh2s3rpsFLIEFc3wfF0
8vmiM4sDc+qeWQByzyOhGeUrdZFF0yzd/2o+WEmBAEy3ndXk4vYLXTtChbBC6BvC
yX4HfnJ1Pzg8nuwgSwEAOalWKTdTdkDD0xnyTVdRCEuBjJDxw7Lh6K13FrI9V05W
MHZBoxreGQa8xjIE9VMJoo1I379XnBrMqDmEF0MCSUO649ujCII=
=J4LG
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
control message for bug #32871
(address . control@debbugs.gnu.org)
87k1ixj0ep.fsf@cbaines.net
tags 32871 pending
Christopher Baines wrote 6 years ago
Re: [bug#32871] [PATCH] gnu: ruby: Add Ruby 2.5.
(address . 32871-done@debbugs.gnu.org)
871s4g54w8.fsf@cbaines.net
Staging has now been merged, so Ruby 2.5 has hit master :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxf+PdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd7Pw//XSleQl/UJGMKuV8kUnjm/Z3W9Dz1ksF+Y8pNWDMXMrSSTBUAqmTwf+kw
0vgU54FgmSlb9FpD3e09BEvzNoURFkFUFSIRZZXkX9/yIuK2HfZUZx9b+doc5Nj1
VI3Dl4cHyPl/YVuFKJohXqa4y+pRJqRw7Yht28YQm/r/vAAs4WCa/mnCPxjXhO04
IGqfDupy4GA0cFAWp6GKYEgpEUxTiAbIRt2PtZiFrWIA7CYwked7H2xHyzm2VFE9
0rAG8m6Bf9X5nqw6WqCY6Y0Ss8p5NpuEXwS4SubAaIbVpav4EHk62hqKUHZqt7rC
Ot/LI9dX1GWwNIdi2IkN3jFmYT6tnXa5aSszHRdP8kNuzKB45XSvR6foArgbU8LD
BWwmHQzt8jUaxr90oSK97ruGLDgDM0dNREvYQgMNCfqAHuiX3YzTIx1eU/7IgjTk
trsbNDiwz/yRxkmixWLoIi/GKoMkXiLj6IT6QFlByJVuYIXRLnkFwW+AYN4zRIw2
mPea5E9LJvnw+APXVp5GGiOQ8ANu5TwZmLx2erMVZmkM0x352x0/P2/mtonRiCPD
olXLQyuNOBltKI/JZ4ZM5Bpv68mK1NJ2Em/GzrAJIdpnFq7T8xfV02Dt+p1x6a+H
DM79KvWJdV6VuaVPo8aI2xMUlQniPHjtLPqyq98zR5J3WJ+QXt0=
=O58R
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32871@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32871
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help