pimi wrote 6 years ago
(address . guix-patches@gnu.org)(address . ricardo.wurmus@mdc-berlin.de)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
* gnu/packages/bioinformatics.scm (porechop): New variable.
---
gnu/packages/bioinformatics.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b619866ba..2ab7135f5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13760,3 +13760,33 @@ sequencing data.")
;; This is free software but the license variant is unclear:
;; <https://github.com/mw55309/poRe_docs/issues/10>.
(license license:bsd-3)))
+
+(define-public porechop
+ ;; The recommended way to install is to clone the git repository
+ ;; https://github.com/rrwick/Porechop#installation
+ (let ((commit "289d5dca4a5fc327f97b3f8cecb68ecaf1014861")
+ (revision "1"))
+ (package
+ (name "porechop")
+ (version (git-version "0.2.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rrwick/Porechop.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05ps43gig0d3ia9x5lj84lb00hbsl6ba9n7y7jz927npxbr2ym23"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/rrwick/porechop")
+ (synopsis "Finding, trimming or splitting adapters, in Oxford Nanopore reads")
+ (description
+ "The porechop package is a tool for finding and removing adapters from Oxford
+Nanopore reads. Adapters on the ends of reads are trimmed off, and when a read
+has an adapter in its middle, it is treated as chimeric and chopped into
+separate reads. Porechop performs thorough alignments to effectively find
+adapters, even at low sequence identity. Porechop also supports demultiplexing
+of Nanopore reads that were barcoded with the Native Barcoding Kit, PCR
+Barcoding Kit or Rapid Barcoding Kit.")
+ (license license:gpl3))))
--
2.17.1