[PATCH] gnu: Add porechop.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 6 years ago
(address . guix-patches@gnu.org)(address . ricardo.wurmus@mdc-berlin.de)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180924133114.14714-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (porechop): New variable.
---
gnu/packages/bioinformatics.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b619866ba..2ab7135f5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13760,3 +13760,33 @@ sequencing data.")
;; This is free software but the license variant is unclear:
;; <https://github.com/mw55309/poRe_docs/issues/10>.
(license license:bsd-3)))
+
+(define-public porechop
+ ;; The recommended way to install is to clone the git repository
+ ;; https://github.com/rrwick/Porechop#installation
+ (let ((commit "289d5dca4a5fc327f97b3f8cecb68ecaf1014861")
+ (revision "1"))
+ (package
+ (name "porechop")
+ (version (git-version "0.2.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rrwick/Porechop.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05ps43gig0d3ia9x5lj84lb00hbsl6ba9n7y7jz927npxbr2ym23"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/rrwick/porechop")
+ (synopsis "Finding, trimming or splitting adapters, in Oxford Nanopore reads")
+ (description
+ "The porechop package is a tool for finding and removing adapters from Oxford
+Nanopore reads. Adapters on the ends of reads are trimmed off, and when a read
+has an adapter in its middle, it is treated as chimeric and chopped into
+separate reads. Porechop performs thorough alignments to effectively find
+adapters, even at low sequence identity. Porechop also supports demultiplexing
+of Nanopore reads that were barcoded with the Native Barcoding Kit, PCR
+Barcoding Kit or Rapid Barcoding Kit.")
+ (license license:gpl3))))
--
2.17.1
Leo Famulari wrote 6 years ago
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32819-done@debbugs.gnu.org)(address . ricardo.wurmus@mdc-berlin.de)
20180930181057.GA5218@jasmine.lan
On Mon, Sep 24, 2018 at 03:31:14PM +0200, pimi wrote:
Toggle quote (2 lines)
> * gnu/packages/bioinformatics.scm (porechop): New variable.

Thanks!

Toggle quote (2 lines)
> + (license license:gpl3))))

I used gpl3+ and pushed as f2bc53af70eea7b7147b9e7e40280941866ed128

For more information about the license, see here:
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluxEbEACgkQJkb6MLrK
fwgQ0RAAvU582ZkRAui0hhwQMMxvMUgZZo/Uq6H5nFQNn8A/LiJrzU5gh2n0vw9f
fPYNdYc1XLVl1oHM6TOCfFRLEW4dXWNqRnXWuonKgRVrq1+OsUvWOyN2udazbAYJ
x+u4LpOOpVAdEFlVciIO7yIBvKxRMbe/6ho0sgcehJ3NkiE0smY2a3Ynhgr6RXT/
xbo/G0RVE9Ij7ghaJcM1d44ZWztPFHhvMb6uQ+QUV07KSHEayY7DdGHzz/NFj+i0
1x2mXxL4LS8eKBnS50H8c6QDO7Ga+b4QIlqltP894eNRFH/GhCLQUWpEqVv3IqAC
W/0heYRDv4tkUMa9fHfPW1PYfypi/+qhGh5qs0mlma2fh7fyGWZm8zhq8vD6waSZ
PK7vvAPZmAsJ1GWJOzzIaZTFvag3/XBpuvQ2VifcTK4JfST9qDD2AqxgkVGbDw3/
fSIPdywDgPPHTtsh1NDVubA3YWmn2D5J4yZUNolsIsXvtqJawwsGnd/c8jEWekm0
rO70RF3bYwq62y41KMV4//MWhI5Bb2lngyLN2nLlqZYVLyaQqrZPOfGBVzLj/pyr
xilCcutFF2gK4DoLRKIuZbKkEOoo2JzYCIUerKpiHPqQEbizr/1iOCCCCmJSIvQl
hvJNQS0eJExh1ShaI2qaVF6H9VDgUAeeEIqYu2XxOSz1TKEikGo=
=La9J
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32819@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32819
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help