[PATCH] gnu: Add poretools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 6 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180920102258.17005-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (poretools): New variable.
---
gnu/packages/bioinformatics.scm | 39 +++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 67f24a617..fdc35e684 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13723,3 +13723,42 @@ juicer) and single-resolution or multi-resolution @code{.cool} files (for
cooler). Both @code{hic} and @code{cool} files describe Hi-C contact
matrices.")
(license license:expat)))
+
+(define-public poretools
+ ;; The latest release was in 2016 and the latest commit is from 2017
+ ;; the recommended way to install is to clone the git repository
+ ;; https://poretools.readthedocs.io/en/latest/content/installation.html
+ (let ((commit "e426b1f09e86ac259a00c261c79df91510777407")
+ (revision "1"))
+ (package
+ (name "poretools")
+ (version (git-version "0.6.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arq5x/poretools.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bglj833wxpp3cq430p1d3xp085ls221js2y90w7ir2x5ay8l7am"))))
+ (build-system python-build-system)
+ ;; requires python >=2.7, <3.0, and the same for python dependencies
+ (arguments `(#:python ,python-2))
+ (inputs
+ `(("hdf5" ,hdf5)))
+ (propagated-inputs
+ `(("python-dateutil" ,python2-dateutil)
+ ("python-h5py" ,python2-h5py)
+ ("python-matplotlib" ,python2-matplotlib)
+ ("python-pandas" ,python2-pandas)
+ ("python-seaborn" ,python2-seaborn)))
+ (home-page "https://poretools.readthedocs.io")
+ (synopsis "Toolkit for working with nanopore sequencing data")
+ (description
+ "The MinION from Oxford Nanopore Technologies is a nanopore sequencer.
+This @code{poretools} package is a flexible toolkit for exploring datasets
+generated by nanopore sequencing devices for the purposes of quality control and
+downstream analysis. Poretools operates directly on the native FAST5, a variant
+of the Hierarchical Data Format (HDF5) standard.")
+ (license license:expat))))
--
2.17.1
Leo Famulari wrote 6 years ago
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32781-done@debbugs.gnu.org)
20181002200542.GC18113@jasmine.lan
On Thu, Sep 20, 2018 at 12:22:58PM +0200, pimi wrote:
Toggle quote (2 lines)
> * gnu/packages/bioinformatics.scm (poretools): New variable.

Thank you! Pushed as 3f0f49d70877df6c829b443830de99e0e1e1f6bc
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluzz5YACgkQJkb6MLrK
fwjB/w//W/fzPoloJqJApVsNWYglEMVxDWL3qVaNwotWJKeJqQ55qJA4hMIP2N8o
TIwYkBuP5Y79HrEK02kL0Mc2rWnYdyUjr8TuF4iVsSjzMgl+7QdDQZGhvdGOuO0f
ne+6vsmmh4IOdv49duUdTyDdlit4unXk7vb+JxZyqw/7/XMaw5V+oPiX4jK6eZ9z
YnJbEauVR6XC9BLWhq9KoDhuTb+gy+dDYZZdLGg976NvmesGVOPiclqGTT3R8rnr
dnxGCWSJxE/rJ3QWFbyeMm91qi2fhT87isPZ+ZYrXBQuE8vwwD1S0zsaMjq018dj
mkp1dVL9wSNqgDyXOQKU+2OEh2wJlhgJe44vxaL89G06JSy5xl0dMcir7OPjdrZe
DVmFLmOCk0BwmKltpe/1YaJ9yHSb+gyusaG7RVnV1rw+cLHlWZMSeocyLsWkDZ9t
AejiOebzD2kzFoaFU6EkFkHqStAhEUJ4hCzTL9r1H82LSvtyS9bhWeC4TB4iloj6
B9zduaQydoFciCizNoM2MiW74uR/tjRblE1hhZPHOFEfepr3SFbif8FGSdftbA/s
q8yk21B6C1LaHoEJ8xQCQzB+WDBBYhK/rqVmpFLAT2nVWz5SoSjWvrzbcrHZDQaU
9/Cwy/WESACwhiRDgpsJI0Ll7b6io9IE+a3Hj06KwlHRNf0ShBo=
=snym
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32781@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32781
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help