[PATCH] gnu: Add r-acclma.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(address . ricardo.wurmus@mdc-berlin.de)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180912120309.2759-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-acclma): New variable.
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e9ad33763..b88721807 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5695,3 +5695,32 @@ user to assess sampling plans against pre-specified levels of performance, as
measured by the probability of acceptance for a given level of quality in the
lot.")
(license license:gpl3+)))
+
+(define-public r-acclma
+ (package
+ (name "r-acclma")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ACCLMA" version))
+ (sha256
+ (base32 "1na27sp18fq12gp6vxgqw1ffsz2yi1d8xvrxbrzx5g1kqxrayy0v"))))
+ (properties `((upstream-name . "ACCLMA")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/ACCLMA/")
+ (synopsis "ACC & LMA graph plotting")
+ (description
+ "This package contains a function that imports data from a @acronym{Comma-Separated
+Values, @acronym{CSV}} file, or uses manually entered data from the format (x,
+y, weight) and plots the appropriate @acronym{Absolute Concentration Curve,
+@acronym{ACC}} vs @acronym{Line of Independence, @acronym{LOI}} graph and
+@acronym{@acronym{LOI} Minus @acronym{ACC}, @acronym{LMA}} graph. The main
+function is plotLMA (source file, header) that takes a data set and plots the
+appropriate @acronym{LMA} and @acronym{ACC} graphs. If no source file (a
+string) was passed, a manual data entry window is opened. The header parameter
+indicates by TRUE/FALSE (false by default) if the source @acronym{CSV} file has
+a header row or not. The dataset should contain only one independent variable
+(x) and one dependent variable (y) and can contain a weight for each
+observation.")
+ (license license:gpl2)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32718
(address . control@debbugs.gnu.org)
165d3e1e150.6310c13-870258820.-7760320347524836899@zoho.com
owner 32718 !
Leo Famulari wrote 6 years ago
Re: [bug#32718] [PATCH] gnu: Add r-acclma.
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . ricardo.wurmus@mdc-berlin.de)(address . 32718-done@debbugs.gnu.org)
20181002203113.GF20264@jasmine.lan
On Wed, Sep 12, 2018 at 02:03:09PM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/cran.scm (r-acclma): New variable.

Thanks! Pushed as 63781c5748b108db5ceab02ce2d201e901ff10a4
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluz1ZEACgkQJkb6MLrK
fwjCiBAAul+mHnoIHeyxEz5XE+AnSIrlz9Mg+xnWLXR3BGZdIk7hm9ac6tfUGb0A
ZlNhGs09KjZCr/5nBTtoeCjkkEP2hGB3l58TJm+vYYj8iJA1sspC2fHqgm/GNwNP
TRNRK0TeNnAX4ke16rO0YOkjeNCzu1ZUwPqHj5PTGiNv50jQDM9yLgMgChpfLSXz
iaYynB62Yx5IVnGepCtIgJN+aBkGaf+qMmiJT+ewITJ56kJKr23Co+OwvqKW/dnN
wRkkjbDPi8udHsH3Ubsp6bOlzxanzuScIFj6KaKtjEa0W6VAYdjPr5PdLkZZd+Un
Ckabbo6M5Yvm8jNvooJSkZD30w9RzC/TJBqFHxJ33hRMytXyzQ5HNgqqccBvq7G3
zp6aulqTbCmeaHEt7WzgxSl8s3HQBn6tND7AjhHTtRV6hM99BNwGMDib2vBR/kzK
cykRBdk+fNftn63J218Bwr1zTBiYRruliPUkiPpjCG5IEvilmDpw/IFCotDBCrp8
klokoANHvtdQ4RNf9h6xt5OrR5p0yjvviPw1+6jle8uuUjuZRPCcCYGPzjdwxAPc
VAq/ZmLA/vqZ9QKg0WYDoHcEI8Zk7v/XjCkh/bp+3CVbtUHOmAJbcx9eC4kaFEPn
sshJaIyJt1zqPj4agjGd0VYn77SZKFNFKX1m/rRCBx8tCIat8i8=
=2tSV
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32718@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32718
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help