[PATCH] gnu: Add r-acceptancesampling.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(address . ricardo.wurmus@mdc-berlin.de)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180912091656.12230-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-acceptancesampling): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab989abff..e9ad33763 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5668,3 +5668,30 @@ Interfaces (GUI) in R. It is independent from any particular GUI widgets. It
centralizes info about GUI elements currently used, and it dispatches GUI
calls to the particular toolkits in use in function of the context.")
(license license:gpl2)))
+
+(define-public r-acceptancesampling
+ (package
+ (name "r-acceptancesampling")
+ (version "1.0-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "AcceptanceSampling" version))
+ (sha256
+ (base32 "18krmmyn8pn11aqd81kbvka68lnd36mnpdh7p3pz9r4m4vjj007x"))))
+ (properties
+ `((upstream-name . "AcceptanceSampling")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/AcceptanceSampling/")
+ (synopsis "Creation and evaluation of acceptance sampling plans")
+ (description
+ "This @code{r-acceptancesampling} provides functionality for creating and evaluating
+acceptance sampling plans. Acceptance sampling is a methodology commonly used
+in quality control and improvement. International standards of acceptance
+sampling provide sampling plans for specific circumstances. The aim of this
+package is to provide an easy-to-use interface to visualize single, double or
+multiple sampling plans. In addition, methods have been provided to enable the
+user to assess sampling plans against pre-specified levels of performance, as
+measured by the probability of acceptance for a given level of quality in the
+lot.")
+ (license license:gpl3+)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32716
(address . control@debbugs.gnu.org)
165d3e1cb3f.586988c8759365803.7662693795993442627@zoho.com
owner 32716 !
Leo Famulari wrote 6 years ago
Re: [bug#32716] [PATCH] gnu: Add r-acceptancesampling.
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32716-done@debbugs.gnu.org)(address . ricardo.wurmus@mdc-berlin.de)
20181002203057.GE20264@jasmine.lan
On Wed, Sep 12, 2018 at 11:16:56AM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/cran.scm (r-acceptancesampling): New variable.

Thanks! Pushed as 9c1c2108a5523015fd83e599b263dfb1ad348324
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluz1YEACgkQJkb6MLrK
fwjR9g//Wi3dMuIuRdY38A/paQ5GMz9jiI9zwug8IBEwVTjxtJGuQlFpN6Iy6+1T
kXRoIlX8tDzVnSdVtJAWL4iJw+T2ZIufAYLPEBSoW2j548DNuUwBEwhmjqeXzrPM
nP8eiiwGE0QTwl/ZYhKuAKPuM+OoIvHrvnhSPX/tZ/fgMVfFZQHkXe3eBcoGqMTe
HFIObBy5Zrk0NKZfp7tdU51KnjlZ+T/6P4QDmmfgYSXquqBSLYg+09Npi4pfB2Ft
fNe795CgIQFsdQ5KZuRd+VxUQc+yrZaBbN2a0YOxS2gFQtw3QwLq9i5s/YKgu01B
XAfot89Q1mlm02wfTwVr5KQ4k/cl9nEmAwGzm4RN3pdrlpBXz5hWO5t+6/Kl1pYc
8R1gSywvsEHSMqMZ3EBJ20jw8DI8EvOKJwB36GQrLvsZaCLjUH/YW5IDql/LFUmt
NFO8a3TvHXwIausI88XA36NbU/1mZZsKRoLiAhk1MfIVe/Q0JcCfXv8peet6vvJl
7dutqn4ONcsazt54LAIrOV2RmtzXL1jSZvfkp8kyXP/UBROzjIqWCkp3E6oE8upQ
/g2iB5IzNNl1po9HLBBhVZlqZZf9iW6Aj1UmwelwVCVKYXPrB1CqxXUKyrC7+YaO
/MzTcxpjl+NPRe2CHgGZQ+NclBgizJnO2fZeCQZx75mdadTo5I8=
=cvgX
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32716@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32716
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help