ericbavier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
From: Eric Bavier <bavier@member.fsf.org>
Fixes build of "lz4" package, e.g.
* guix/ui.scm (build-output-port)[handle-string]: Check for #\nul before doing
any regex matching.
---
guix/ui.scm | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)
Toggle diff (38 lines)
diff --git a/guix/ui.scm b/guix/ui.scm
index c55ae7e2f..207aba8ad 100644
--- a/guix/ui.scm
+++ b/guix/ui.scm
@@ -1762,18 +1762,19 @@ phase announcements and replaces any other output with a spinner."
RED BLUE RED BLUE RED BLUE))))
(lambda (str)
(let ((processed
- (any (match-lambda
- ((pattern #:transform transform)
- (and=> (string-match pattern str)
- transform))
- ((pattern . colors)
- (and=> (string-match pattern str)
- (lambda (m)
- (let ((substrings
- (map (cut match:substring m <>)
- (iota (- (match:count m) 1) 1))))
- (string-join (map proc substrings colors) ""))))))
- rules)))
+ (and (not (string-index str #\nul)) ;(ice-9 regex) cannot handle #\nul
+ (any (match-lambda
+ ((pattern #:transform transform)
+ (and=> (string-match pattern str)
+ transform))
+ ((pattern . colors)
+ (and=> (string-match pattern str)
+ (lambda (m)
+ (let ((substrings
+ (map (cut match:substring m <>)
+ (iota (- (match:count m) 1) 1))))
+ (string-join (map proc substrings colors) ""))))))
+ rules))))
(when spun?
(display (string #\backspace) port))
(if processed
--
2.18.0