• Done
  • quality assurance status badge
Details
4 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Leo Famulari
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 7 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
918DDFCAA65E9447BD6F28DB666521DA99357D@DAGONE.mdc-berlin.net
Mădălin Ionel Patrașcu
System Administrator
Bioinformatics Platform
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany
pimi wrote 7 years ago
(address . 32701@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911140503.13839-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-pscl): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0f39080b3..e3c813bf2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5871,3 +5871,29 @@ that are part of an activity bout, and find the maximum 10-minute average count
value. The functions are generally very flexible, allowing for a variety of
algorithms to be implemented.")
(license license:gpl3)))
+
+(define-public r-pscl
+ (package
+ (name "r-pscl")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pscl" version))
+ (sha256
+ (base32 "1phf3awsfr4ncqfqzin5m1pz0g7y1zhbcm2sz7358ssw914fd7rc"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)))
+ (home-page "https://github.com/atahk/pscl/")
+ (synopsis "Political science computational laboratory")
+ (description
+ "The @code{pscl} is an R package providing classes and methods for:
+@enumerate
+@item Bayesian analysis of roll call data (item-response models);
+@item elementary Bayesian statistics;
+@item maximum likelihood estimation of zero-inflated and hurdle models for count
+data;
+@item utility functions.
+@end enumerate")
+ (license license:gpl2)))
--
2.17.1
pimi wrote 7 years ago
[PATCH 2/2] gnu: Add r-accelmissing.
(address . 32701@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911140503.13839-2-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-accelmissing): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e3c813bf2..541a26645 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5897,3 +5897,28 @@ data;
@item utility functions.
@end enumerate")
(license license:gpl2)))
+
+(define-public r-accelmissing
+ (package
+ (name "r-accelmissing")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "accelmissing" version))
+ (sha256
+ (base32 "1nql9inx6azdzi3z4sfm2vdml2mms6krl8wzlf1dn1c97ahn57fy"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mice" ,r-mice)
+ ("r-pscl" ,r-pscl)))
+ (home-page "https://cran.r-project.org/web/packages/accelmissing/")
+ (synopsis "Missing value imputation for accelerometer data")
+ (description
+ "This package provides a statistical method to impute the missing values in
+accelerometer data. The methodology includes both parametric and
+semi-parametric multiple imputations under the zero-inflated Poisson lognormal
+model. It also provides multiple functions to preprocess the accelerometer data
+previous to the missing data imputation. These include detecting the wearing
+and the non-wearing time, selecting valid days and subjects, and creating plots.")
+ (license license:gpl2+)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32701
(address . control@debbugs.gnu.org)
165d3e1b536.8463e2b1938337039.-3846510118261042480@zoho.com
owner 32701 !
Leo Famulari wrote 6 years ago
Re: [bug#32701] [PATCH 1/2] gnu: Add r-pscl.
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32701-done@debbugs.gnu.org)
20181001123829.GA7623@jasmine.lan
On Tue, Sep 11, 2018 at 04:05:02PM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/cran.scm (r-pscl): New variable.

Thanks! I pushed the patch series as
e710d1a4ffe0131d9a59eba1d1ad615f8448f50d
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluyFUQACgkQJkb6MLrK
fwiWRBAA0gb8SgZ4Bo/gN6uxuTajciFiqrBty0vW6gDGlZ/HQMB4KXs5xARS1ESA
yoSrdGpFCFZca5KDab3CTCc8V4L1GsSjURmWllq0FRS4jDxEH1qaaESsMXTAtUwO
kU101MrFeGMXY1VeyuopzD2YIQlmYTCBUgVDdujUCq8bA9xVM/CrbFrJR3b3prtr
+WI1LONs7qKAZH2XmW45wJdNdqcZWzcaRGStY9Ft2SKF/ITcPNbwpqJ3m7mPkRyW
w2hkKRw1BnW1Y0gQcq7P0j8cXyuipL38zG5QhlxgSCYzZqtwmhWl265FK3Szfr7f
2qiclDP3Lt0PLi7jDFUsibHvFW9PK+TbRbylfqAV7RbJuJhlB/VbIHYvDWE3XvKj
U+/C+OgyNFGCC2vG8rBY6AjD8dpoQN627MIEG/ppHpi3Rtpnq9g/d4qK8BJivfqI
KleWeJAToWuwq/Z7E1BWfsBcE4xyjPhsbkO/lsuGlqw0/ZboA7MhaJCzuLTX8w7a
IWIAV+TIIgd4s6h4Cg9Bu3HvlIIPr1Z2TyNCH7/w6zYhuh2M/eA9GfsRM3ujaF7J
Tl55rW/OieuZ/65qH/Jt3bSUx/xWn9a4pX+K5QvEZdeakD6JBmEb8kygfmXPPUT6
1w40aZOvYtPlnlGoBeSIspGLLBPJs8eMQnCTgy9HWKHf44P2TUw=
=J59/
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32701@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32701
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help