• Done
  • quality assurance status badge
Details
4 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Leo Famulari
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 7 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
918DDFCAA65E9447BD6F28DB666521DA99354A@DAGONE.mdc-berlin.net
Mădălin Ionel Patrașcu
System Administrator
Bioinformatics Platform
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany
pimi wrote 7 years ago
(address . 32700@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911131827.12372-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-rbenchmark): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7621b3bb6..aada8acce 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5797,3 +5797,28 @@ on user-defined cut-points of accelerometer counts.
and generates data summaries. Also, includes functions to plot, analyze, and
simulate accelerometer data.")
(license license:gpl2+)))
+
+(define-public r-rbenchmark
+ (package
+ (name "r-rbenchmark")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rbenchmark" version))
+ (sha256
+ (base32 "010fn3qwnk2k411cbqyvra1d12c3bhhl3spzm8kxffmirj4p2al9"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/rbenchmark/")
+ (synopsis "Benchmarking routine for R")
+ (description
+ "This @code{r-rbenchmark} package is inspired by the Perl module Benchmark,
+and is intended to facilitate benchmarking of arbitrary R code. The library
+consists of just one function, benchmark, which is a simple wrapper around
+system.time. Given a specification of the benchmarking process (counts of
+replications, evaluation environment) and an arbitrary number of expressions,
+benchmark evaluates each of the expressions in the specified environment,
+replicating the evaluation as many times as specified, and returning the results
+conveniently wrapped into a data frame.")
+ (license license:gpl2+)))
+
--
2.17.1
pimi wrote 7 years ago
[PATCH 2/3] gnu: Add r-dvmisc.
(address . 32700@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911131827.12372-2-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-dvmisc): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index aada8acce..f4ca7778e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5822,3 +5822,28 @@ replicating the evaluation as many times as specified, and returning the results
conveniently wrapped into a data frame.")
(license license:gpl2+)))
+(define-public r-dvmisc
+ (package
+ (name "r-dvmisc")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dvmisc" version))
+ (sha256
+ (base32 "1dy0yykskwhkql19bhzmbwsgv028afc8jh9yqwbczj6f3vpv31zh"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-rbenchmark" ,r-rbenchmark)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://cran.r-project.org/web/packages/dvmisc/")
+ (synopsis "Faster computation of common statistics and miscellaneous functions")
+ (description
+ "This package implements faster versions of base R functions (e.g. mean, standard
+deviation, covariance, weighted mean), mostly written in C++, along with
+miscellaneous functions for various purposes (e.g. create the histogram with
+fitted probability density function or probability mass function curve, create
+the body mass index groups, assess the linearity assumption in logistic
+regression).")
+ (license license:gpl2)))
--
2.17.1
pimi wrote 7 years ago
[PATCH 3/3] gnu: Add r-accelerometry.
(address . 32700@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911131827.12372-3-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-accelerometry): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f4ca7778e..0f39080b3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5847,3 +5847,27 @@ fitted probability density function or probability mass function curve, create
the body mass index groups, assess the linearity assumption in logistic
regression).")
(license license:gpl2)))
+
+(define-public r-accelerometry
+ (package
+ (name "r-accelerometry")
+ (version "3.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "accelerometry" version))
+ (sha256
+ (base32 "13xzrwhr4i1nj9c8vrmfdg2rmrc8n446iihcyxmy99sm99hpzyip"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dvmisc" ,r-dvmisc)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://cran.r-project.org/web/packages/accelerometry/")
+ (synopsis "Functions for processing accelerometer data")
+ (description
+ "This package provides a collection of functions that perform operations on
+time-series accelerometer data, such as identify the non-wear time, flag minutes
+that are part of an activity bout, and find the maximum 10-minute average count
+value. The functions are generally very flexible, allowing for a variety of
+algorithms to be implemented.")
+ (license license:gpl3)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32700
(address . control@debbugs.gnu.org)
165d3e19b04.5f43dc771599736461.897393611111271157@zoho.com
owner 32700 !
Leo Famulari wrote 6 years ago
Re: [bug#32700] [PATCH 1/3] gnu: Add r-rbenchmark.
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32700-done@debbugs.gnu.org)
20181002194655.GA18113@jasmine.lan
On Tue, Sep 11, 2018 at 03:18:25PM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/cran.scm (r-rbenchmark): New variable.

Thanks! I pushed the patch series as
d8d8844ec12c017480e83cd541e98b55e18a17f4
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluzyy8ACgkQJkb6MLrK
fwjo7BAAigx1I/fjewsQvC9lm7blPgNvIOKsjUnwVtu5H6JdEHpRkozuW8Gh/jbK
uzHAnejyezfe5d3aQxQtHlCkRPpevo/c7+QydAy/+/riwHLry0Brnl/EARNboQ7S
9gyhcWnvlCao/plp5CWhM55g+CZul8ncy/RjYj/d6c1VO9lW88lsowceOobYm6LL
5KHjAriSo9eIb9U5sirFlNaLgT4JYfTSfeafIxFGXsQ5zJr9JEPV0qPXoGBIPC5L
XDtE0k2gjtRpbBV2NVumsfy89MdogwsEHJJwmI0qeWwAW4+y7bCnBE1lFUMxrt4A
6Qz5moFZ+xP13x1KEle9hC1oH+UvICTYQuudgYGu7U5K4JcMWWktwkWDGWS6wHlJ
+/XQyGsqUQeTXZEPezTLwihhbd3t4Na3js0jr/TdGlbEloog3yvz3+WoIBdsCrCx
O3BYz1YLZOvUbxC/Nr5DRlR8wg2cVmDachlf6J5uQBOeExQSX9B+iGOH50B8Rizk
TWaqWyI1ryqPhxurkJOUu6tWx0YM4zmkWsYNn1LFR3NmIXtkzn6PQ+nrse2pWWy9
yzGEMFo7itYQbkNLTqnNb4C4zTsNE8qiAQl/dpEZBLnnG95VcStRzkSMTkyUY+nG
925e3t9AXzM4S0sJk0uBYz4JclsqgaZOkKyVEjDaRh5o45hnjU0=
=3ba0
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32700@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32700
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help