Package azr3-1.2.3 fails during install

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal

Debbugs page

Thorsten Wilms wrote 7 years ago
(address . bug-guix@gnu.org)
caeb60eb-dcd7-4b5c-0ab9-29ecea23be81@freenet.de
Hi, azr3-1.2.3 fails during install, printing:

...
phase `build' succeeded after 16.1 seconds
starting phase `check'
test suite not run
phase `check' succeeded after 0.0 seconds
starting phase `install'
mkdir -p //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/bin &&
cp azr3/azr3 //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/bin
mkdir -p
//gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/azr3-jack
cp azr3/presets azr3/cknob.png azr3/minioffon.png azr3/onoffgreen.png
azr3/panelfx.png azr3/vonoff.png azr3/voice.png azr3/num_yellow.png
azr3/dbblack.png azr3/dbbrown.png azr3/dbwhite.png
//gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/azr3-jack
mkdir -p
//gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/doc/azr3-jack
cp AUTHORS COPYING README ChangeLog
//gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/doc/azr3-jack
man_section=`echo azr3.1 | sed 's/.*\.\([0-9]\)/\1/'`; mkdir -p
//gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/man/man$man_section;
gzip -c azr3.1 >
//gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/man/man$man_section/`basename
azr3.1`.gz
gzip: azr3.1: warning: file timestamp out of range for gzip format
make: *** [Makefile.template:357: install-manuals] Error 2
Backtrace:
4 (primitive-load "/gnu/store/bjx9zf1kdp3xm7kz9dq4136sg0w?")
In ice-9/eval.scm:
191:35 3 (_ _)
In srfi/srfi-1.scm:
640:9 2 (for-each #<procedure 95d8e0 at /gnu/store/f95ghy8mx00?> ?)
In
/gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/gnu-build-system.scm:
799:31 1 (_ _)
In
/gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/utils.scm:
616:6 0 (invoke _ . _)

/gnu/store/f95ghy8mx00fc22nrvswvnpqlfdkf2nk-module-import/guix/build/utils.scm:616:6:
In procedure invoke:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program:
"make" arguments: ("install" "LV2PEG=ttl2c" "CXXFLAGS=-std=gnu++11"
"CFLAGS=-std=gnu++11"
"prefix=/gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3"
"pkgdatadir=/gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/azr3-jack")
exit-status: 2 term-signal: #f stop-signal: #f] 68fb80>)'.
builder for `/gnu/store/ik7f5kdvlzr9iamgiv3fw227lnly6fsk-azr3-1.2.3.drv'
failed with exit code 1
Build failed: /gnu/store/ik7f5kdvlzr9iamgiv3fw227lnly6fsk-azr3-1.2.3.drv
- 1 builder for
`/gnu/store/ik7f5kdvlzr9iamgiv3fw227lnly6fsk-azr3-1.2.3.drv' failed with
exit code
guix package: error: build failed: build of
`/gnu/store/ik7f5kdvlzr9iamgiv3fw227lnly6fsk-azr3-1.2.3.drv' failed
Ricardo Wurmus wrote 6 years ago
(address . t_w_@freenet.de)(address . 32698@debbugs.gnu.org)
87y3c8jgnv.fsf@elephly.net
Hi Thorsten,

Toggle quote (8 lines)
> //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/doc/azr3-jack
> man_section=`echo azr3.1 | sed 's/.*\.\([0-9]\)/\1/'`; mkdir -p
> //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/man/man$man_section;
> gzip -c azr3.1 >
> //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/man/man$man_section/`basename
> azr3.1`.gz
> gzip: azr3.1: warning: file timestamp out of range for gzip format

We might be able to fix this with a build phase like this:

Toggle snippet (9 lines)
(add-before 'reset-gzip-timestamps 'make-manpages-writable
(lambda* (#:key outputs #:allow-other-keys)
(map make-file-writable
(find-files (string-append (assoc-ref outputs "out")
"/share/man")
".*\\.gz$"))
#t))

Would you like to give that a try?

--
Ricardo
Thorsten Wilms wrote 6 years ago
(address . 32698@debbugs.gnu.org)
00b59718-250a-9ffc-6837-553d7773652a@freenet.de
On 11.09.2018 15:40, Ricardo Wurmus wrote:
Toggle quote (25 lines)
>
> Hi Thorsten,
>
>> //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/doc/azr3-jack
>> man_section=`echo azr3.1 | sed 's/.*\.\([0-9]\)/\1/'`; mkdir -p
>> //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/man/man$man_section;
>> gzip -c azr3.1 >
>> //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/man/man$man_section/`basename
>> azr3.1`.gz
>> gzip: azr3.1: warning: file timestamp out of range for gzip format
>
> We might be able to fix this with a build phase like this:
>
> --8<---------------cut here---------------start------------->8---
> (add-before 'reset-gzip-timestamps 'make-manpages-writable
> (lambda* (#:key outputs #:allow-other-keys)
> (map make-file-writable
> (find-files (string-append (assoc-ref outputs "out")
> "/share/man")
> ".*\\.gz$"))
> #t))
> --8<---------------cut here---------------end--------------->8---
>
> Would you like to give that a try?

I got the exact same message as before, now with your snippet inserted
as follows, testing via
./pre-inst-env guix build azr3:

[PATCH] gnu/packages/audio.scm, azr3: add reset-gzip-timestamps
phase.

---
gnu/packages/audio.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 446587273..38ef11b18 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -453,7 +453,16 @@ tools.")
"CXXFLAGS=-std=gnu++11"
"CFLAGS=-std=gnu++11"
(string-append "prefix=" %output)
- (string-append "pkgdatadir=" %output "/share/azr3-jack"))))
+ (string-append "pkgdatadir=" %output "/share/azr3-jack"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-manpages-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map make-file-writable
+ (find-files (string-append (assoc-ref outputs "out")
+ "/share/man")
+ ".*\\.gz$"))
+ #t)))))
(inputs
`(("gtkmm" ,gtkmm-2)
("lvtk" ,lvtk)
--
2.19.0


--
Thorsten Wilms

thorwil's design for free software:
http://thorwil.wordpress.com/
Ricardo Wurmus wrote 6 years ago
(address . t_w_@freenet.de)(address . 32698-done@debbugs.gnu.org)
87va6dqvv3.fsf@elephly.net
[Resending because this email could not be delivered to debbugs.]

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (38 lines)
> Thorsten Wilms <t_w_@freenet.de> writes:
>
>> On 11.09.2018 15:40, Ricardo Wurmus wrote:
>>>
>>> Hi Thorsten,
>>>
>>>> //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/doc/azr3-jack
>>>> man_section=`echo azr3.1 | sed 's/.*\.\([0-9]\)/\1/'`; mkdir -p
>>>> //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/man/man$man_section;
>>>> gzip -c azr3.1 >
>>>> //gnu/store/rxn9php37bgcvznjiq0mvvr6a4s8zayg-azr3-1.2.3/share/man/man$man_section/`basename
>>>> azr3.1`.gz
>>>> gzip: azr3.1: warning: file timestamp out of range for gzip format
>>>
>>> We might be able to fix this with a build phase like this:
>>>
>>> --8<---------------cut here---------------start------------->8---
>>> (add-before 'reset-gzip-timestamps 'make-manpages-writable
>>> (lambda* (#:key outputs #:allow-other-keys)
>>> (map make-file-writable
>>> (find-files (string-append (assoc-ref outputs "out")
>>> "/share/man")
>>> ".*\\.gz$"))
>>> #t))
>>> --8<---------------cut here---------------end--------------->8---
>>>
>>> Would you like to give that a try?
>>
>> I got the exact same message as before, now with your snippet inserted
>> as follows, testing via
>> ./pre-inst-env guix build azr3:
>
> Ah, the error is about the input to gzip; this error happens during
> installation. So all that’s needed is to update the timestamp of the
> man page source.
>
> This is now fixed with commit ef1f9acf4.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32698@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32698
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help