• Done
  • quality assurance status badge
Details
4 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Leo Famulari
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 7 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
918DDFCAA65E9447BD6F28DB666521DA9934F1@DAGONE.mdc-berlin.net
Mădălin Ionel Patrașcu
System Administrator
Bioinformatics Platform
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany
pimi wrote 7 years ago
(address . 32697@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911122847.11246-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-mhsmm): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 35badf334..e9ea46e4a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5686,3 +5686,26 @@ biological data by Michael Whitlock and Dolph Schluter.")
series.")
;; Any version of the GPL
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-mhsmm
+ (package
+ (name "r-mhsmm")
+ (version "0.4.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mhsmm" version))
+ (sha256
+ (base32 "009dj0zkj1zry7jr9hf4cknb686z50a2l967if64xm0dvjmp7dgs"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-mvtnorm" ,r-mvtnorm)))
+ (home-page "https://github.com/jaredo/mhsmm/")
+ (synopsis "Inference for hidden Markov and semi-Markov models")
+ (description
+ "The @code{r-mhsmm} package implements estimation and prediction methods for
+hidden Markov and semi-Markov models for multiple observation sequences. Such
+techniques are of interest when observed data is thought to be dependent on some
+unobserved (or hidden) state. Also, this package is suitable for equidistant
+time series data, with multivariate and/or missing data. Allows user defined
+emission distributions.")
+ (license license:gpl2+)))
--
2.17.1
pimi wrote 7 years ago
[PATCH 2/4] gnu: Add r-nleqslv.
(address . 32697@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911122847.11246-2-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-nleqslv): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e9ea46e4a..f5b259d53 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5709,3 +5709,25 @@ unobserved (or hidden) state. Also, this package is suitable for equidistant
time series data, with multivariate and/or missing data. Allows user defined
emission distributions.")
(license license:gpl2+)))
+
+(define-public r-nleqslv
+ (package
+ (name "r-nleqslv")
+ (version "3.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nleqslv" version))
+ (sha256
+ (base32 "1v9znvncyigw9r25wx2ma0b7ib179b488dl0qsrhp5zrcz7mcjgm"))))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/nleqslv/")
+ (synopsis "Solve systems of nonlinear equations")
+ (description
+ "The @code{r-nleqslv} package solves a system of nonlinear equations using a
+Broyden or a Newton method with a choice of global strategies such as line
+search and trust region. There are options for using a numerical or user
+supplied Jacobian, for specifying a banded numerical Jacobian and for allowing a
+singular or ill-conditioned Jacobian.")
+ (license license:gpl2+)))
--
2.17.1
pimi wrote 7 years ago
[PATCH 3/4] gnu: Add r-physicalactivity.
(address . 32697@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911122847.11246-3-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-physicalactivity): New variable.
---
gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f5b259d53..df320c229 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5731,3 +5731,36 @@ search and trust region. There are options for using a numerical or user
supplied Jacobian, for specifying a banded numerical Jacobian and for allowing a
singular or ill-conditioned Jacobian.")
(license license:gpl2+)))
+
+(define-public r-physicalactivity
+ (package
+ (name "r-physicalactivity")
+ (version "0.2-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "PhysicalActivity" version))
+ (sha256
+ (base32 "14z6plgwyr46vs9m997rvlz8sdglfs9g087an8668zqkzzs2w4ln"))))
+ (properties
+ `((upstream-name . "PhysicalActivity")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/PhysicalActivity/")
+ (synopsis "Procesing accelerometer data for physical activity measurement")
+ (description
+ "This @code{r-physicalactivity} package provides a function @code{wearingMarking}
+for classification of monitor wear and nonwear time intervals in accelerometer
+data collected to assess physical activity. The package also contains functions
+for making plots of accelerometer data and obtaining the summary of various
+information including daily monitor wear time and the mean monitor wear time
+during valid days. The revised package version 0.2-1 improved the functions
+regarding speed, robustness and add better support for time zones and daylight
+saving. In addition, several functions were added:
+@enumerate
+@item the @code{markDelivery} can classify days for ActiGraph delivery by mail;
+@item the @code{markPAI} can categorize physical activity intensity level based
+on user-defined cut-points of accelerometer counts.
+@end enumerate
+ It also supports importing ActiGraph (AGD) files with @code{readActigraph} and
+@code{queryActigraph} functions.")
+ (license license:gpl3+)))
--
2.17.1
pimi wrote 7 years ago
[PATCH 4/4] gnu: Add r-acc.
(address . 32697@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911122847.11246-4-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-acc): New variable.
---
gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index df320c229..7621b3bb6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5764,3 +5764,36 @@ on user-defined cut-points of accelerometer counts.
It also supports importing ActiGraph (AGD) files with @code{readActigraph} and
@code{queryActigraph} functions.")
(license license:gpl3+)))
+
+(define-public r-acc
+ (package
+ (name "r-acc")
+ (version "1.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "acc" version))
+ (sha256
+ (base32 "1ii2vm47djxbixa75h690q1s2f9m9x6i8nkygik93j6dayr6kr1m"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-circlize" ,r-circlize)
+ ("r-dbi" ,r-dbi)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-iterators" ,r-iterators)
+ ("r-mhsmm" ,r-mhsmm)
+ ("r-nleqslv" ,r-nleqslv)
+ ("r-physicalactivity" ,r-physicalactivity)
+ ("r-plyr" ,r-plyr)
+ ("r-r-utils" ,r-r-utils)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-zoo" ,r-zoo)))
+ (home-page "https://cran.r-project.org/web/packages/acc/")
+ (synopsis "Exploring accelerometer data")
+ (description
+ "This package processes accelerometer data from uni-axial and tri-axial devices
+and generates data summaries. Also, includes functions to plot, analyze, and
+simulate accelerometer data.")
+ (license license:gpl2+)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32697
(address . control@debbugs.gnu.org)
165d3e17f26.1137380e1906097614.2282488940638546416@zoho.com
owner 32697 !
Leo Famulari wrote 6 years ago
Re: [bug#32697] [PATCH 1/4] gnu: Add r-mhsmm.
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32697-done@debbugs.gnu.org)
20181001130903.GA10828@jasmine.lan
On Tue, Sep 11, 2018 at 02:28:44PM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/cran.scm (r-mhsmm): New variable.

Thanks! I pushed this patch series as
f95d45425152bda85950d2b8f9ead50bdce2e2cc
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluyHG8ACgkQJkb6MLrK
fwiw4w/+IAsneII9YIun38v5FErkaBIhKfWb4tShhy4ggf4HCZY58zBBFmf9DJvd
MmgCRTO5cJmesJQNMFz2NpX3VUjZed4ynRnJ0s+8R+c0W5SRrYGi7RZfTFKYbQFz
PmXsoojqzgrKQtQOTUbB4MoAq/iJ/LT/sT6t2hLIvqKO9YYep7rxz8i43V1KbzJh
hAEdlQs/yzxaZArwJR1p2e3WRgI+webRY4Ac5RcXuaVIxT3U+IjYoWcVLn86S4vv
1lXbzpuT5aA4fQcjO59MdlFP5VopJtl6g6/osqT6wQkvwKs34OTYdYtZklSkYs1c
Fhd2MShwKQTDYMaDFBT2zPI2rHmsBbV4TIZ+IMiG+ZQlNtomobuYxB+xNdbR6uL6
XV8dUv34dneNAAmsTR6pMo3g/f/0dUm+cqvIV46hQzwxcBfWckyk+0O0p8FtrdLf
0d8RQaMo1z5ZW3OXkTJBvG8m/syLbpEYhXT8+cCnGK6m4DLOiOjPLfpgsVMM1RvH
tqle9LatkOirYsjMJCv2lOiIhGj5UQg9SDhAv2321uHMlk8VLt0BqLyoLfi5L6KK
+8jE9klL0GThU2an48oJBHwnz6eZ0HHhqjTxog1t2beRmDKLRok/EM4r1hA0cw4d
jZtzmk+YvzJu0d6ni9UCj3tW6zdpDTEFiy+KXOZWGzVwyQFxFxc=
=rZ92
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32697@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32697
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help