[PATCH] gnu: Add r-ac3net.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911085529.8441-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-ac3net): New variable.
---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5cd456914..86e873ec2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5645,3 +5645,24 @@ professional lives, but which are usually taught in isolation, if at all.")
"The @code{r-abd} package contains data sets and sample code for the Analysis of
biological data by Michael Whitlock and Dolph Schluter.")
(license license:gpl2)))
+
+(define-public r-ac3net
+ (package
+ (name "r-ac3net")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Ac3net" version))
+ (sha256
+ (base32 "1ns4n0xxz6p34c11bj0k7nzgmyqr9mis2b0g5nfz37dbikndyqyz"))))
+ (properties `((upstream-name . "Ac3net")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)))
+ (home-page "https://cran.r-project.org/web/packages/Ac3net/")
+ (synopsis "Inferring directional conservative causal core gene networks")
+ (description
+ "This package infers directional Conservative causal core (gene) networks (C3NET).
+ This is a version of the algorithm C3NET with directional network.")
+ (license license:gpl3+)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32695
(address . control@debbugs.gnu.org)
165d3e1551f.34d03368221940930.1946413586986432600@zoho.com
owner 32695 !
Leo Famulari wrote 6 years ago
Re: [bug#32695] [PATCH] gnu: Add r-ac3net.
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32695-done@debbugs.gnu.org)
20181002202808.GD20264@jasmine.lan
On Tue, Sep 11, 2018 at 10:55:29AM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/cran.scm (r-ac3net): New variable.

Thanks! Pushed as c2ffc4fb53a23c4db975a52f85686ed4b194cfcf
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluz1NcACgkQJkb6MLrK
fwipjw//aa9dJsHrpo4dUJmol/c4umJMH7JrmrxBifB5w2KyL3yq3uQsCsQUjcze
5gFXTjMkutlhvmIJkwm697Dbnvi1I3SEPGN8v8jvDQJbRlybGZ5uQv0TSkHuPMzE
L5TFlWxtHz/eJEdFbV900n7hRNoaYXDgpD15Gs5BwqES/F/u4I9BLIgXIGXQ2u6n
IfwYwAcWW7vLYm9hmlybQOjxALZ8/TWWN7YHG060aDZw2Uwu/6Ci9tmQ/Q33s2dL
wU3smhzERhp6d7JlFGO9fM8rIuPAqEaBHLJ3OeWCd1NuxcaXS1Q0J7rtpAHr0rxC
NlK0igjmm21l9tV4OgJlpUx2zmiGYlQNb96YEURpNs/2XBO0CA0WQnClzWptAWBv
UzleP5tlf0TViKASWuzQdXH/m4x2BUEctogc7nnsVFum6Evrd+DZ+oEWLbFfSFI7
Xa0RgF9CRoSu1Yf4pr9TcMnMrNC5wRrYkdNbZ/zWQLHd+smOyDWngLZ3JwoexH0l
8ELLVHBLxrGpk62jkT8+FXRPU5uqJZGEZlIZ11aHNBnH/bMq+CotE0LtS8DSgueH
v8pFe45l2JanjpZTyI2VFgUjNDiEcbDwoS6tyzpPbtrT5ChHg7nS5ZYEhqiYuaKd
LPpA8ceGXXZY3VTryItbe5HXBKxQWAaxDODb9/WQaNTiGg9cKUo=
=iFql
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32695@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32695
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help