Update LibreOffice to 6.1.0.3

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 7 years ago
(address . guix-patches@gnu.org)
b73abf83-dda4-2edc-7aa2-b5e6a24146b1@web.de
Hi,

the attached patches updates LibreOffice to 6.1.0.3. I packaged "libnumbertext"
and verified that the functions "NUMBERTEXT" and "MONEYTEXT" working correct
after you installed the required extension.

I'm a little unsure if I have choosen the correct license for libnumbertext

Kind Regards
Jonathan
From 2fb37ecc93ae0dfa42f99a5a6f73a71113bc0f42 Mon Sep 17 00:00:00 2001
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Date: Tue, 11 Sep 2018 07:58:36 +0200
Subject: [PATCH 1/2] gnu: Add libnumbertext.

* gnu/packages/libreoffice.scm (libnumbertext): New public variable.
---
gnu/packages/libreoffice.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 3dc7a4bbf..2d1f9262d 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,7 +33,7 @@
#:use-module (guix download)
#:use-module ((guix licenses)
#:select (gpl2+ lgpl2.1+ lgpl3+ mpl1.1 mpl2.0
- non-copyleft x11-style))
+ non-copyleft x11-style bsd-2))
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (ice-9 match)
@@ -524,6 +525,31 @@ Aldus/Macromedia/Adobe FreeHand documents.")
Microsoft Publisher documents of all versions.")
(license mpl2.0)))
+(define-public libnumbertext
+ (package
+ (name "libnumbertext")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/numbertext/" name
+ "/archive/" version ".tar.gz"))
+ (sha256 (base32
+ "0wnsn4911fdd2na8jxkcvmk04a6xw6qlviic9w4qwg9fcym6866v"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-static")))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/Numbertext/libnumbertext")
+ (synopsis "Language-neutral NUMBERTEXT and MONEYTEXT functions")
+ (description "Language-neutral NUMBERTEXT and MONEYTEXT functions for
+LibreOffice Calc, available for C++ and Java.")
+ (license (list lgpl3+ bsd-2))))
+
(define-public libpagemaker
(package
(name "libpagemaker")
--
2.16.4
From d00a06c9edb50759eb7228a1581c4ef9bc313e5d Mon Sep 17 00:00:00 2001
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Date: Tue, 11 Sep 2018 07:59:11 +0200
Subject: [PATCH 2/2] gnu: libreoffice: Update to 6.1.0.3.

* gnu/packages/libreoffice.scm (libreoffice): Update to 6.1.0.3.
[source]: Correct indenting.
[inputs]: Add libnumbertext and python-lxml.
---
gnu/packages/libreoffice.scm | 22 ++++++++++++----------
1 file changed, 12 insertions(+), 10 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 2d1f9262d..fb49d18d5 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -922,19 +922,19 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(define-public libreoffice
(package
(name "libreoffice")
- (version "6.0.6.2")
+ (version "6.1.0.3")
(source
(origin
- (method url-fetch)
- (uri
+ (method url-fetch)
+ (uri
(string-append
- "https://download.documentfoundation.org/libreoffice/src/"
- (version-prefix version 3) "/libreoffice-" version ".tar.xz"))
- (sha256
- (base32
- "13kaikaz65xw9a3hxbh245cnydjpy58np22c7s0s65pnmcq68rpi"))
- (patches (search-patches "libreoffice-icu.patch"
- "libreoffice-glm.patch"))))
+ "https://download.documentfoundation.org/libreoffice/src/"
+ (version-prefix version 3) "/libreoffice-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1n7b6abc0bp9x8lddx60w5br444wf62mdlkqmfk2zmkmiwkcvv2l"))
+ (patches (search-patches "libreoffice-icu.patch"
+ "libreoffice-glm.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
@@ -975,6 +975,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("libltdl" ,libltdl)
("libmspub" ,libmspub)
("libmwaw" ,libmwaw)
+ ("libnumbertext" ,libnumbertext)
("libodfgen" ,libodfgen)
("libpagemaker" ,libpagemaker)
("libqxp" ,libqxp)
@@ -1001,6 +1002,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("poppler" ,poppler)
("postgresql" ,postgresql)
("python" ,python)
+ ("python-lxml" ,python-lxml)
("redland" ,redland)
("sane-backends" ,sane-backends)
("unixodbc" ,unixodbc)
--
2.16.4
Ludovic Courtès wrote 6 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 32692-done@debbugs.gnu.org)
87pnxk828o.fsf@gnu.org
Hi,

Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

Toggle quote (3 lines)
> I'm a little unsure if I have choosen the correct license for libnumbertext
> https://github.com/numbertext/libnumbertext/

AFAICS it’s BSD-3 + LGPLv3+.

Toggle quote (7 lines)
> From 2fb37ecc93ae0dfa42f99a5a6f73a71113bc0f42 Mon Sep 17 00:00:00 2001
> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
> Date: Tue, 11 Sep 2018 07:58:36 +0200
> Subject: [PATCH 1/2] gnu: Add libnumbertext.
>
> * gnu/packages/libreoffice.scm (libnumbertext): New public variable.

Applied with these changes:
Toggle diff (30 lines)
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 217e95126..d81f8aa79 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -33,7 +33,7 @@
#:use-module (guix download)
#:use-module ((guix licenses)
#:select (gpl2+ lgpl2.1+ lgpl3+ mpl1.1 mpl2.0
- non-copyleft x11-style bsd-2))
+ non-copyleft x11-style bsd-3))
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (ice-9 match)
@@ -547,10 +547,12 @@ Microsoft Publisher documents of all versions.")
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(home-page "https://github.com/Numbertext/libnumbertext")
- (synopsis "Language-neutral NUMBERTEXT and MONEYTEXT functions")
- (description "Language-neutral NUMBERTEXT and MONEYTEXT functions for
-LibreOffice Calc, available for C++ and Java.")
- (license (list lgpl3+ bsd-2))))
+ (synopsis "Language-neutral @code{NUMBERTEXT} and @code{MONEYTEXT} functions")
+ (description
+ "The libnumbertext library provides language-neutral @code{NUMBERTEXT}
+and @code{MONEYTEXT} functions for LibreOffice Calc, available for C++ and
+Java.")
+ (license (list lgpl3+ bsd-3))))
(define-public libpagemaker
(package
Toggle quote (9 lines)
> From d00a06c9edb50759eb7228a1581c4ef9bc313e5d Mon Sep 17 00:00:00 2001
> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
> Date: Tue, 11 Sep 2018 07:59:11 +0200
> Subject: [PATCH 2/2] gnu: libreoffice: Update to 6.1.0.3.
>
> * gnu/packages/libreoffice.scm (libreoffice): Update to 6.1.0.3.
> [source]: Correct indenting.
> [inputs]: Add libnumbertext and python-lxml.

Pushed as 52b0a352c376eaed4ae7cf109f66538d6ac0a859.

I speculatively chose to push it without waiting for the build to
complete. If it turns out to break, we should revert it and work from
there.

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32692@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32692
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help