Add r-quic + r-abundant

  • Done
  • quality assurance status badge
Details
4 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Ludovic Courtès
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 7 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
918DDFCAA65E9447BD6F28DB666521DA991050@DAGONE.mdc-berlin.net
Mădălin Ionel Patrașcu
System Administrator
Bioinformatics Platform
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany
pimi wrote 7 years ago
(address . 32689@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180910192951.8049-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-quic): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fd4929c0f..d31f1c81a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5592,3 +5592,25 @@ with an initial V-D-J recombination event, starting the first phylogenetic tree.
representing one simulated time step. Various mutation events are possible at
each time step, contributing to a diverse final repertoire.")
(license license:gpl2)))
+
+(define-public r-quic
+ (package
+ (name "r-quic")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "QUIC" version))
+ (sha256
+ (base32 "021bp9xbaih60qmss015ycblbv6d1dvb1z89y93zpqqnc2qhpv3c"))))
+ (properties `((upstream-name . "QUIC")))
+ (build-system r-build-system)
+ (home-page "https://www.cs.utexas.edu/users/sustik/QUIC/")
+ (synopsis "Regularized sparse inverse covariance matrix estimation")
+ (description
+ "This package algorithm implements the l1 regularized Gaussian maximum likelihood
+estimation of the inverse of a covariance matrix. It uses Newton's method and
+coordinate descent to solve the regularized inverse covariance matrix estimation
+problem.")
+ ;; on the home-page it is mentioned that the release is under GPLv3 or later
+ (license license:gpl3+)))
--
2.17.1
pimi wrote 7 years ago
[PATCH] gnu: Add r-abundant.
(address . 32689@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180910193257.8345-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abundant): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d31f1c81a..41d6e44ed 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5614,3 +5614,27 @@ coordinate descent to solve the regularized inverse covariance matrix estimation
problem.")
;; on the home-page it is mentioned that the release is under GPLv3 or later
(license license:gpl3+)))
+
+(define-public r-abundant
+ (package
+ (name "r-abundant")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abundant" version))
+ (sha256
+ (base32 "1m76qdmqvwpgm0sihazi2dna7cgsz9rljal18vgffb5wamwmg9k7"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-quic" ,r-quic)))
+ (home-page "https://cran.r-project.org/web/packages/abundant/")
+ (synopsis "Abundant regression and high-dimensional principal fitted components")
+ (description
+ "This package fits and predicts with the high-dimensional principal fitted components
+model. It is demonstrated that asymptotic behavior of a class of methods for
+sufficient dimension reduction in high-dimension regressions, are consistent in
+a variety of settings, particularly in abundant regressions where most
+predictors contribute some information on the response, and oracle rates are
+possible.")
+ (license license:gpl2)))
--
2.17.1
Ludovic Courtès wrote 7 years ago
control message for bug #32689
(address . control@debbugs.gnu.org)
87lg89cdqu.fsf@gnu.org
retitle 32689 Add r-quic + r-abundant
Ricardo Wurmus wrote 6 years ago
(address . control@debbugs.gnu.org)
165d3e13c38.6a6b1c06974273209.-184459513028708500@zoho.com
owner 32689 !
Ludovic Courtès wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 32689@debbugs.gnu.org)
87bm7fa1zu.fsf@gnu.org
Hello!

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (2 lines)
> owner 32689 !

Are you taking care of these two patches? :-)

Thanks,
Ludo’.
Ricardo Wurmus wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 32689-done@debbugs.gnu.org)(name . Patrascu, Madalin Ionel)(address . MadalinIonel.Patrascu@mdc-berlin.de)
87in1n49du.fsf@elephly.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
> Hello!
>
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>> owner 32689 !
>
> Are you taking care of these two patches? :-)

Ouch! This fell through the many cracks that have opened up in my life
in the past two months. Thank you for the reminder.

I just made some minor changes, linted, and built the two packages.
Pushed with commit b509df82d.

Thanks and my apologies for taking so long!

--
Ricardo
Closed
Ludovic Courtès wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 32689-done@debbugs.gnu.org)(name . Patrascu, Madalin Ionel)(address . MadalinIonel.Patrascu@mdc-berlin.de)
87va5l4s71.fsf@gnu.org
Hi!

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (13 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hello!
>>
>> Ricardo Wurmus <rekado@elephly.net> skribis:
>>
>>> owner 32689 !
>>
>> Are you taking care of these two patches? :-)
>
> Ouch! This fell through the many cracks that have opened up in my life
> in the past two months. Thank you for the reminder.

I thought so but I wasn’t sure if the “owner” directive really meant
what I thought it meant.

Toggle quote (5 lines)
> I just made some minor changes, linted, and built the two packages.
> Pushed with commit b509df82d.
>
> Thanks and my apologies for taking so long!

No problem, thank you!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32689@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32689
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help