[PATCH] gnu: Add r-absfiltergsea.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180910140541.705-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/bioinformatics.scm (r-absfiltergsea): New variable.
---
gnu/packages/bioinformatics.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6580cac53..9c01cb86f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13504,3 +13504,30 @@ reference transcripts provided in a annotation file (also in GTF/GFF3 format).
(list
license:expat ;license for gffcompare
license:artistic2.0))))) ;license for gclib
+
+(define-public r-absfiltergsea
+ (package
+ (name "r-absfiltergsea")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "AbsFilterGSEA" version))
+ (sha256
+ (base32 "15srxkxsvn38kd5frdrwfdf0ad8gskrd0h01wmdf9hglq8fjrp7w"))))
+ (properties `((upstream-name . "AbsFilterGSEA")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-deseq" ,r-deseq)
+ ("r-limma" ,r-limma)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page "https://cran.r-project.org/web/packages/AbsFilterGSEA/")
+ (synopsis "Improved false positive control of gene-permuting with absolute filtering")
+ (description
+ "This package provides a function that performs gene-permuting of a gene-set
+enrichment analysis (GSEA) calculation with or without the absolute filtering.
+ Without filtering, users can perform (original) two-tailed or one-tailed
+absolute GSEA.")
+ (license license:gpl2)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32682
(address . control@debbugs.gnu.org)
165d3e10739.1058569c-417232338.7578034511434327224@zoho.com
owner 32682 !
Leo Famulari wrote 6 years ago
Re: [bug#32682] [PATCH] gnu: Add r-absfiltergsea.
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32682-done@debbugs.gnu.org)
20181002202416.GB20264@jasmine.lan
On Mon, Sep 10, 2018 at 04:05:41PM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/bioinformatics.scm (r-absfiltergsea): New variable.

Thanks! Pushed as 0f1622220a39a620854b0a268793e262746d460a
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluz0/AACgkQJkb6MLrK
fwh3VhAAz2ehnh1DIJhykRqtiEdpvUzc96nNhXkXfoQequQAmPY/ZfX83tI2rSPc
gHYzsIQ4/XQDzbyipuXZlJoBHalA2gubGksiPyDUrHyMhbBHVVJPuXlT9fpmtQqF
0e6SUMFEzdoNK3RzvBPBE8Mm4avimWmdffHeppQOIhgFVy9fBfz+JwnSNZ+X1xBr
8XsRq0CwCPyt9CfvlYot/l6s/XqSLUj+n2zRlykvUVJ+y3zs/5D9jvfSSTYS+rNt
O893xIRjiAhjhMh41dgryRPsNdDXJ8+Hw4RIty4o5kRtYC+hYNfz9lcG9v8OPw9F
L72VooRrvbLrCCUb0UfwaA4YKEyIbf1BHebzJze0MA07EHzYEsOpDESaa05B3Lnr
FA4jJ2gMaweuFA6ZRLxsnV40/dV9wj6KILIAyG8Yt+xpd1ZVwwDxBLDOkjEpIDVV
mPGrODMnJAV4Vk9pFZBznja+rrLuNDmYOo+0Yd4iUxpo6ci6fXta0HiOE3qiZEls
2DlQU3EueOVL10fKJbNXrGIx4mJeZSU6jZ5aV9Vz26/BNMhhUdd1FvTV+/mwMFa5
j6IKR+vOv3iaoxL4i/7Klec2ELaIJorvsVT+eZ9M51O5o81iSGU6smxZVLKbRc8J
DD3Qx3lU+xSC/FQPNRjnGJMG4jQbnDgRfKtvGo3QCxP3wfOzp00=
=Fm5y
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32682@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32682
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help