pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
gnu/packages/cran.scm (r-abps): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 962b82168..2d97a12d0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5592,3 +5592,27 @@ complexity;
@end enumerate
These algorithms are well suited for high dimensional data outlier detection.")
(license license:expat)))
+
+(define-public r-abps
+ (package
+ (name "r-abps")
+ (version "0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ABPS" version))
+ (sha256
+ (base32 "1k3f5i34f4w2khkszb4qhwwcpiy7gsfh82vjr6rypwg6rx5rjclq"))))
+ (properties `((upstream-name . "ABPS")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-kernlab" ,r-kernlab)))
+ (home-page "https://cran.r-project.org/web/packages/ABPS/")
+ (synopsis "Abnormal blood profile score to detect blood doping")
+ (description
+ "This package offers an implementation of the Abnormal blood profile score (ABPS).
+ The ABPS is a part of the Athlete biological passport program of the World
+anti-doping agency, which combines several blood parameters into a single score
+in order to detect blood doping. The package also contains functions to
+calculate other scores used in anti-doping programs, such as the ratio of
+hemoglobin to reticulocytes (OFF-score), as well as example data.")
+ (license license:gpl2+)))
--
2.17.1