[PATCH] gnu: Add r-abps.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180910125007.25253-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abps): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 962b82168..2d97a12d0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5592,3 +5592,27 @@ complexity;
@end enumerate
These algorithms are well suited for high dimensional data outlier detection.")
(license license:expat)))
+
+(define-public r-abps
+ (package
+ (name "r-abps")
+ (version "0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ABPS" version))
+ (sha256
+ (base32 "1k3f5i34f4w2khkszb4qhwwcpiy7gsfh82vjr6rypwg6rx5rjclq"))))
+ (properties `((upstream-name . "ABPS")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-kernlab" ,r-kernlab)))
+ (home-page "https://cran.r-project.org/web/packages/ABPS/")
+ (synopsis "Abnormal blood profile score to detect blood doping")
+ (description
+ "This package offers an implementation of the Abnormal blood profile score (ABPS).
+ The ABPS is a part of the Athlete biological passport program of the World
+anti-doping agency, which combines several blood parameters into a single score
+in order to detect blood doping. The package also contains functions to
+calculate other scores used in anti-doping programs, such as the ratio of
+hemoglobin to reticulocytes (OFF-score), as well as example data.")
+ (license license:gpl2+)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32679
(address . control@debbugs.gnu.org)
165d3e0ca6c.41e0b443658515734.4434753622409084115@zoho.com
owner 32679 !
Leo Famulari wrote 6 years ago
Re: [bug#32679] [PATCH] gnu: Add r-abps.
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32679-done@debbugs.gnu.org)
20181002195142.GB18113@jasmine.lan
On Mon, Sep 10, 2018 at 02:50:07PM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/cran.scm (r-abps): New variable.

Pushed as 03c95f04147b8022983d39d49171db8eb08e8c59
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluzzE4ACgkQJkb6MLrK
fwjlMg/9F5qBoZe13KB2arRe7NCx2aqlARr/weAgb7SXrKCoJUZI82EgOuU8NwsQ
m/g4/U1b9AYDwvc61UAXfGcWb4i8wlYInphR4Bc7MpgcaXPjn/FAveiDK7Z2A699
ewrLevuTm1EnJMASDRxoknP2HkNzrWDHRZSIbGf5+oPfAjjMb5QN+YCwriMZrMLv
CMOQhet8is8hX5Ko0f+NxD5mSD7I/GUvpaMnaVAmjSMvlqc+K2vCmOQYf2cQb8Mm
NpGAocyGOkQ5xvti/O1LUn+BfL9irxieGrASIaIOJDXRyZa6e9KaXcFlTHDLQXOS
TlNBAzYAVxcf21VTyKTVV6NDVSdEWrDy1wo148Uhwm/t3pp7+/Hq8njCzbxz7U/4
UE96252GXfC3GY6tT4LQ0uvSpADD/O0bgQeaquTImwKS/KHe9pnx9nYpQTIh6e5z
VU3bB7bdm+6TPfKYnzxpb73YDUuFgTT79iNE7i5aSjH8JG0I8fZb1KLAAO0arz6W
Q5ieul/pnz33bi6OnclWylcpt+PFX30kj+ELgO5UNIsh1wF+888cGXg2wA6O6V+c
moIm/PUywbgOd0gqia8XfU1Iod9UmujczvldPX4JfKqqNQZuyFOhoJA3PjWDIzyx
FOEeIao9InrfZEtJ9Ds7MH3xBz/2CcFtN4Ez2GcORMC5pgyZa2I=
=S5Fu
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32679@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32679
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help