[PATCH] gnu: Add r-abodoutlier.

  • Done
  • quality assurance status badge
Details
2 participants
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal
P
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180910112138.24192-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abodoutlier): New variable.
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 814439172..962b82168 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5564,3 +5564,31 @@ gf_density(), and so on, bring the formula interface to ggplot(). This captures
and extends the excellent simplicity of the lattice-graphics formula interface,
while providing the intuitive capabilities of @code{r-ggplot2}.")
(license license:expat)))
+
+(define-public r-abodoutlier
+ (package
+ (name "r-abodoutlier")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abodOutlier" version))
+ (sha256
+ (base32 "1pvhgxmh23br84r0fbmv7g53z2427birdja96a67vqgz18r3fdvj"))))
+ (properties `((upstream-name . "abodOutlier")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cluster" ,r-cluster)))
+ (home-page "https://cran.r-project.org/web/packages/abodOutlier/")
+ (synopsis "Angle-based outlier detection")
+ (description
+ "This package performs angle-based outlier detection on a given data frame.
+ The @code{r-abodoutlier} package offers three methods to process data:
+@enumerate
+@item - full but slow implementation using all the data that has cubic
+complexity;
+@item - a fully randomized method;
+@item - a method using k-nearest neighbours.
+@end enumerate
+ These algorithms are well suited for high dimensional data outlier detection.")
+ (license license:expat)))
--
2.17.1
R
R
Ricardo Wurmus wrote on 13 Sep 2018 19:00
control message for bug #32678
(address . control@debbugs.gnu.org)
165d3e0a81e.7caabafe709204280.-7423030561080352544@zoho.com
owner 32678 !
R
R
Ricardo Wurmus wrote on 14 Sep 2018 07:48
[PATCH] gnu: Add r-abodoutlier.
(address . 32678-done@debbugs.gnu.org)
8736uc7hoi.fsf@elephly.net
Hi,

I’ve adjusted the description and applied the patch to the “master”
branch with commit 016cabf7bee007fb580d355113de8aa13d0f0a2b.

Thanks!

--
Ricardo
Closed
?