[PATCH] gnu: Add r-abodoutlier.

  • Done
  • quality assurance status badge
Details
2 participants
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180910112138.24192-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abodoutlier): New variable.
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 814439172..962b82168 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5564,3 +5564,31 @@ gf_density(), and so on, bring the formula interface to ggplot(). This captures
and extends the excellent simplicity of the lattice-graphics formula interface,
while providing the intuitive capabilities of @code{r-ggplot2}.")
(license license:expat)))
+
+(define-public r-abodoutlier
+ (package
+ (name "r-abodoutlier")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abodOutlier" version))
+ (sha256
+ (base32 "1pvhgxmh23br84r0fbmv7g53z2427birdja96a67vqgz18r3fdvj"))))
+ (properties `((upstream-name . "abodOutlier")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cluster" ,r-cluster)))
+ (home-page "https://cran.r-project.org/web/packages/abodOutlier/")
+ (synopsis "Angle-based outlier detection")
+ (description
+ "This package performs angle-based outlier detection on a given data frame.
+ The @code{r-abodoutlier} package offers three methods to process data:
+@enumerate
+@item - full but slow implementation using all the data that has cubic
+complexity;
+@item - a fully randomized method;
+@item - a method using k-nearest neighbours.
+@end enumerate
+ These algorithms are well suited for high dimensional data outlier detection.")
+ (license license:expat)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32678
(address . control@debbugs.gnu.org)
165d3e0a81e.7caabafe709204280.-7423030561080352544@zoho.com
owner 32678 !
Ricardo Wurmus wrote 6 years ago
[PATCH] gnu: Add r-abodoutlier.
(address . 32678-done@debbugs.gnu.org)
8736uc7hoi.fsf@elephly.net
Hi,

I’ve adjusted the description and applied the patch to the “master”
branch with commit 016cabf7bee007fb580d355113de8aa13d0f0a2b.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32678@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32678
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help