[PATCH] gnu: Add r-abnormality.

  • Done
  • quality assurance status badge
Details
2 participants
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180903145946.17691-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abnormality): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 35ac818d1..842cac011 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5096,3 +5096,27 @@ based on @code{r-ggplot2}.")
and basic manipulation of Brazilian lawsuits identification number. It also
implements functions for text cleaning, such as accentuation removal.")
(license license:expat)))
+
+(define-public r-abnormality
+ (package
+ (name "r-abnormality")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abnormality" version))
+ (sha256
+ (base32 "1fzfskl9akl06nliy8hkv2a0pznpj8pwcypg3gj5r2nzvr3kan9v"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-matrix" ,r-matrix)))
+ (home-page "https://cran.r-project.org/web/packages/abnormality/")
+ (synopsis "Measure a subject's abnormality with respect to a reference population")
+ (description
+ "This package contains functions to implement the methodology and considerations
+laid out by Marks et al. in article Measuring abnormality in high dimensional
+spaces: applications in biomechanical gait analysis. Using high-dimensional
+datasets to measure a subject's overall level of abnormality as compared to a
+reference population is often needed in outcomes research.")
+ (license license:expat)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32626
(address . control@debbugs.gnu.org)
165d3e07b6f.12f823ab402892733.-3110773266435384135@zoho.com
owner 32626 !
Ricardo Wurmus wrote 6 years ago
[PATCH] gnu: Add r-abnormality.
(address . 32626-done@debbugs.gnu.org)
877ejp6rro.fsf@elephly.net
I made some changes to the description and pushed it to the “master”
branch with commit b6afe7b7f.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32626@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32626
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help