[PATCH] gnu: Add r-abjutils.

  • Done
  • quality assurance status badge
Details
2 participants
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180903141638.16832-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abjutils): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e72eec369..35ac818d1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5062,3 +5062,37 @@ provides functionalities not found in either @code{TASSEL} or @code{r-qtl} in
addition to visualization of genotypes as \"graphical genotypes\". Plotting is
based on @code{r-ggplot2}.")
(license license:gpl3)))
+
+(define-public r-abjutils
+ (package
+ (name "r-abjutils")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abjutils" version))
+ (sha256
+ (base32 "0qrsc4if7aif73qp95lw6b5986c2r0jn7m39123zij8k15vc935b"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-devtools" ,r-devtools)
+ ("r-dplyr" ,r-dplyr)
+ ("r-glue" ,r-glue)
+ ("r-httr" ,r-httr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-plyr" ,r-plyr)
+ ("r-progress" ,r-progress)
+ ("r-purrr" ,r-purrr)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-scales" ,r-scales)
+ ("r-stringi" ,r-stringi)
+ ("r-stringr" ,r-stringr)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "https://github.com/abjur/abjutils/")
+ (synopsis "This package is a collection of tools for Jurimetrical analysis")
+ (description
+ "This package implements general purpose tools, such as functions for sampling
+and basic manipulation of Brazilian lawsuits identification number. It also
+implements functions for text cleaning, such as accentuation removal.")
+ (license license:expat)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32625
(address . control@debbugs.gnu.org)
165d3e05ba2.3eb4efb127801250.8485516068056899346@zoho.com
owner 32625 !
Ricardo Wurmus wrote 6 years ago
[PATCH] gnu: Add r-abjutils.
(address . 32625-done@debbugs.gnu.org)
87musliaah.fsf@elephly.net
Fixed the commit message and pushed it to the “master” branch with
commit ebb3cdb1e.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32625@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32625
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help