[PATCH] gnu: Add r-abhgenotyper.

  • Done
  • quality assurance status badge
Details
2 participants
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180903134520.15980-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abhgenotyper): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 33dc61593..e72eec369 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5035,3 +5035,30 @@ practically sound, highly interpretable model.")
Axon Instruments/Molecular Devices software such as pClamp 10. Only files
recorded in gap-free mode are currently supported.")
(license license:artistic2.0)))
+
+(define-public r-abhgenotyper
+ (package
+ (name "r-abhgenotyper")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ABHgenotypeR" version))
+ (sha256
+ (base32 "08cpmnaaxsm5c5bjifnfxdlvg5inrf13biqpcl2yq5zpqjmiki0l"))))
+ (properties `((upstream-name . "ABHgenotypeR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-reshape2" ,r-reshape2)))
+ (home-page "https://github.com/StefanReuscher/ABHgenotypeR/")
+ (synopsis "The @code{r-abhgenotyper} helps visualize and manipulate ABH genotypes")
+ (description
+ "The @code{r-abhgenotyper} package provides simple imputation, error-correction and
+plotting capacities for genotype data. The @code{r-abhgenotyper} package is
+supposed to serve as an intermediate but independent analysis tool between the
+@code{TASSEL GBS} pipeline and the @code{r-qtl} package. The @code{r-abhgenotyper}
+provides functionalities not found in either @code{TASSEL} or @code{r-qtl} in
+addition to visualization of genotypes as \"graphical genotypes\". Plotting is
+based on @code{r-ggplot2}.")
+ (license license:gpl3)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32623
(address . control@debbugs.gnu.org)
165d3e037c4.34cd48ef18457303.-3329951539175846017@zoho.com
owner 32623 !
Ricardo Wurmus wrote 6 years ago
[PATCH] gnu: Add r-abhgenotyper.
(address . 32623-done@debbugs.gnu.org)
87o9d1iakd.fsf@elephly.net
I fixed the description and the commit message and pushed it to the
“master” branch with commit 1efcd0f1ea980472659805d91a2bb486b4136f81.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32623@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32623
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help