pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
gnu/packages/cran.scm (r-abhgenotyper): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 33dc61593..e72eec369 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5035,3 +5035,30 @@ practically sound, highly interpretable model.")
Axon Instruments/Molecular Devices software such as pClamp 10. Only files
recorded in gap-free mode are currently supported.")
(license license:artistic2.0)))
+
+(define-public r-abhgenotyper
+ (package
+ (name "r-abhgenotyper")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ABHgenotypeR" version))
+ (sha256
+ (base32 "08cpmnaaxsm5c5bjifnfxdlvg5inrf13biqpcl2yq5zpqjmiki0l"))))
+ (properties `((upstream-name . "ABHgenotypeR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-reshape2" ,r-reshape2)))
+ (home-page "https://github.com/StefanReuscher/ABHgenotypeR/")
+ (synopsis "The @code{r-abhgenotyper} helps visualize and manipulate ABH genotypes")
+ (description
+ "The @code{r-abhgenotyper} package provides simple imputation, error-correction and
+plotting capacities for genotype data. The @code{r-abhgenotyper} package is
+supposed to serve as an intermediate but independent analysis tool between the
+@code{TASSEL GBS} pipeline and the @code{r-qtl} package. The @code{r-abhgenotyper}
+provides functionalities not found in either @code{TASSEL} or @code{r-qtl} in
+addition to visualization of genotypes as \"graphical genotypes\". Plotting is
+based on @code{r-ggplot2}.")
+ (license license:gpl3)))
--
2.17.1