pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
gnu/packages/cran.scm (r-abf2): New variable.
---
gnu/packages/cran.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)
Toggle diff (29 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dde5fb317..33dc61593 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5016,3 +5016,22 @@ information based criteria with the change in estimate to either select the
optimal model for prediction purposes or to serve as a tool to obtain a
practically sound, highly interpretable model.")
(license license:gpl2+)))
+
+(define-public r-abf2
+ (package
+ (name "r-abf2")
+ (version "0.7-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abf2" version))
+ (sha256
+ (base32 "0d65mc1w4pbiv7xaqzdlw1bfsxf25587rv597hh41vs0j0zlfpxx"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/abf2/")
+ (synopsis "Load gap-free axon @code{r-abf2} files")
+ (description
+ "This package loads electrophysiology data from @code{r-abf2} files, as created by
+Axon Instruments/Molecular Devices software such as pClamp 10. Only files
+recorded in gap-free mode are currently supported.")
+ (license license:artistic2.0)))
--
2.17.1