[PATCH] gnu: Add r-abf2.

  • Done
  • quality assurance status badge
Details
2 participants
  • pimi
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180903132814.15547-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abf2): New variable.
---
gnu/packages/cran.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dde5fb317..33dc61593 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5016,3 +5016,22 @@ information based criteria with the change in estimate to either select the
optimal model for prediction purposes or to serve as a tool to obtain a
practically sound, highly interpretable model.")
(license license:gpl2+)))
+
+(define-public r-abf2
+ (package
+ (name "r-abf2")
+ (version "0.7-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abf2" version))
+ (sha256
+ (base32 "0d65mc1w4pbiv7xaqzdlw1bfsxf25587rv597hh41vs0j0zlfpxx"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/abf2/")
+ (synopsis "Load gap-free axon @code{r-abf2} files")
+ (description
+ "This package loads electrophysiology data from @code{r-abf2} files, as created by
+Axon Instruments/Molecular Devices software such as pClamp 10. Only files
+recorded in gap-free mode are currently supported.")
+ (license license:artistic2.0)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32622
(address . control@debbugs.gnu.org)
165d3dffd31.57b7caf4-1084143163.7981734202466066165@zoho.com
owner 32622 !
Ricardo Wurmus wrote 6 years ago
[PATCH] gnu: Add r-abf2.
(address . 32622-done@debbugs.gnu.org)
87pnxhiax7.fsf@elephly.net
Pushed to “master” branch with commit ef26400b6 after fixing the
description.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32622@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32622
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help