[PATCH] gnu: Add r-abe.

  • Done
  • quality assurance status badge
Details
2 participants
  • pimi
  • Ricardo Wurmus
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180903122758.15121-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abe): New variable.
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 016d1b1e4..dde5fb317 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4988,3 +4988,31 @@ maximum cycle number. The @code{r-abcoptim} implements the Artificial bee
colony optimization algorithm @url{http://mf.erciyes.edu.tr/abc/pub/tr06_2005.pdf}.
This version is a work-in-progress and is written in R code.")
(license license:expat)))
+
+(define-public r-abe
+ (package
+ (name "r-abe")
+ (version "3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abe" version))
+ (sha256
+ (base32
+ "1f19h3xzzmjhvwc1rrb8z0rai3ip03y4gdi2gg9bfr5sg2nfklk6"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/abe/")
+ (synopsis "Augmented backward elimination")
+ (description
+ "Statistical models are simple mathematical rules derived from empirical data describing
+the association between an outcome and several explanatory variables. In a
+typical modeling situation statistical analysis often involves a large number of
+potential explanatory variables and frequently only partial subject-matter
+knowledge is available. Therefore, selecting the most suitable variables for a
+model in an objective and practical manner is usually a non-trivial task. This
+package performs augmented backward elimination and checks the stability of the
+obtained model. Augmented backward elimination combines significance or
+information based criteria with the change in estimate to either select the
+optimal model for prediction purposes or to serve as a tool to obtain a
+practically sound, highly interpretable model.")
+ (license license:gpl2+)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
(address . 32621-done@debbugs.gnu.org)
87tvmtil9z.fsf@elephly.net
Thanks for the patch!

I found the description a little too long, so I shortened it and pushed
the patch to the master branch with commit 3cadd3ce9.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32621@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32621
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help