[PATCH 1/1] gnu: kicad: Update to 5.0.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 7 years ago
(address . guix-patches@gnu.org)
72009cd2-d7cd-1e32-a460-4a3613dc6776@web.de
Hello Guix,

the attached patch updates KiCAD to version 5.0.0.

kicad-library is still on version 4.0.7, because upstream splitted it into three individual repos:
- symbols
- footprints
- 3D models

This work will be left over for another patch...

Jonathan
From 0a77d3c9c278a4b82f02095a18df64764e42a743 Mon Sep 17 00:00:00 2001
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Date: Thu, 16 Aug 2018 13:33:48 +0200
Subject: [PATCH 1/1] gnu: kicad: Update to 5.0.0.

* gnu/packages/engineering.scm (kicad): Update to 5.0.0.
[source]: Change from git to url-fetch.
[arguments]: Remove now unneeded build version parameter.
---
gnu/packages/engineering.scm | 24 +++++++++---------------
1 file changed, 9 insertions(+), 15 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index d53b25cff..be58cb9ac 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -680,24 +681,19 @@ language.")
(define-public ao
(deprecated-package "ao-cad" libfive))
-;; We use kicad from a git commit, because support for boost 1.61.0 has been
-;; recently added.
(define-public kicad
- (let ((commit "5f4599fb56da4dd748845ab10abec02961d477f3")
- (revision "2"))
(package
(name "kicad")
- (version (string-append "4.0-" revision "."
- (string-take commit 7)))
+ (version "5.0.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.launchpad.net/kicad")
- (commit commit)))
+ (method url-fetch)
+ (file-name (string-append name "-" version ".tar.xz"))
+ (uri (string-append
+ "https://launchpad.net/kicad/5.0/" version "/+download/" name
+ "-" version ".tar.xz"))
(sha256
- (base32 "1833pln2975gmc5s18xf7s8m9vg834lmxxdjk0wlk3lq7bvjjnff"))
- (file-name (string-append name "-" version "-checkout"))))
+ (base32 "17nqjszyvd25wi6550j981whlnb1wxzmlanljdjihiki53j84x9p"))))
(build-system cmake-build-system)
(arguments
`(#:out-of-source? #t
@@ -706,8 +702,6 @@ language.")
#:configure-flags
(list "-DKICAD_STABLE_VERSION=ON"
"-DKICAD_REPO_NAME=stable"
- ,(string-append "-DKICAD_BUILD_VERSION=4.0-"
- (string-take commit 7))
"-DKICAD_SKIP_BOOST=ON"; Use our system's boost library.
"-DKICAD_SCRIPTING=ON"
"-DKICAD_SCRIPTING_MODULES=ON"
@@ -764,7 +758,7 @@ language.")
boards and electrical circuits. The software has a number of programs that
perform specific functions, for example, pcbnew (Editing PCB), eeschema (editing
electrical diagrams), gerbview (viewing Gerber files) and others.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public kicad-library
(let ((version "4.0.7"))
--
2.16.4
Ludovic Courtès wrote 7 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 32616@debbugs.gnu.org)
87d0tuuupd.fsf@gnu.org
Hi Jonathan,

Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

Toggle quote (9 lines)
> From 0a77d3c9c278a4b82f02095a18df64764e42a743 Mon Sep 17 00:00:00 2001
> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
> Date: Thu, 16 Aug 2018 13:33:48 +0200
> Subject: [PATCH 1/1] gnu: kicad: Update to 5.0.0.
>
> * gnu/packages/engineering.scm (kicad): Update to 5.0.0.
> [source]: Change from git to url-fetch.
> [arguments]: Remove now unneeded build version parameter.

I applied the patch but it fails to build for me on current master
(commit c702749dfd47ea6983768cd5b8cf828898445af0):

Toggle snippet (34 lines)
-- Found wxWidgets: -L/gnu/store/1yc0cjffyhssfs86vfihagz87p1d3cv2-wxwidgets-gtk2-3.0.3/lib;-pthread;;;-L/gnu/store/9chrdljzgar9mxll0bh2cv1r09mvas80-mesa-18.1.5/lib;-lwx_gtk2u_gl-3.0;-lwx_gtk2u_aui-3.0;-lwx_gtk2u_adv-3.0;-lwx_gtk2u_html-3.0;-lwx_gtk2u_core-3.0;-lwx_baseu_net-3.0;-lwx_baseu-3.0;-lwx_baseu_xml-3.0;-lwx_gtk2u_stc-3.0 (found suitable version "3.0.3", minimum required is "3.0.0")
-- Found OpenGL: /gnu/store/9chrdljzgar9mxll0bh2cv1r09mvas80-mesa-18.1.5/lib/libGL.so
-- Found GLEW: /gnu/store/3ly2mih66bwd41qgxc9x987vzan3ar7q-glew-2.0.0/include
-- Check for installed GLEW -- found
-- Found GLM: /gnu/store/lfnmqgl6kmxnjxmjlxhpdwcs14ch2rgr-glm-0.9.9.0/include (found suitable version "0.9.9.0", minimum required is "0.9.5.1")
-- Found PkgConfig: /gnu/store/vjxqhnn5vf223prpkq6yk3vcjlvqdx15-pkg-config-0.29.2/bin/pkg-config (found version "0.29.2")
-- Checking for module 'cairo'
-- Found cairo, version 1.14.10
-- Found Cairo: /gnu/store/r7ma8kclbk0gp4ymc8mfj4f7mywm46rn-cairo-1.14.10/lib/libcairo.so (found suitable version "1.14.10", minimum required is "1.8.8")
-- Checking for module 'pixman-1'
-- Found pixman-1, version 0.34.0
-- Found Pixman: /gnu/store/pslvw8b4r0m5vmbz2ml7whcv2wbdpa57-pixman-0.34.0/lib/libpixman-1.so (found suitable version "0.34.0", minimum required is "0.30")
-- Boost version: 1.66.0
-- Found ngspice: /gnu/store/kbfhl2m9yck3sa10a0bld85vhy73lqfr-libngspice-28/include
CMake Error at CMakeLists.txt:635 (find_package):
By not providing "FindOCE.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "OCE", but
CMake did not find one.

Could not find a package configuration file provided by "OCE" (requested
version 0.16) with any of the following names:

OCEConfig.cmake
oce-config.cmake

Add the installation prefix of "OCE" to CMAKE_PREFIX_PATH or set "OCE_DIR"
to a directory containing one of the above files. If "OCE" provides a
separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/tmp/guix-build-kicad-5.0.0.drv-0/build/CMakeFiles/CMakeOutput.log".

Ideas?

Thanks,
Ludo’.
Jonathan Brielmaier wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 32616@debbugs.gnu.org)
8962dea9-494d-a2eb-af11-6cf09ddfd0e4@web.de
On 9/3/18 11:39 PM, Ludovic Courtès wrote:
Toggle quote (4 lines)
> I applied the patch but it fails to build for me on current master
> (commit c702749dfd47ea6983768cd5b8cf828898445af0):
> Ideas?

Oh yes. I forget somewhere on the way "opencascade-oce" as input, which
is needed when you build kicad-5 with default config fkags. I attached
a patch including that change. Building with that patch was successful
here...

Thanks for reviewing :)
Jonathan
From 4d01274e9db300c120c7586d40db9b07f94e21a6 Mon Sep 17 00:00:00 2001
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Date: Thu, 16 Aug 2018 13:33:48 +0200
Subject: [PATCH 1/1] gnu: kicad: Update to 5.0.0.

* gnu/packages/engineering.scm (kicad): Update to 5.0.0.
[source]: Change from git to url-fetch.
[arguments]: Remove now unneeded build version parameter.
[inputs]: Add opencascade-oce.
---
gnu/packages/engineering.scm | 25 ++++++++++---------------
1 file changed, 10 insertions(+), 15 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index d53b25cff..ee524ec78 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -680,24 +681,19 @@ language.")
(define-public ao
(deprecated-package "ao-cad" libfive))
-;; We use kicad from a git commit, because support for boost 1.61.0 has been
-;; recently added.
(define-public kicad
- (let ((commit "5f4599fb56da4dd748845ab10abec02961d477f3")
- (revision "2"))
(package
(name "kicad")
- (version (string-append "4.0-" revision "."
- (string-take commit 7)))
+ (version "5.0.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.launchpad.net/kicad")
- (commit commit)))
+ (method url-fetch)
+ (file-name (string-append name "-" version ".tar.xz"))
+ (uri (string-append
+ "https://launchpad.net/kicad/5.0/" version "/+download/" name
+ "-" version ".tar.xz"))
(sha256
- (base32 "1833pln2975gmc5s18xf7s8m9vg834lmxxdjk0wlk3lq7bvjjnff"))
- (file-name (string-append name "-" version "-checkout"))))
+ (base32 "17nqjszyvd25wi6550j981whlnb1wxzmlanljdjihiki53j84x9p"))))
(build-system cmake-build-system)
(arguments
`(#:out-of-source? #t
@@ -706,8 +702,6 @@ language.")
#:configure-flags
(list "-DKICAD_STABLE_VERSION=ON"
"-DKICAD_REPO_NAME=stable"
- ,(string-append "-DKICAD_BUILD_VERSION=4.0-"
- (string-take commit 7))
"-DKICAD_SKIP_BOOST=ON"; Use our system's boost library.
"-DKICAD_SCRIPTING=ON"
"-DKICAD_SCRIPTING_MODULES=ON"
@@ -754,6 +748,7 @@ language.")
("libngspice" ,libngspice)
("libsm" ,libsm)
("mesa" ,mesa)
+ ("opencascade-oce" ,opencascade-oce)
("openssl" ,openssl)
("python" ,python-2)
("wxwidgets" ,wxwidgets-gtk2)
@@ -764,7 +759,7 @@ language.")
boards and electrical circuits. The software has a number of programs that
perform specific functions, for example, pcbnew (Editing PCB), eeschema (editing
electrical diagrams), gerbview (viewing Gerber files) and others.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public kicad-library
(let ((version "4.0.7"))
--
2.18.0
Ludovic Courtès wrote 7 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 32616-done@debbugs.gnu.org)
87h8j5bdv5.fsf@gnu.org
Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

Toggle quote (10 lines)
>>From 4d01274e9db300c120c7586d40db9b07f94e21a6 Mon Sep 17 00:00:00 2001
> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
> Date: Thu, 16 Aug 2018 13:33:48 +0200
> Subject: [PATCH 1/1] gnu: kicad: Update to 5.0.0.
>
> * gnu/packages/engineering.scm (kicad): Update to 5.0.0.
> [source]: Change from git to url-fetch.
> [arguments]: Remove now unneeded build version parameter.
> [inputs]: Add opencascade-oce.

Perfect. Applied, thanks!

Ludo'.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32616@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32616
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help