[PATCH] gnu: Add zabbix-agentd and zabbix-server.

  • Done
  • quality assurance status badge
Details
2 participants
  • Oleg Pykhalov
  • Leo Famulari
Owner
unassigned
Submitted by
Oleg Pykhalov
Severity
normal
O
O
Oleg Pykhalov wrote on 31 Aug 2018 04:50
(address . guix-patches@gnu.org)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20180831025033.16113-1-go.wigust@gmail.com
* gnu/packages/monitoring.scm (zabbix-agentd, zabbix-server): New variables.
---
gnu/packages/monitoring.scm | 85 ++++++++++++++++++++++++++++++++++++-
1 file changed, 84 insertions(+), 1 deletion(-)

Toggle diff (116 lines)
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index fae62d549..7332e6883 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -29,18 +29,25 @@
#:use-module (guix build-system python)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
+ #:use-module (guix utils)
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages django)
#:use-module (gnu packages gd)
#:use-module (gnu packages image)
#:use-module (gnu packages mail)
+ #:use-module (gnu packages networking)
+ #:use-module (gnu packages libevent)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
- #:use-module (gnu packages time))
+ #:use-module (gnu packages time)
+ #:use-module (gnu packages tls))
(define-public nagios
(package
@@ -138,6 +145,82 @@ etc. via a Web interface. Features include:
@end itemize\n")
(license license:gpl2)))
+(define-public zabbix-agentd
+ (package
+ (name "zabbix-agentd")
+ (version "3.4.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/zabbix/ZABBIX%20Latest%20Stable/" version
+ "/zabbix-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0qxgf6hx7ibhjmxd2sxizkjc8df4c9d31wz5hhql409ws98qf173"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--enable-agent"
+ (string-append "--with-iconv="
+ (assoc-ref %build-inputs "libiconv"))
+ (string-append "--with-libpcre="
+ (assoc-ref %build-inputs "pcre")))))
+ (inputs
+ `(("libiconv" ,libiconv)
+ ("pcre" ,pcre)))
+ (home-page "https://www.zabbix.com/")
+ (synopsis "Distributed monitoring solution (client-side agent)")
+ (description "This package provides a distributed monitoring
+solution (client-side agent)")
+ (license license:gpl2)))
+
+(define-public zabbix-server
+ (package
+ (inherit zabbix-agentd)
+ (name "zabbix-server")
+ (arguments
+ (substitute-keyword-arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-frontend
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((php (string-append (assoc-ref outputs "out")
+ "/share/zabbix/php"))
+ (front-end-conf (string-append php "/conf"))
+ (etc (string-append php "/etc")))
+ (mkdir-p php)
+ (copy-recursively "./frontends/php" php)
+ (rename-file front-end-conf
+ (string-append front-end-conf "-example"))
+ (symlink "/etc/zabbix" front-end-conf)))))
+ ,@(package-arguments zabbix-agentd))
+ ((#:configure-flags flags)
+ `(cons* "--enable-server"
+ "--with-postgresql"
+ (string-append "--with-libevent="
+ (assoc-ref %build-inputs "libevent"))
+ "--with-net-snmp"
+ (string-append "--with-gnutls="
+ (assoc-ref %build-inputs "gnutls"))
+ "--with-libcurl"
+ ,flags))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("libevent" ,libevent)
+ ("gnutls" ,gnutls)
+ ("postgresql" ,postgresql)
+ ("zlib" ,zlib)
+ ("net-snmp" ,net-snmp)
+ ("curl" ,curl)
+ ,@(package-inputs zabbix-agentd)))
+ (home-page "https://www.zabbix.com/")
+ (synopsis "Distributed monitoring solution (server-side)")
+ (description "This package provides a distributed monitoring
+solution (server-side)")
+ (license license:gpl2)))
+
(define-public darkstat
(package
(name "darkstat")
--
2.18.0
L
L
Leo Famulari wrote on 1 Sep 2018 14:53
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 32598@debbugs.gnu.org)
20180901125308.GA10255@jasmine.lan
On Fri, Aug 31, 2018 at 05:50:33AM +0300, Oleg Pykhalov wrote:
Toggle quote (2 lines)
> * gnu/packages/monitoring.scm (zabbix-agentd, zabbix-server): New variables.

LGTM, thanks! Just remember to add a copyright line to the file.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluKi64ACgkQJkb6MLrK
fwhB8w/+J1za5muH+oNoTzjHQAnsizt6ksd3cHGZ0gn7YAR52B1fUvyq2eCp1fVk
B6IK3k1Inck5T21Hf5ZnhgIxCctQ6+9g9+dmq7d0MdMnfEdbs9a0gQP8A4lHkMlx
HfQamLBAMbYdxFw+IEUtexV4GOJsnvcaeeO5He3Br5cOzotPqHfsrpVRcnhF9/me
8rjhGuS7AYYv6JunhQTXGXZ9pJKyZ5Dvg96gXrbiOfuYdlIlyhfkVbhgh080G4Vi
85PYB9rvz76EMuF14ttV1gc5Sf8VbRWJ6Qfdh/CjTzbZgV5BUUyYBvs+XsPZUOlf
oK3AmeCf9EXnd7VECua6rikbJSytBNUwtAF3HpdIm2N8/gOIBuBhvXHWBXzu1ZQ/
EPYYV59g+6WklEmXBa4jXzy3YDakkOUx4DjqAWuL29U7IKXkWYw6732l9L9yevpd
PwEP53YNm67u5m8bAtb4ul4rfWWNzCeZ7Z4IBdYSgujS6yka69iHD0O/sM20qOdM
XONZ2v1mR0QpgFIi7frnkocfkmOQikI3xG3KzJYVjzMqHXSqnheyqupf+3YQxYkC
l4K57DBSeg7uXjMZt7RY71yHRdRWChImYJJwm9bOItsbIZa5xSlqTr5hn7kFPzFB
47yXEgRri9X0ej8TZWalEdaQku249KrTdbTMQE1il+2B3rSr2XE=
=8hxB
-----END PGP SIGNATURE-----


O
O
Oleg Pykhalov wrote on 1 Sep 2018 18:02
(name . Leo Famulari)(address . leo@famulari.name)(address . 32598-done@debbugs.gnu.org)
87k1o59pe7.fsf@gmail.com
Hello Leo,

Thank you for review.

Leo Famulari <leo@famulari.name> writes:

Toggle quote (5 lines)
> On Fri, Aug 31, 2018 at 05:50:33AM +0300, Oleg Pykhalov wrote:
>> * gnu/packages/monitoring.scm (zabbix-agentd, zabbix-server): New variables.
>
> LGTM, thanks! Just remember to add a copyright line to the file.

OK, pushed with changes as ead46692ec8a17ed9cf668131343d7cf1b3725e5
Toggle diff (35 lines)
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 7332e6883..a59e51a5e 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -3,7 +3,8 @@
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>w
+;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -205,7 +206,6 @@ solution (client-side agent)")
(assoc-ref %build-inputs "gnutls"))
"--with-libcurl"
,flags))))
- (build-system gnu-build-system)
(inputs
`(("curl" ,curl)
("libevent" ,libevent)
@@ -215,11 +215,9 @@ solution (client-side agent)")
("net-snmp" ,net-snmp)
("curl" ,curl)
,@(package-inputs zabbix-agentd)))
- (home-page "https://www.zabbix.com/")
(synopsis "Distributed monitoring solution (server-side)")
(description "This package provides a distributed monitoring
-solution (server-side)")
- (license license:gpl2)))
+solution (server-side)")))
(define-public darkstat
(package
Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEc+OyAXw1EaDPCmAPckbhHGm3lWkFAluKuDAACgkQckbhHGm3
lWn3Wg/+JEa9G1pgqKbi/GQ7mt0YILAFTcw9oTkvAUEVzMfbCOOI7AUPawIBc+mZ
U6ZZrSWWZ4L5+NhfXMHgCtZmnMiffOmiwqSYUwjLLtVOIAZeLlQGUraRZj1fR5L0
7aivjqYLPsvk9+iLsLSFM0PYFd54feVj4aq/oPXbH9l3d2aEYbAa1EvVmpuhGlOk
aAfFhq+rs6uVoTFSV5oGfT0bjKKuAS1RbSFPZI6dHuM5ook8bQw3i5S4QBI24OKd
MpdupIf9qny7ynyqFKTzHzkGZBQSfzIYk9OptIBHV8sPP+5VcSJjbQ8ouArdR3eF
gO69Z3oeijgJ+WJJVKj0nPDp/pEmsVTEW0NCGrcwFMDUUctbdD2fUnl1v6gSgpRh
VmJM6HvII8poymOBoiaT9c2+I19G1c7AZrlkex8ynic45dQX30Ley2RTjBkmSaB6
agNAFDQFtU+LsnrlBlx+5Upk+RCHRem3+vrg/a+oNZs2CX7TgfVHlR0vnFXuIymp
MgcnwfSYui2oGjghJ0hOQsdFgoYP6pklysLYr0s6R+v5jBPN1TPDP/s+RPnzlzod
wP4PlLyBLBy8LOGMbAXsT9umM0uwTMDcUf0ABPT0TUYJVhwS4/dPlSMIoRQdpXAT
vQanxld0Z/bmwtiWRsRs3qod3qTRKhgI6eGh4+o7POI3yxwnuuc=
=yNB2
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32598@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32598
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch