[PATCH] gnu: Add r-pore.

  • Done
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • pimi
  • Ricardo Wurmus
  • Ricardo Wurmus
Owner
Somebody
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180830103703.10473-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/bioinformatics.scm (r-pore): New variable
---
gnu/packages/bioinformatics.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 22a00894c..0605e4564 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13558,3 +13558,30 @@ reference transcripts provided in a annotation file (also in GTF/GFF3 format).
(list
license:expat ;license for gffcompare
license:artistic2.0))))) ;license for gclib
+
+(define-public r-pore
+ (package
+ (name "r-pore")
+ (version "0.24")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://sourceforge.net/projects/rpore/files/"version"/poRe_"version".tar.gz"))
+ (sha256
+ (base32 "0pih9nljbv8g4x8rkk29i7aqq681b782r5s5ynp4nw9yzqnmmksv"))))
+ (properties `((upstream-name . "poRe")))
+ (build-system r-build-system)
+ (native-inputs
+ `(("r-rhdf5" ,r-rhdf5)
+ ("r-shiny" ,r-shiny)
+ ("r-svdialogs" ,r-svdialogs)
+ ("r-data-table" ,r-data-table)
+ ("r-bit64" ,r-bit64)))
+ (home-page "https://sourceforge.net/projects/rpore/files/")
+ (synopsis "This R package enable visualisation of nanopore sequencing data")
+ (description
+ "The Oxford Nanopore MinION is a revolutionary sequencer with a unique model of data
+delivery, requiring novel tools for the novice user. This package enables
+organisation and visualisation of MinION data.")
+ (license license:gpl3)))
--
2.17.1
Ricardo Wurmus wrote 7 years ago
(address . MadalinIonel.Patrascu@mdc-berlin.de)(address . 32587@debbugs.gnu.org)
idjpnxu38sq.fsf@bimsb-sys02.mdc-berlin.net
Hi,

thanks for the patch!

Toggle quote (11 lines)
> +
> +(define-public r-pore
> + (package
> + (name "r-pore")
> + (version "0.24")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://sourceforge.net/projects/rpore/files/"version"/poRe_"version".tar.gz"))

Please use mirror://sourceforge/ here.

Toggle quote (11 lines)
> + (sha256
> + (base32 "0pih9nljbv8g4x8rkk29i7aqq681b782r5s5ynp4nw9yzqnmmksv"))))
> + (properties `((upstream-name . "poRe")))
> + (build-system r-build-system)
> + (native-inputs
> + `(("r-rhdf5" ,r-rhdf5)
> + ("r-shiny" ,r-shiny)
> + ("r-svdialogs" ,r-svdialogs)
> + ("r-data-table" ,r-data-table)
> + ("r-bit64" ,r-bit64)))

Are you sure these should be native-inputs? They probably should be
propagated inputs, because they should be installed together with the
“r-pore” package.

Please also sort these inputs alphabetically.

Toggle quote (2 lines)
Toggle quote (2 lines)
> + (synopsis "This R package enable visualisation of nanopore sequencing data")

Please use “Visualize Nanopore sequencing data”.

Toggle quote (5 lines)
> + (description
> + "The Oxford Nanopore MinION is a revolutionary sequencer with a unique model of data
> +delivery, requiring novel tools for the novice user. This package enables
> +organisation and visualisation of MinION data.")

Please try to avoid marketing terms such as “revolutionary”, “unique”,
“novel” etc. Could you try to come up with a description that better
describes the features of the poRe package?

Here’s a draft:

This package provides graphical user interfaces to organize and
visualize Nanopore sequencing data.

Toggle quote (2 lines)
> + (license license:gpl3)))

I don’t think this is correct. The DESCRIPTION file says “BSD”, but
fails to state the variant. I have opened an issue about this here:


Could you please send an updated patch?

--
Ricardo
pimi wrote 7 years ago
(address . 32587@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180911145432.3477-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/bioinformatics.scm (r-pore): New variable.
---
gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f6410c3ca..49ed19535 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13699,3 +13699,31 @@ are highly customizable. Currently, it is possible to plot: bigwig, bed (many
options), bedgraph, links (represented as arcs), and Hi-C matrices.
pyGenomeTracks can make plots with or without Hi-C data.")
(license license:gpl3+)))
+
+(define-public r-pore
+ (package
+ (name "r-pore")
+ (version "0.24")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "mirror://sourceforge/projects/rpore/files/"version"/poRe_"version".tar.gz"))
+ (sha256
+ (base32 "0pih9nljbv8g4x8rkk29i7aqq681b782r5s5ynp4nw9yzqnmmksv"))))
+ (properties `((upstream-name . "poRe")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bit64" ,r-bit64)
+ ("r-data-table" ,r-data-table)
+ ("r-rhdf5" ,r-rhdf5)
+ ("r-shiny" ,r-shiny)
+ ("r-svdialogs" ,r-svdialogs)))
+ (home-page "https://sourceforge.net/projects/rpore")
+ (synopsis "Visualize Nanopore sequencing data")
+ (description
+ "This package provides graphical user interfaces to organize and visualize Nanopore
+sequencing data.")
+ ;;license unclear https://github.com/mw55309/poRe_docs/issues/10
+ (license license:bsd-3)))
--
2.17.1
Ricardo Wurmus wrote 6 years ago
control message for bug #32587
(address . control@debbugs.gnu.org)
165d3e227e9.630907442054671123.2886074654087780988@zoho.com
owner 32587 !
Ludovic Courtès wrote 6 years ago
Re: [bug#32587] [PATCH] gnu: Add r-pore.
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32587-done@debbugs.gnu.org)
87worf11bf.fsf@gnu.org
Hello,

pimi <madalinionel.patrascu@mdc-berlin.de> skribis:

Toggle quote (2 lines)
> gnu/packages/bioinformatics.scm (r-pore): New variable.

[...]

Toggle quote (3 lines)
> + (string-append
> + "mirror://sourceforge/projects/rpore/files/"version"/poRe_"version".tar.gz"))

I fixed the URL, clarified the comment about the license, and committed.

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32587@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32587
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help